Redmi 3pro Microphone Problem In Calls

Discussion in 'Xiaomi Redmi 3 / Pro' started by Illumino, Dec 4, 2016.

  1. Illumino

    IlluminoMembers

    Jun 20, 2016
    172
    55
    38
    Male
    Austria
    Hi. Ever since i bought my redmi 3 pro i have a microphone problem. It's not ROM related as i had it on global rom and on every xiaomi eu release up to 6.12.1.

    When i call someone or get a call after a few seconds nobody can here me. Searching the web it seems to be caused by a bug in noise canceling. I couldn't find a software fix that works yet and the only workaround is to put a finger on the top microphone (next to the IR blaster).
    Does anyone have a solution for this issue?
    greetz and thank you.
     
  2. bassdoew

    bassdoewMembers

    Dec 6, 2016
    1
    0
    11
    Male
    Hey,
    I have exactly the same issue. I thought it was due to hardware, but since you got the same problem it will be software probably.
    Anyone got the solution? I can't find any for the Redmi 3 on the internet....
     
  3. Stormbringer81

    Dec 11, 2016
    3
    0
    11
    Male
    Hi everyone,
    Try to add this parameters into end of the build.prop:

    ro.qc.sdk.audio.ssr=false
    ro.qc.sdk.audio.fluencetype=fluence
    persist.audio.fluence.mode=endfire
    persist.audio.handset.mic=digital
    persist.audio.voice.clarity=ON
    persist.audio.handset_rx_type=DEFAULT
    persist.audio.fluence.voicecall=true
    persist.audio.fluence.voicerec=false
    persist.audio.fluence.speaker=false
    persist.audio.fluence.audiorec=false
    persist.audio.fluence.spk.mono=true

    If you will still have a negative result after that, then try to disable the noise canceller and dual mic configuration:

    ro.qc.sdk.audio.ssr=false
    ro.qc.sdk.audio.fluencetype=none
    persist.audio.fluence.mode=false
    persist.audio.handset.mic=analog
    #
    persist.audio.voice.clarity=ON
    persist.audio.handset_rx_type=DEFAULT
    persist.audio.fluence.voicecall=false
    persist.audio.fluence.voicerec=false
    persist.audio.fluence.speaker=false
    persist.audio.fluence.audiorec=false
    persist.audio.fluence.spk.mono=false
     
  4. Stormbringer81

    Dec 11, 2016
    3
    0
    11
    Male
    #4Stormbringer81,Dec 12, 2016
    Last edited: Dec 12, 2016
    Hi guys,
    I come back to you again with 100% working solution regarding this issue. In additional to this, it resolved my issue with not working microphone on my wired headset Panasonic RP-HJX6M.
    Just find and comment out the next rows in the build.prop:

    #persist.audio.fluence.voicecall=true
    #persist.audio.fluence.voicerec=true
    #persist.audio.fluence.speaker=true
    #persist.audio.fluence.audiorec=false
    #persist.audio.fluence.spk.mono=true

    Add the next rows at the end of the build.prop:

    persist.audio.fluence.mode=endfire
    persist.audio.handset.mic=digital
    persist.audio.voicecall.mic=0
    persist.audio.voice.clarity=none
    persist.audio.aanc.enable=false
    persist.audio.handset_rx_type=DEFAULT
    persist.audio.nsenabled=ON
    persist.speaker.prot.enable=false
    persist.audio.spkcall_2mic=OFF

    I have tested it on global developer ROM MIUI8 6.11.3. Besides that, the voice call has become much clearer than ever before.
     
  5. leganini

    leganiniMembers

    Nov 19, 2016
    3
    0
    13
    Male


    this is not solve my problem...
     
  6. Illumino

    IlluminoMembers

    Jun 20, 2016
    172
    55
    38
    Male
    Austria
    for me with the fix it works for about 1 minute but if a call takes longer the sound drops again so the others cant hear me as before.
     
  7. ThisIsMadness1

    Dec 16, 2016
    1
    0
    13
    Male
    I got the same problem with different ROMS, I have tried factory reset and flashing but the same problem continues.

    Tried to find and comment the rows in the "build.prop" but I couldn't because my cellphone isn't rooted...

    does anyone know if there are any other solutions?

    Thanks.
     
  8. Illumino

    IlluminoMembers

    Jun 20, 2016
    172
    55
    38
    Male
    Austria
    For me the only working solution is to cover the top microphone with a finger as i wrote in the entry post.
    i wonder if its possible to just disable the noise canceling mic through the build prop.
     
  9. Hamilton

    HamiltonMembers

    Jan 17, 2017
    1
    0
    11
    Male
    Try to prick the microphone hole in the botton of the device with a needle.
     

Share Our Site