Redmi Note 10 MIUI 12.5.2 There is no animation when holding in the Weather app SOLVED!


1NFERR

Members
Aug 14, 2021
33
20
You can delete the previous module and install this one. That's all.
I understood that. Can you make a twrp archive? It's just a problem, you can say, a one-time fix. So it will be easier to flash the archive once and that's it. I'm sorry for my little rudeness
 

geoorg

Members
Sep 28, 2020
1,724
297
I apologize for the repeated concern. I'm in trouble again. During a thunderstorm (my favorite weather in this application), there are no lightning. And if I hold my finger for more than 4 seconds, then I lose the sound. Can you make a magisk module for version g-12.3.5.9, please?
Not twrp?
Are you sure this version works tht way?
 

geoorg

Members
Sep 28, 2020
1,724
297
Doesn't work... What am I doing wrong? Should I try to continue installing older and older versions?
I don't think so.
If you want to keep trying though, simply replace the "system/priv-app/Weather/Weather.apk" file in the zip with your desired version and flash in magisk
 

1NFERR

Members
Aug 14, 2021
33
20
I don't think so.
If you want to keep trying though, simply replace the "system/priv-app/Weather/Weather.apk" file in the zip with your desired version and flash in magisk
Version G-12.3.5.2 is working. Here is the magisk module. I also want to say that I can't put a twrp archive - it gives an error 7. What can this be related to?
Magisk_MIUIWeather_G-12.3.5.2.zip
 
Last edited:

1NFERR

Members
Aug 14, 2021
33
20
The twrp archive you modified or the original one i sent?
I tried both the original and the modified version with a replacement for version G-12.3.5.2 - still error 7. Version twrp-3.5.1_10-Nebrassy. Mounting the system did not help.
 

Attachments

  • Screenshot_2021-08-21-08-25-59.png
    Screenshot_2021-08-21-08-25-59.png
    170.5 KB · Views: 49
  • Screenshot_2021-08-21-08-26-15.png
    Screenshot_2021-08-21-08-26-15.png
    79.1 KB · Views: 52

Poney70

Donator
Oct 3, 2019
5,500
337
@geoorg In your "updater-script", don't use run_program("/sbin/chmod", "777", "/path/to/file"); but use set_perm(0, 0, 0777, "/path/to/file"); instead. ;)
 
  • Like
Reactions: geoorg