Regarding the biggest problem with audio on most XIAOMI.EU ROMS (stable 10.3.15, 10.3.16, dev. 9.8.1, 9.8.8, 9.8.15, etc.)


Jul 27, 2019
Since many people complain about this issue in numerous threads in this forum and others, I decided to make a thread explaining the audio issues and some solutions that worked so far.​
I encountered this problem after I had flashed all of the above roms. My device came unlocked with fake Global. The first time I flashed directly through TWRP the stable version, but even after flashing China Rom trough fastboot and reflashing, the problem still persists.​
The audio problems manifest themselves more or less identically to everybody who encounters them. Some people, however, don't have any audio problems whatsoever with audio, regardless of what version of this ROM they use.​
The symptoms are as follows:​
- complete loss of audio system-wide, through all streaming apps;​
- no call audio. While some people report the other person can hear them, this was not my case. I couldn't hear the caller and she/he could not hear me;​
- While the audio bug is present, video from streaming apps is laggy.​
The most probable cause of the issue is, as far as I can tell, the Google app - the one that gives us the search widget, Google Discover, Google Assistant and so on. More precisely, I believe it has something to do with Voice match (''OK Google'') not being compatible with the current version of MIUI+SD855. Even though there is no way to make the OK Google command work (not that I know of), something happens while saying this that breaks the audio.​
I tested the hypothesis by saying either OK Google or Hey Google multiple times while having Voice Match activated. This would sometimes break the audio completely. Curiously, it didn't happen 100% of the times I tried saying it. The audio would not break by accessing Google assistant by other means, such as power button, or through the search widget. However, I cannot isolate the issue to the Speech command, since I encountered it once or twice and I could swear I hadn't tried the ''OK Google'' command. Strange indeed.​
Since I am by no means a developer, nor do i consider myself knowledgeable enough to figure out the root cause of this behaviour, I have no idea why this is present in, but is completely absent in other ROMS (though some people have, indeed, reported similar issues in LOS).​

Current fixes : I have searched the web for fixes, and, up until this point, all require some sort of compromise:​
1. Rebooting device - this is a temporary fix. The audio will most likely break within a few minutes - hours.​
2. Installing Magisk, then downloading and installing the following modules:​
- Audio Compatibility Patch - most important one;​
It will ask "do you want to skip audio_policy patching?"​
-press VOL DOWN as NO​
-select VOL UP as NEW LOGIC​
It will next ask "if you like to skip notification helper remover?"​
-select VOL DOWN as NO​
Select fix method​
it will next ask if you "would like to skip USB policy patching"​
-any option will do. up to you​
it will next ask for a lib workaround​
-select VOLUME DOWN as NO (recommended)​

- Audio Modification library - doesn't require any further steps - just install.​
- Viper4android FX - no further steps, type yes if asked for.​
Install these. Most likely, the first module will solve the problem with audio missing from YouTube, Spotify, or all other apps.​
After some weeks of usage, I can report this is, by no means, perfect. Though the issues decrease substantially, I still encountered the problem, once every few days, and had to reboot the phone to get audio again;​
3. Uninstalling the ''Google" app. I have done it through Titanium Backup app, installed via Google Play store. Open the app (requires root) and search for the ''Google" app - the package name is "". Back it up and then uninstall it. This fix is independent from the previous one, meaning it works without having any modules installed. I have not encountered any audio box since uninstalling the app. If your device isn't rooted, there are still ways to uninstall the app (via adb).​
However, this means you lose access to:​
- Google Search widget;​
- Google Assistant;​
- Google Lens;​
- Google Discover (swipe right from third party launcher to get to Google Feed).​
- Probably some other minor features.​
Credit for the third solution goes to TechExhibeo.
These are the current fixes I know of.
In the hope that people will no longer make threads regarding this issue, I suggest all other fixes we find should be posted here, so people will know where to look for.​
  • Like
Reactions: pavelcheto
U missed that actually, the india rom (out already 1 month more or less) works perfectly with no audio issue and with google assistant too. Just miss nfc cos is deactived in india for local reasons. So probably flashing new global roms, not sure if those from india or those for the new mi9t pro for europe (this one for sure will have nfc enabled cos in europe nfc is used), everything will be fixed. Sadly works only on china roms and so, no google assistant will work nor the audio will work 100% and we will miss their upgrades but for me, it's still better to have a working audio and google then some "extras". Btw I've the global rom from india from day0 installed and I confirm everything i've said.

ps.:; if u wanna try, first flash back che china rom through mi flash, for what i've read around, modify something on the boot files or around there and that will mismetch will others miui roms so, if u dont go back first to china, u may brick the phone (I've done it and can confirm it worked).

  • Like
Reactions: Adavius
I actually managed to fix it somehow i dont know how it happened but all i did is deactivate google voice detection and that stuff and after a while it started to work and most importantly i think that if you reboot it all goes to s**t


    282.7 KB · Views: 674
Last edited: