[RN8] Problems with TWRP recovery


4llerbuntu

Members
Aug 10, 2011
9
15
Change the cable , usb port maybe...


tried new cables and ports. same result

then tried this with adb:


$ df

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 4644512 3223708 1404420 70% /
tmpfs 1860356 1368 1858988 1% /dev
tmpfs 1860356 0 1860356 0% /mnt
/dev/block/mmcblk0p85 1548144 740868 790892 49% /vendor
tmpfs 1860356 0 1860356 0% /apex
none 1860356 0 1860356 0% /sys/fs/cgroup
/dev/block/mmcblk0p82 364504 2944 349764 1% /cache
/dev/block/mmcblk0p84 999320 408464 574472 42% /cust
/dev/block/mmcblk0p87 112392172 21623156 90769016 20% /data
/dev/fuse 112392172 21623156 90769016 20% /storage/emulated




can't see a mount point for recovery
 

Gecov

Members
Jan 26, 2021
1
5
Mystery solved. The issue with the TWRP on the latest ROM for ginkgo occured due to changes in the boot image. This is also the reason that flashing to a previous ROM (which would obviously write a new boot image) would automatically correct the issue. Xiaomi, in their not so infinite wisdom, saw fit to implement changes in the kernel so that the recovery would not be able to read the decryption keys, at least not without recompiling the kernel. The problem was investigated and fixed over @Xiaomi-miui.gr.

You can try flashing this TWRP: https://www.mediafire.com/file/ma34dbgir2hbnvi/twrp_ginkgo-willow_3.4A9_23-12-2020_BL.img/file

It should work for ROM 20.12.09 (and only this ROM for now).

Hi, i´m new here but i had the same problem, my phone ca'tn be decriypted also when i type adb device command, the result was offline, when i flash twrp ANY version the SDCARD was encrypted... i solved by doing the following: i downloaded my original rom from here https://bigota.d.miui.com/V12.0.3.0...M_20201226.0000.00_10.0_global_044c052090.tgz
unziped and via fastboot executed the "flash_all.bat" file, it restores my phone to the latest global version, then when it booted entered again to fastboot and typed the command "fastboot erase userdata", flash the recovery image from BANDITGR's post, then forced the phone to reboot and press volume up and the i can enter the twrp and mount storage, copy rom and magisk, format data, flash rom, flash magisk, reboot.... i waited a while (like 5 mins), and then... ALL OK YEAAHHHH!!! Thanx to all!!!
 
  • Like
Reactions: geoanto555

kubikill

Members
Jan 26, 2021
6
15
I can't decrypt data on my willow device. I've tried several recoveries from this thread as well as the latest unofficial TWRP recovery and none of them can decrypt the data. Every recovery I tried asked me for a pattern then tried decrypting the data for 5 minutes or so only to display "Pattern failed, please try again!". If I input the wrong pattern it gives me the same error instantly though. Can someone please tell me how can I fix this? I just want to want to update the system from V12.0.1.0 to V12.0.2.0.
 

geoanto555

Members
Jan 27, 2017
147
40
I can't decrypt data on my willow device. I've tried several recoveries from this thread as well as the latest unofficial TWRP recovery and none of them can decrypt the data. Every recovery I tried asked me for a pattern then tried decrypting the data for 5 minutes or so only to display "Pattern failed, please try again!". If I input the wrong pattern it gives me the same error instantly though. Can someone please tell me how can I fix this? I just want to want to update the system from V12.0.1.0 to V12.0.2.0.
Change pattern to pin or remove all and try.
If decryption works add again the pattern.
 

kubikill

Members
Jan 26, 2021
6
15
Change pattern to pin or remove all and try.
If decryption works add again the pattern.

Changed pattern to pin and it doesn't work, it still tries to decrypt for about 5 minutes and then fails.
Tried removing both pattern and pin too and the recovery still asks me for a password to decrypt.
 

kubikill

Members
Jan 26, 2021
6
15
i think only the format data is the solution.

I did that and now it works! At first trying to format data would throw a "unable to format to remove encryption" error so I rebooted to fastboot and used "fastboot format userdata" instead. Then I tried format data again from recovery and it worked. After that I used "adb push" to put the V12.0.2.0 zip on /sdcard and flashed the new system from there. Once I was done setting up the system I rebooted into recovery to check if it can decrypt properly now and it works! Thank you for all the help!
 

brunomalone

Members
Feb 5, 2020
3
13
Mystery solved. The issue with the TWRP on the latest ROM for ginkgo occured due to changes in the boot image. This is also the reason that flashing to a previous ROM (which would obviously write a new boot image) would automatically correct the issue. Xiaomi, in their not so infinite wisdom, saw fit to implement changes in the kernel so that the recovery would not be able to read the decryption keys, at least not without recompiling the kernel. The problem was investigated and fixed over @Xiaomi-miui.gr.

You can try flashing this TWRP: https://www.mediafire.com/file/ma34dbgir2hbnvi/twrp_ginkgo-willow_3.4A9_23-12-2020_BL.img/file

It should work for ROM 20.12.09 (and only this ROM for now).
Thank you, thank you, thank you! And thank the greeks!
 

GreekManiac6923

Members
May 8, 2021
1
3
Mystery solved. The issue with the TWRP on the latest ROM for ginkgo occured due to changes in the boot image. This is also the reason that flashing to a previous ROM (which would obviously write a new boot image) would automatically correct the issue. Xiaomi, in their not so infinite wisdom, saw fit to implement changes in the kernel so that the recovery would not be able to read the decryption keys, at least not without recompiling the kernel. The problem was investigated and fixed over @Xiaomi-miui.gr.

You can try flashing this TWRP: https://www.mediafire.com/file/ma34dbgir2hbnvi/twrp_ginkgo-willow_3.4A9_23-12-2020_BL.img/file

It should work for ROM 20.12.09 (and only this ROM for now).
Aderfaki me eswses, gamise to design tis recovery kai goustarw pou vriskw lisi sto problima pou exw apo ellines
Wraios..
 

Vyto-Khron

Members
Dec 13, 2020
18
15
Hey there, reviving this thread to ask if anyone had issues with Magisk v22 installation/update?
 

OsZero

Members
May 10, 2021
4
13
Hello everybody.

Someone solved the problem in RM8 ginkgo MIUI 12.0.4 stable, I already tried everything and the folders are still encrypted and it won't let me install magisk.

Please help me with a tip.
 

dexterv

Members
Jul 22, 2020
651
102
Hello everybody.

Someone solved the problem in RM8 ginkgo MIUI 12.0.4 stable, I already tried everything and the folders are still encrypted and it won't let me install magisk.

Please help me with a tip.
Did you install the TWRP from geoanto555?
 

OsZero

Members
May 10, 2021
4
13
[QUOTE = "dexterv, publicación: 606863, miembro: 268597"]
¿Instalaste el TWRP desde geoanto555?
[/CITA]

Yes, I did, and I bricked my phone. Do you know if installing another ROM would fix the problem?
 
Last edited:

dexterv

Members
Jul 22, 2020
651
102
[QUOTE = "dexterv, publicación: 606863, miembro: 268597"]
¿Instalaste el TWRP desde geoanto555?
[/CITA]

Yes, I did, and I bricked my phone. Do you know if installing another ROM would fix the problem?
Well, I am not sure what the issue is exactly, you are missing a lot of information. What exactly happened, logs, steps, versions from and to and so on. All I know I've been using it for months on the latest weeklies since they changed the encryption without issues.