Resolved Search Bar issue

Discussion in 'Bugs' started by lukeaton, Jul 5, 2012.

Thread Status:
Not open for further replies.
  1. lukeaton

    lukeatonMembers

    Nov 27, 2010
    18
    0
    11
    Running Miui 2.6.29
    Samsung Galaxy S2
    Full wipe and also upgrade.

    My issue is as follows:
    When I enter a search into the search widget (bar) it opens up default browser(Baidu I believe?) It then takes me to the Chinese results.
    There is no way for me to change the default to Chrome browser, or any other browser. This is very frustrating as I find the default browser intolerable.

    This issue is also present on 2.6.22.

    I tried a fix that was posted for a similar, yet not exact same issue posted here.. http://miuiandroid.com/community/threads/searching-in-browser-sends-me-to-google-homepage.16886/ however this almost bricked my phone. After flashing this fix, my screen went into a colour negative style.(As in an actual colour film negative) Then became un-responsive. I had to do a full wipe and re-flash ROM. (Not saying there is anything wrong with that gentleman's fix. Just warning others if they have the same issue, to not apply that fix.)

    All and any help would be appreciated.
    cheers
     
  2. bitti09

    bitti09Members

    Jun 23, 2012
    43
    5
    18
    Male
    What fix do you mean? my xml fix or the file from boxcarracer81?

    If you mean the second it could be possible that the file in the fix is too old for your rom ( it was for version 2.6.8 )
     
  3. boxcarracer81

    Mar 20, 2012
    551
    63
    75
    Male
    the Netherlands
    It was not my fix, just reposted it in that thread. ;)

    That fix still works for me on the latest rom, both the multi and non multi rom. :)
     
  4. lukeaton

    lukeatonMembers

    Nov 27, 2010
    18
    0
    11
    Yeah, nothing wrong with your fixes guys. Just doesn't work with that particular issue.

    To the devs. This issue is still persisting in 2.7.6.

    To get rid of the default browser, is it a matter of deleting the default browser apk and replacing with your one of choice?

    Sent from my GT-I9100 using Tapatalk 2
     
  5. iBotPeaches

    iBotPeachesScript Gatekeeper

    Oct 31, 2011
    3,811
    1,121
    335
    Kansas
    apktool keeps re-messing up the XML. Since I actually make apktool now, I'll work on fixing the issue at the source. It must be double escaping & into & over and over. I'll check if its already escaped to leave it untouched.
     
  6. lukeaton

    lukeatonMembers

    Nov 27, 2010
    18
    0
    11
    Lovely. Thank you peaches.

    Sent from my GT-I9100 using Tapatalk 2
     
  7. lukeaton

    lukeatonMembers

    Nov 27, 2010
    18
    0
    11
    Bump. Just updated to 2.7.13.
    This issue is still present.
    Driving me bonkers.

    Can I unzip Rom, replace default browser apk with chrome. Rezip, reflash? Is it that simple?

    Sent from my GT-I9100 using Tapatalk 2
     
  8. iBotPeaches

    iBotPeachesScript Gatekeeper

    Oct 31, 2011
    3,811
    1,121
    335
    Kansas
    I fixed this in MULTI ROM. It'll be in next week. 100% fixed.
     
    lukeaton likes this.
  9. lukeaton

    lukeatonMembers

    Nov 27, 2010
    18
    0
    11
    oh ok. I never use the multi rom. Cheers thanks iBot.
     
  10. lukeaton

    lukeatonMembers

    Nov 27, 2010
    18
    0
    11
    Should i do a complete wipe when installing 2.7.20 to help with this?
    Or will it not matter? Can i just wipe dalvick etc and flash.
     
  11. iBotPeaches

    iBotPeachesScript Gatekeeper

    Oct 31, 2011
    3,811
    1,121
    335
    Kansas
    If your already on MIUI, just wipe /dalvik and /cache.
     

Share Our Site