[SOLVED] Building CM-10.2 but mic not working


Dec 24, 2013
31
13
18
#1
I am trying to build CM-10.2 with @M1cha kernel, using this local manifest.xml:
Code:
<?xml version="1.0" encoding="UTF-8"?>
<manifest>
  <project name="M1cha/android_device_xiaomi_aries" path="device/xiaomi/aries" remote="github" revision="cm-10.2" />
  <project name="M1cha/android_kernel_xiaomi_aries" path="kernel/xiaomi/aries" remote="github" revision="cm-10.2" />
  <project name="M1cha/proprietary_vendor_xiaomi" path="vendor/xiaomi" remote="github" revision="cm-10.2" />
</manifest>
I have not change any code, build successful, but after installing the ROM, the mic is not working at all, that is no sound, but other thing work well.

My building step:
Code:
$ repo sync
$ cd vendor/cm
$ ./get-prebuilts
$ cd ../..
$ source build/envsetup.sh
$ breakfast aries
$ export USE_CCACHE=1
$ brunch aries
What am I missing ? :(
( Sorry for my bad english )
 

M1cha

Members
May 29, 2011
1,747
2,839
297
#2
you forgot these lines in manifest:
<remove-project path="hardware/qcom/audio-caf" name="CyanogenMod/android_hardware_qcom_audio-caf" />
<project path="hardware/qcom/audio-caf" name="M1cha/android_hardware_qcom_audio-caf" groups="qcom" remote="github" />
 

M1cha

Members
May 29, 2011
1,747
2,839
297
#6
cm10.2 still ist the most stable rom and kitkat reducec battery life(on all devices as far as I read on google)
But I'm already too much used to kk to switch back :D

and if u develope as much as I do u don't even need 1h of battery life :D