"This app is incompatible with your device"


Mar 27, 2014
25
0
11
#3
Thanks Richard.

Am already on MIUI 4.3.28 version - which I had downloaded from this site. Do you suggest that I upgrade to 4.4.27 to make it work?