In Progress Whatsapp notification tone


Jun 22, 2012
6
0
11
#1
I cant seem to change the Whatsapp tone, initially it was set to a default one which rings for about 5 seconds and now there is just vibration. When I click to change tone within the app, it brings up the Theme menu instead of ringtones.. I'm sure this is a bug. I try to change the tone from this menu but it doesnt work. I am running RD MIUI for HTC One X.

Does anyone have a fix for this? Many thanks

(I posted this in the One X section too, but maybe its more suited for the bugs section)
 
Jun 22, 2012
6
0
11
#3
I am downloading the new release now so will test it with that one too! Thanks for the quick response Peaches, will report back later :)
 
Jun 22, 2012
6
0
11
#4
Ok just tested it on the latest Miui version 2.6.22 and can confirm the bug still exists here. When you go into Whatsapp settings>notification tone> .. it just brings up the theme menu.
 
Mar 20, 2012
551
63
75
#7
The workaround is this: Whatsapp uses the default notification tone set in Miui settings. Just select the tone you want, set it as default notification and that should work.
 
Jun 22, 2012
6
0
11
#8
The workaround is this: Whatsapp uses the default notification tone set in Miui settings. Just select the tone you want, set it as default notification and that should work.
Already tried this mate, it doesn't work. There are no tones now, just vibration. Sometimes there is a tone but its an annoying default one that lasts for 5-6 seconds. I can't even find this tone in the list of the sound files.
 
Jun 25, 2012
4
0
11
#9
The workaround is this: Whatsapp uses the default notification tone set in Miui settings. Just select the tone you want, set it as default notification and that should work.
no, i can't do that, there are 2 types of tone in whatsapp: group and personal, group chat is not so important so i set it to short tone, for personal i set it to normal tone. it is impossible.
Already tried this mate, it doesn't work. There are no tones now, just vibration. Sometimes there is a tone but its an annoying default one that lasts for 5-6 seconds. I can't even find this tone in the list of the sound files.
this is work for me but i dont like it, are you using titanium backup to restore the apps? if yes then try to celar data from "Managed Apps" menu then re do the registration etc..