Whatsapp Notifications Don't Arrive When Phone Is Locked More Than 20 Min.

Discussion in 'Xiaomi Redmi Note 3 / Pro' started by UnknownAX, Dec 14, 2015.

  1. UnknownAX

    UnknownAXMembers

    Dec 13, 2015
    20
    10
    15
    Male
    Hello,

    I've done several tests on the ROM 7.0.7.0 and 7.0.16.0 with the same result, after a while (20 min aprox) push notifications do not reach till you unlock the phone and enter tothe application.

    I have tried:

    Whatsapp and all the google apps have autostar permission.
    Whatsapp is locked in memory, with the padlock.
    On data usage stats Whatsapp have all enable: data, wlan, background data.
    On restrict data usage enable: data, wlan.
    On cleaner disable: clean automatically, memory clean up.
    I have created a new battery profile with clean memory to never and networks on.
    On installed apps whatsapp have all enable: allow notifications, priority...On manage apps battery disable the options and also try leave enable and uncheck watsapp of the list of apps to restrict

    I don't know what is wrong but is annoying, there is something that kill the process or the data background after some time.

    If you lock the phone it recives push notifications during a time...then nothing, you unlock, on recent apps is the whatsapp icon with the padlock, press on the icon, whatsapps open and after a second you receive all the lost mesages.
     
    pramod likes this.
  2. pramod

    pramodMembers

    Jul 11, 2014
    159
    12
    28
    Male
    Empoyed
    Singapore, Jakarta, Kolkata
    How to fix it

    Sent from my Redmi Note 3 using Tapatalk
     
  3. UnknownAX

    UnknownAXMembers

    Dec 13, 2015
    20
    10
    15
    Male
    That's what I am looking for a Fix for this problem

    Are you facing this same problem ?
     
  4. Vin87

    Vin87Members

    Dec 12, 2015
    16
    3
    13
    Male
    I do not face this problem at all (running the old 7.0.7.0) I've tested it with Whatsapp this morning after 30 minutes. Notifications arrive just fine :) I did:
    -Autostart Whatsapp
    -Lock Whatsapp on recents screen
    -Disable battery usage limitation for Whatsapp
     
  5. UnknownAX

    UnknownAXMembers

    Dec 13, 2015
    20
    10
    15
    Male
    How to Disable battery usage limitation for Whatsapp ?
     
  6. Vin87

    Vin87Members

    Dec 12, 2015
    16
    3
    13
    Male
    Settings > Additional settings > Battery & Performance > Manage apps battery usage > Choose apps to restrics > Uncheck Whatsapp
     
  7. UnknownAX

    UnknownAXMembers

    Dec 13, 2015
    20
    10
    15
    Male
    Have already done that
     
  8. canijito

    canijitoMembers

    Sep 27, 2015
    46
    4
    20
    Male
    the same happens to me
     
  9. revanth

    revanthMembers

    Jul 28, 2016
    19
    2
    13
    Male
    This video helped me hope it is useful for you

     
  10. Pilsor

    PilsorMembers

    Apr 17, 2016
    6
    1
    15
    Male
    and also this one:
    Apps/security/permissions/autostart ... enable whatsapp

    #succes
     

Share Our Site