Xiaomi 13 Ultra problem with NFC Google Pay


frankgout

Members
Apr 25, 2024
6
3
have phone with Hyper OS, 1.0.6.0.UMACNXM installed, NFC was working fine now I get the message "your device doesn't meet security standards to make contactless payments"

any sugestios in changing settinges to make t work again?

RGDS, Frank
 
I have recently acquired a Xiaomi 13 with OS 1.0.4.0.UMCMIXM and have the same problem when I try to configure my credit card for contactless payment with Google pay.
I have tried to install the Gooble Pay fix mentioned above, (XiaomiEUModule_2024.05.22.apk) but the problem remains.
Any clue on what else can I do?
 
You don't have xiaomi.eu ROM but Global ROM. If your device is a Chinese version, it is clear that GPay cannot work for you because you have an unlocked bootloader. This FIX only works on xiaomi.eu ROM.
 
You don't have xiaomi.eu ROM but Global ROM. If your device is a Chinese version, it is clear that GPay cannot work for you because you have an unlocked bootloader. This FIX only works on xiaomi.eu ROM.
Thank for your quick reply.
How could I change to xiaomi.eu ROM?
 
 
well, my xiaomi account is just new and the procedure referred above requires an account older than 30 days. How do I do to Unlock the bootloader?
 
If your device is a CN version and you have a Global ROM installed, it is likely that the bootloader is already unlocked.

To check the status of the bootloader, you can enter this fastboot command:
Code:
fastboot getvar all
 
Sorry to bother you again but I don't know how to do so...
However I can see a padlock open at the top of the screen when I start the device (in normal mode). Might this mean that the bootloader is unlocked?

When in Fastboot mode, when I run windows_fastboot_first_install_with_data_format.bat a window appears with following text:

Waiting for device...
Compatible devices: veux, peux
Your device: fuxi
Press a key to continue . . .

Then, when I press a key, this window disappears and nothing else happens.
 
Well, finally I succeded with the Xiaomi.eu ROM.
Now the OS version is 1.0.8.0UMCCNXM.
However I still have the same problem with Google Pay.
The bootloader seems still unlocked (open padlock when booting)
I have NFC activated and run option "NFC funtionality recovery"
What is next now?
 
Super!
Many , many thanks!
Now I could configure my cards in Google Pay.
Later on todat I will test it in a store.

I see that the padlock remains open when booting.
Does this means that the bootloader is still unblocked?
May it be a security issue?
 
Of course, you can't lock the bootloader with a custom ROM, or a ROM not matching your phone origin (China / Global)
 
And what would happen if I do a factory recovery? would the new EU ROM be kept or the original one (global) will be recovered?
 
OMG. When I run the factory reset the phone boots with Orangefox Recovery and data and applications are kept. How to remove this OrangeFos stuff????
 
If your device is Xiaomi 13 (fuxi), I don't understand why you have OrangeFox recovery.
Install this TWRP recovery: twrp-3.7.1_12-v8.6_A14-fuxi-skkk.img

After installing TWRP, do "Format Data". This will factory reset the device and format the data partition..
 

Attachments

  • Format_Data.png
    Format_Data.png
    79.3 KB · Views: 5
It's in the ROM installation guide.
Or you use these fastboot commands.
Code:
fastboot flash recovery_ab filename.img
fastboot reboot recovery
 
Ashamed but not familiar with the tools.
I'm afraid of bricking the device if I do something wrong.
I would absolutely appreciate if you could help me through the steps either using the ROM installation or the fastboot commands.
 
Let me see if I understand how to use the fastboot commands:

1.- Reboot the Xiaomi phone to fastboot mode (press volume down + power)
2- open the windows cmd window and promt to the folder where the twrp-3.7.1_12-v8.6_A14-fuxi-skkk.img file is stored.
3.- write in the command prompt:
>fastboot flash recovery_ab twrp-3.7.1_12-v8.6_A14-fuxi-skkk.img
- what response shall I expect now?
4.- write in the command prompt:
>fastboot reboot recovery
- what response shall I expect now?
5.- Follow the procedure after installing TWR as explained in your post on Tuesday 10:40 AM

Is that correct?