Xiaomi.eu 8.3|7.2.16|weekly Fastboot & Recovery Mode Problem


Feb 21, 2016
49
4
18
#1
I am facing camera issues on 7.2.16.So as always i tried to access twrp via updater app to change the rom.But instead of going to recovery mode,phone only switched off.So tried to access recovery mode manually but nothing happened. I thought may be this rom doesn't come with any twrp.so i tried to install twrp via fastboot.But if i press power+vol - only fastboot logo appears and nothing happens afterwards.If i leave that in that situation, phone gets switched off.What should i do now?
 
Dec 21, 2016
67
30
30
#4
TWRP libra 7.0 is the one we are talking about version 3.0.3.0. What confuses me is the "fastboot menu".
fastboot doesn't have a menu.. recovery has only. fastboot is just the Mi bunny logo.

You can enter fastboot by pressing Power + Vol Down, then connect the phone to a PC and via cmd you flash the recovery.

 
Dec 21, 2016
67
30
30
#6
This is the fastboot logo as said.

Install Mi PC Suite (or MiFlash can't remember which program is actually) and that one will install the adb drivers and fastboot on your pc needed to access your phone via fastboot.
After that you can re flash the current twrp and i believe your problem will be fixed.
 
Likes: imontop
Dec 21, 2016
67
30
30
#8
no need to connect your phone to PC Suite...
now if you open a cmd while your phone is connected to pc and type fastboot devices your mi4c will show up. (you got to have the phone in fastboot mode first of course).

Sent from my Mi-4c using Tapatalk
 
Jun 16, 2016
14
2
15
#9
tried to flash 7.3.9. over 6.12.22 on twrp 3, i did all the wipes, flashed the 7.3.9 and something went wrong (there was an error). tried to restore the previous working version and although the message was a success, when i rebooted the phone is stuck on mi screen for like 10 seconds and then shuts down. i can acess fastboot mode but miflash doesn't recognize it. what has happened? what can i do ? did the bootloader lock even if the update failed ?
 
Dec 21, 2016
67
30
30
#10
First of all do you know what that error was? Did you take a notice of it?
Secondly boot into fastboot and check your bootloader with "fastboot oem device-info"
And lasty twrp 3 is too general... because twrp 3.0.2 is for Android 5.1 (6.12.22) and twrp 3.0.3 is for Android 7.0 (7.3.9), so which one did you use? If you can boot into recovery (Power + Volume Up) you can see there the version of twrp.
 
Jun 16, 2016
14
2
15
#11
First of all do you know what that error was? Did you take a notice of it?
Secondly boot into fastboot and check your bootloader with "fastboot oem device-info"
And lasty twrp 3 is too general... because twrp 3.0.2 is for Android 5.1 (6.12.22) and twrp 3.0.3 is for Android 7.0 (7.3.9), so which one did you use? If you can boot into recovery (Power + Volume Up) you can see there the version of twrp.
i can't boot into recovery to check it... i checked fastboot oem device-info in fastboot and got the following: device tampered: false, device unlocked: false, device critical unlocked: false, charger screen enabled: true
 
Dec 21, 2016
67
30
30
#12
You need to Unlock your bootloader first.

After you unlock download https://www.androidfilehost.com/?fid=457095661767135741
Unzip it in a folder and there press Shift + Right Click > Open command window here.
From there run:
fastboot flash recovery twrp.img
fastboot boot twrp.img

PS: Next time please open another thread for your situation because this thread is another's users with different problem.
 
Feb 21, 2016
49
4
18
#13
Seems like my bootloader is locked.when try to install twrp in fastboot mode, it says you need to unlock your phone first.I have already submitted a request to unlock my bootloader.But how ami supposed to know if they have unlocked or revoked?
 
Feb 21, 2016
49
4
18
#15
Likes: shadowerwtas
Feb 21, 2016
49
4
18
#16
Hey bro,I have a new problem.when i installed twrp it ran just fine.but after installing a rom when i reboot to system it comes o twrp again.It seems like aforever loop ,every time i reboot it comes back to twrp.It happens to every rom
 
Mar 17, 2017
2
2
5
#17
Hey bro,I have a new problem.when i installed twrp it ran just fine.but after installing a rom when i reboot to system it comes o twrp again.It seems like aforever loop ,every time i reboot it comes back to twrp.It happens to every rom
I had same problem when I installed nougat. You must power off phone and then power on again. I pressed power button for 5-6 second and the phone power off.
 
Likes: shadowerwtas