Answering a call, caller can't hear me first time


Jan 10, 2013
18
0
11
#1
I have been using version 3.1.11 on Huawei Ascend P1 and I am having this issue 80% of the time. When I answer a call caller can't hear me, I can hear them fine. They, or I have to hang up and when the caller calls again, usually after 10-20 seconds, everything works fine, we can hear each other. Also tried MIUI version 2.12.28, with same problem.
Needless to say, it's driving me nuts.
Tried going back to stock ROM and no problem ever.
Anyone has any idea why this is happening?

Thanks.
 
Jan 10, 2013
18
0
11
#4
If you disable filter calls through the blacklist that delay goes away

Sent from my MI 2 using Tapatalk 2
I did think that may have been the cause and I tried it but it did not change anything. This is not the case of delay. On first call, if I answer after one or two rings caller cannot hear me. Period. However, I did try another scenario: If I let it ring 4-5 times before answering then it would be OK. But that's an unacceptable workaround.

Any further suggestion is appreciated. Thank you.
 
Jan 10, 2013
18
0
11
#5
If you disable filter calls through the blacklist that delay goes away

Sent from my MI 2 using Tapatalk 2
Since this didn't work either I tried disabling(freezing) Guard app. Nope, didn't work.
I finally solved it with the help from Tasker. Set the task on "incoming call" phone state to kill Guard.

It worked!
No more temptation to smash the phone every time I answered a call :D