Apr 10, 2023
Yo guys, I have a feeling about this, but TWRP Can't. Be. Installed. On. My. Redmi 10? Because I said so.
So, I wanted to install TWRP, but there was a problem. See, I tried tens of hundreds of videos, but to no avail.

Tried commands like:

fastboot boot recovery.img
fastboot flash recovery recovery.img
And, fastboot flast boot recovery.img.

All of them do not work.

The first one said FAILED (status read failed (Too many links)).
The second one said FAILED (remote: This partition doesn't exist)
And the third one, just bootloops.

I wanted to install unofficial TWRP recovery (3.6.1) for Redmi 10 (selene).

The original Mi Recovery 5.0 still works just fine. It's still there.

With that out the way, do some of you have a fix for these issues? Looking foward.
Here is XDA post: https://forum.xda-developers.com/t/...elene-how-do-i-do-that.4576331/#post-88422807


XM12 Tester
Apr 22, 2021
This forum does not support devices with MediaTek Helio chipset.
I suggest you forget about TWRP. For devices with a MediaTek Helio CPU, there is a high risk of killing the phone.
  • Wow
Reactions: pitileteharpalete