[fix] Can't Upgrade To Latest Xiaomi.eu Dev Roms (7.9.21, 7.10.12 & Up)


Sep 15, 2017
1,064
687
222
#1
It seems that many Kenzo users having problem upgrading to some last Xiaomi.eu Dev ROMs (7.9.21, 7.10.12 & 7.10.19), turned out this has something to do with file 'emmc_appsboot.mbn' (confirmed, flashing this file fix this problem, but please read the post and guide carefully).

Updated : started with dev rom 7.10.26, EU rom included the emmc file back in the rom, so there is no need to flash the emmc file separately, if bootloop happens after upgrade all you need to do is use Mi Flash Unlock to re unlock your bootloader.

A little history..
Xiaomi.eu ROM Creators started removing this file from their Kenzo Dev ROM since 6.11.17 to protect people who unlocked their Bootloader UN-OFFICIALLY from getting bootloop (Xiaomi changed something related to bootloader that resulted in people with UnOfficial BL get bootloop if they flash that ROM, then since Dev ROM 7.3.16 Kenzo-ers started to having the 'reboot to recovery' bug, then started with 7.9.21, many Kenzo-ers (those has been using xiaomi.eu for quite some time, their 'emmc_appsboot.mbn' is old) started to get bootloop if they flash the ROM).

(all this also happened to Redmi Note 3 Special Edition / KATE, Redmi 3 / IDO & Redmi 3s / LAND, so the same procedure can also be applied to KATE & IDO).

To fix this problem (and also the reboot to recovery bug), all you need is update the 'emmc_appsboot.mbn' file, you only need to do this once.

WARNING (really important) :
1. This is for OFFICIALLY UNLOCKED BOOTLOADER ONLY.
2. MAKE SURE your device is USING the SAME Mi Account you used to unlocked the bootloader.
3. Turn on USB Debugging & OEM Unlocking in the Developer Options.
4. Make sure your bootloader is still unlock (Fastboot mode, type 'fastboot oem device-info').
5. After flashing this file, some people had their bootloader re-locked and bootloop (it was smooth for me, not re-locked bootloader or bootloop), fortunatelly once you unlocked the bootloader officially, you can use Mi Unlock tool to unlock it again without asking for permission.

6. Backup important data on your phone to SD Card or PC ... better safe than sorry, right?).


Read here for details on how to update the 'emmc_appsboot.mbn' : https://xiaomi.eu/community/threads/solved-cant-reboot-to-recovery-from-os.41559/#post-387445.

Confirmation from people who fixed the problem on Kenzo :
https://xiaomi.eu/community/threads/7-10-19.41961/page-18#post-391704

https://xiaomi.eu/community/threads/7-10-19.41961/page-14#post-391473
https://xiaomi.eu/community/threads/7-10-12-13-14.41877/page-30#post-390851
https://xiaomi.eu/community/threads/7-10-12-13-14.41877/page-28#post-390764

Note :
*) It turned out that this problem also happened to Mi4c & Mi4s users (Xiaomi.eu ROM Creators started removing the 'emmc_appsboot.mbn' file from their Dev ROM since 7.7.13, and Xiaomi changed something related to bootloader with dev ROM 7.9.21), so the same procedure also works for Mi4c & Mi4s, just use the 'emmc_appsboot.mbn' file from the official MIUI China Developer ROM for Mi4c & Mi4s or you can use the one I provided in that thread.

Confirmation from people who fixed the problem on Mi4c :
https://xiaomi.eu/community/threads/7-10-19.41961/page-6#post-391201

https://xiaomi.eu/community/threads/7-10-19.41961/page-11#post-391364

Read here for details on how to update the 'emmc_appsboot.mbn' : https://xiaomi.eu/community/threads/solved-cant-reboot-to-recovery-from-os.41559/#post-387445.
 
Last edited:
Sep 10, 2017
3
0
1
#4
Nope, all these were true, and Xiaomi.eu rom started to include the emmc file again since 7.10.26, that's why they included warning at the 1st post (you can download eu rom 7.10.12 and see for yourself there is no emmc file.
oh i see but you must address that in your post now , thank you for the quick reply .
 
Jul 6, 2015
20
1
15
#6
Hello
I have the same issue with Hennessy, should I follow the same procedure in order to get OTA update of the recent ROM ?

Thanks for your answer

Edit: it's the MTK version

Envoyé de mon MI NOTE LTE en utilisant Tapatalk