GPS lost signal

Discussion in 'Xiaomi Mi 2 / Mi 2S' started by MARCELO KLEINKE, May 22, 2014.

  1. MARCELO KLEINKE

    Mar 5, 2014
    7
    1
    23
    Male
    Curitiba, Brazil
    I have bought a MI2S and I have many problem with GPS lost signal. It seems that the GPS sign is weak inside the phone. I have compared with another MI2S and the difference is very big. i tested them outside any buildings and clear sky.
    Is there an internal antenna in the MI2S? Maybe this internal antenna is discnonnect?
    I have tested with many softwares as GPSfix and it showed very low signal, few satelites.

    all GPS programs as WAZE, Google MAPS, IGO, works the same.
    It keeping loosing the signal many times in few minutes.

    Any help?

    tks
     
  2. davfiala

    davfialaMembers

    Aug 20, 2013
    550
    199
    80
    Male
    Land Rover addict
    Czech Republic
    What version of MIUI?
     
  3. davfiala

    davfialaMembers

    Aug 20, 2013
    550
    199
    80
    Male
    Land Rover addict
    Czech Republic
    Try to downgrade to 4.1.10 with full wipe. I also had problems with GPS on latest builds.
     
  4. spacefabio

    spacefabioMembers

    Mar 12, 2014
    3
    0
    11
    Male
    Hello Marcelo,
    I got this problem when I changed the original battery cover with a metallic one[​IMG]

    coming back to the original cover did solve the problem for me
     
  5. MARCELO KLEINKE

    Mar 5, 2014
    7
    1
    23
    Male
    Curitiba, Brazil
    My battery cover is original (plastic)
     
  6. MARCELO KLEINKE

    Mar 5, 2014
    7
    1
    23
    Male
    Curitiba, Brazil
    You all can see that, the signal of the GPS is weak.
    The sky is very clean and the signal should be much better
    see below:

    Screenshot_2014-05-27-13-33-17.png

    how can make it better?
    the signal level should be more than 24.
     
    Michachu likes this.
  7. Michachu

    MichachuMembers

    Jul 11, 2013
    107
    25
    38
    Male
    Same problem here for few months already. I'm thinking about opening the phone to check for antenna connection as it was in the Samsung galaxy s1

    Sent from my MI 2S using Tapatalk
     
  8. MARCELO KLEINKE

    Mar 5, 2014
    7
    1
    23
    Male
    Curitiba, Brazil
    You can see that, even after 5 minutes GPS turned ON, no signal or sync from the satelites.
    Screenshot_2014-06-05-07-34-10.png

    it should be sync after few seconds and also with a good signal, like:
    Screenshot_2014-06-05-07-49-57.png
     

Share Our Site