Help installing TWRP on Redmi 6A (cactus)


younicke

Members
Aug 25, 2018
8
15
Hi Guys,

Sorry if i posted it here but I cant seem to install TWRP on 8.12.13 on a Redmi 6A codename cactus. I have successfully unlocked my device after waiting 15 days and when i tried installing twrp via fastboot on cmd it was successfully being written. But when i boot it, it doesnt boot from twrp but always boot normally. Has anything changed on Redmi 6A? I tried the last 3 versions of TWRP for my device but they always end up the same, which is booting normally after issuing this commands from console.

D:\Downloads>fastboot flash recovery twrp.img
Sending 'recovery' (16982 KB) OKAY [ 0.635s]
Writing 'recovery' OKAY [ 0.221s]
Finished. Total time: 0.856s

D:\Downloads>fastboot boot twrp.img
Downloading 'boot.img' OKAY [ 0.546s]
booting OKAY [ 0.063s]
Finished. Total time: 0.617s

Is there anything i have done wrong? My phone status is already unlocked from Developer Options.

Please help. This is the first time that I have encountered this thing, I have been using xioami.eu on my other devices, i.e, (Redmi 2, Redmi 4X, Redmi Note 4X, and Redmi Note 5 whyred) but this is the first time that I havent had any success booting TWRP from my device.

I would really appreciate any help I could get from you guys! I really wanted xiaomi.eu on my phone, as I always have.

Thank you very much in advance.

Allan Guintu
 

sdet0

Members
Aug 1, 2018
13
15
Xiaomi.eu won't run on this phone, so don't bother. Your only option is to use the stock ROM at this stage. There is a MIUIPro for this device, but I think I prefer stock global over MIUIPro.