How to install ROM for Redmi K40 / Poco F3

I have bad English.
- When you have a Weekly ROM you do not get an update to Stable ROM.
- If you install Stable ROM you will receive updates on Stable ROM.
Maybe we already understand each other. :)

The transition from weekly to Stable ROM requires Format Data.
  • Like
Reactions: Poney70
Nah, your English is fine :) Thanks for the quick replies too. So, to be clear:

1. I will receive an update notification to update the weekly rom. Then I have to update it manually using usb?
2. If I want, I can update to a stable rom but then I will have to wipe all my data and use TWRP as per your instructions starting from step 4?
1. Yes if it is a fastboot ROM.
- Download our ROM zip file
- Unpack downloaded zip file in the PC
- Reboot your device to fastboot mode (press volume down + power)
- Connect to PC via USB cable
- Run fastboot installation script from unpacked zip according your PC operating system
- Wait for the phone to restart itself.

For Windows OS ./windows_fastboot_update_rom.bat

2. Yes correctly
Last edited:
I have decided to go to stable after initially installing weekly, weekly I think is a bit too risky and since am just a normal user and don't want or need to update weekly, better I stick with the slower and stable version I guess.
Hey guys,

Im in lastest weekly ROM and want to try stable.

The procedute is this: Installing recovery ROM (TWRP).

Thank you
Hey guys,

Im in lastest weekly ROM and want to try stable.

The procedute is this: Installing recovery ROM (TWRP).

Thank you
Yes. If it's a recovery ROM.
It has already been said in the posts above your ..
I downloaded the zipped rom into the phone's storage in order to install the stable rom. I saved it in the root in the internal storage. When I start the TWRP tool however, it says my internal storage is 0 and it doesn't seem to detect the data on my phone. What am I doing wrong? The TWRP version I installed (from the given link) appears to be of a higher version than the one in the screenshot. But otherwise, everything seems similar. FYI, I have the weekly installed and want to install the stable one.
Thanks. Unfortunately can't open the image file you linked to in windows, says is corrupted or is not valid. I even downloaded a third-party app (winzip) just in case the native windows app had issues with the image but it didn't help.


  • Screenshot_2021-06-17-12-54-35 - kopie.png
    Screenshot_2021-06-17-12-54-35 - kopie.png
    25.6 KB · Views: 189
  • Screenshot_2021-06-17-12-56-52.png
    34.2 KB · Views: 203
Last edited:
  • Like
Reactions: Poney70 and Enigmow
@Enigmow & @Pedrompf1990

OK. Transition from A12 to A11.
Use this TWRP toolkit.
Follow these steps:
- run TWRP
- Format Data
- reboot system
- reboot fastboot
- run TWRP
- insert the ROM into the phone
- install ROM
- Format Data
- reboot system
- Done
Thanks,. After a long struggle, I finally managed it with this TWRP Toolkit. No idea but this TWRP detected the rom and the other one didn't.

However, there was one major problem with the TWRP Toolkit. It was all in Chinese, so had to google and fond a youtube showing me how to change language into English.

The other issue is that running the bat file initially made no difference, TWRP didn't launch. So I opened the bat file and checked and it was all due to a typo in the file name. You named the image file tvrp.img instead of twrp.img as in the batch command. I renamed the image as twrp and it launched successfully.
Now that the installation of the has been successful on my Poco F3, I was just playing around with the device got what seems to me to be a worrying message and tells me that regular updates have ended for this device.

The other thing is that device identification seems to be wild. Google seems to identify it as Google Pixel 2, Xioami itself identifies as Redmi K40 although it is a Poco F3.


  • No more updates message.jpeg
    No more updates message.jpeg
    92.8 KB · Views: 245
I had this error too. If you can not boot up or get into fastboot or recovery then you will need to access via EDL making a bridge at the test points (google it). Prob is the glued back cover will probably be broken in the process so I chose to send it to service in warranty.
I sent him for assistance too. I will no longer be modding the main phone.

Inviato dal mio M2012K11AG utilizzando Tapatalk
I have a new computer. I installed ADB 15.6 on the PC. I want to update my POCO F3 to 22.1.6 but my computer no longer recognizes the phone. I've tried searching but can't see what I'm doing wrong.
Install drivers:
1) Unzip the downloaded zip file to your PC desktop

2) Put the phone in Fastboot mode (hold down "Volume Down" + "Power" at the same time until you see the "FASTBOOT" screen

3) Run miflash_unlock.exe on your computer (in the 'miflash' folder)
> Go to the "Settings" menu (gear icon)
> Click on Check
> Allow this tool to run as an administrator (if asked ~ may ask twice)
> Now connect (or disconnect / reconnect) the USB cable from the phone to the computer
> Done! You can now run fastboot commands

restart PC + restart phone


  • Bez-n-zvu.png
    284 KB · Views: 186
  • Like
Reactions: Jan Groen
I have a new computer. I installed ADB 15.6 on the PC. I want to update my POCO F3 to 22.1.6 but my computer no longer recognizes the phone. I've tried searching but can't see what I'm doing wrong.
I had a similar issue and in my case, it was a Windows driver issue. I clicked on Windows update and under optional updates, I installed the drivers suggested by Windows and all went well after that.
Sorry if these questions were answered already. I looked through most of the thread.

I'm on stock 12.5.5. installed latest TWRP 2 weeks ago

1. I wanna install stable 12.5.19. Do I need to format data? ( mathematically speaking x.5 > x.19 .. but generally speaking 5<19 so idk lol)
2. Do I still need to start TWRP through toolkit? or with the latest TWRP I can just boot into recovery and do a normal install no PC needed?

thanks in advance
Good afternoon, I unlocked the bootloader, and I did the step by step on the first page, and everything went well!! Thanks for the tutorial, Just a question, coming out stable version, I just flash without format data.. right?
Hello, i have an issue to download the new version of MIUI (v13.0.2.0). I try to download it from my phone but it said "every mirror are unaivalable"
It's the first time i have this issue using this method to upgrade my MIUI, i alway download the latest version with my phone and never have a single issue.

Do someone have the same issue ? Or maybe someone know how to repair this ?