HTC Desire Z \ G2 Section


Jul 13, 2012
16
0
11
#1
I just installed a MIUI ROM for my T-Mobile HTC G2 which I found on the net somewhere (can't remember exactly where). I'm trying to find the page or section on this site for the ROM.... at first I couldn't, but now i see the HTC G2 & Desire Z forum section's have been merged: http://miuiandroid.com/community/forums/htc-g2.37/

There only seems to be two post in the section, one by the admin saying the two forums have been merged, and one by somebody asking about the dark themes. Is that really are there is? I guess no one has or uses the G2 anymore, either that or i'm looking in the wrong area. The phones been out for 2 years, i figured there would be tons of talk and questions i could read up on.

Anyway, love the ROM so far. Only issue is some of the stuff is still in Chinese or Japanese. Just random things like the notepad, themes titles, some things in the phone\contacts section. Is there a way to fix this?
 
Jul 13, 2012
16
0
11
#3
Nice, thanks man. I figured I was looking in the wrong place. Any idea on how to fix the text to be all in english? Some of it is still in another language... like the FM radio app and other random stuff.
 
Jul 13, 2012
16
0
11
#5
That's appears to be the same version I'm running, not quite sure. My phone says I'm runing the same MIUI version 2.3.30. Like I said, it only a few random things that aren't in my native english.
 
Jul 13, 2012
16
0
11
#6
I just downloaded and flashed the ROM on the page you provided. For some reason the Market Place (Google Play) is missing. It showed up as soon as i rebooted after flashing the rom. But after clicking on it and it saying it is changing to Google Play, it is now missing. I was able to download titanium backup before it went missing, but now titanium backup will not get root permitions.... i dont see busy box on the phone either. Not sure whats goiong on, i didn't have any of these issues with the other 2.3.30 version i was running before. Only reason i flashed this one is some parts of the phone were still in another language.
 
Jul 13, 2012
16
0
11
#7
I was able to revert back to version I was running before with the clockwork recovery backup I saved in recovery mode.... it came back up and is running the same as before. I would really love to be running the full English version you provided me the link of. What am I missing that's keeping the version you provided from working correctly in regards to the market place and busy box (and I’m sure some other things I didn't notice at first glance)?
 
Aug 30, 2012
4
0
11
#8
I had the same problem, and was able to get the icon back by creating a Play widget on one of my screens and then launching it. It created the icon and then I just removed the widget.
 
Jul 13, 2012
16
0
11
#9
I'll have to give that a try and see what happens. Did you have any other issues with that ROM? I also noticed that busy box was missing which was giving me some issues as well.... not really sure what busy box does, all i know is that it is needed for many root type programs to function. Ive never seen a rom not have it when booted up.
 
Aug 30, 2012
4
0
11
#10
I haven't had any other issues with it... it seems more stable than prior versions for me.

Busy box is just a small set of *NIX command line utilities, I don't think MIUI has ever included it. You can install it from the market though.
 

iBotPeaches

Script Gatekeeper
Oct 31, 2011
3,808
1,123
335
#11
I haven't had any other issues with it... it seems more stable than prior versions for me.

Busy box is just a small set of *NIX command line utilities, I don't think MIUI has ever included it. You can install it from the market though.
Busybox is included. Its a tad bit out of date though.
 
Jul 13, 2012
16
0
11
#12
Looks like everything working just fine, got the english version installed and its now runing grate. Had to do the little trick mentioned above with the market wigit to get the app to show up correctly.

I am having a bit of an issue with the music player though. When I set the music folder, it doesn't seem to be able to fine every song in the folder.... even after rescaning the folder with the app. I have my download folder set as the only folder its should look for music in. Ill download some new music, then rescan with the music app, but the newly added music will not show up in the player. Even after restarting the phone and then rescaning the folder(s). Id love to use miui's stock music app as I like the way it looks and functions (for the most part), but if it can't even find music atm its worthless to me. It will play music from the folder if I use a file manager to find and click on the music file, but half the time I do it that way, it will crash the music player and go back to the file manager app.

Any help would be nice... I'm gonna do a search on this site for music player and see if anyone else is having the same issue.