New Mi 11 - MIUI 13.0.8 Very weird bug please help.


RSE99

Members
Mar 6, 2022
2
13
Hello,
For weeks now i have been trying to figure out a very weird bug on my Mi 11 but i can't seem to find the cause.
What is happening is that the navigation buttons go crazy in some apps. For example when i press on one of the 3 navigation buttons in lets say Edge web browser the buttons register like 10 presses in a single second and send me all the way back to the home screen even though i hit the back button once to try and go one page back.
I thought that maybe there was a hardware problem or a problem with the screen protector but even without one i still have the same issue. And the issue only appears in certain apps or certain places in certain apps. For example in YouTube the home/back/navigate buttons work fine and register a single press until it is playing a video then when i press one it goes mental. I really hope to solve this issue because now i cant navigate back in apps because it just yeets me all the way back to the homescreen with a single press.


Things i have tried with no success

-
Change the refresh rate and resolution
- Remove screen protector / clean phone
- Try out different launchers
- Reboot phone
- Remove apps that used a overlay / on screen widgets
- Update to MIUI 13.0.8 i ran the version prior to 13.0.8 and that is where the problem initially started out of nowhere.

I am trying to avoid a factory reset because that would take me a lot of work to get everything back.

I have uploaded a video to make the problem a bit more clear as you can see in the video in Google Play store the buttons function correctly but once i open Edge or Reddit they go crazy.