MI 9 SE: Reluctancy after soft brick when flashing 21.1.27/28


May 17, 2016
I use a Xia

I downloaded the 21.1.27/28 update after running 21.1.20/21 for a week.

Upon reboot I could not interface with my phone any longer. It booted to fastboot mode instead of recovery (I was running twrp-3.4.0-2grus from https://github.com/redispade/device_xiaomi_grus-twrp/releases) and had no way of connecting to my device with adb.

I tried two different computers, but every time I tried interfacing with adb commands, my phone immediately crashed, asking for a key press upon which it rebooted again to fastboot.

I was truly at a loss on how to resolve the problem en in the end, I got the phone back to stock (global) firmware using XiaomiTool V2 (https://xiaomitool.com/). I lost my entire configuration this way, which really annoyed the hell out of me.

So I'm slightly reluctant on going back to Xiaomi.eu firmware, even though I really like the features. Could somebody please give me some advice with regards to:
  1. Which USB Drivers to use in Windows?
  2. Which TWRP to use nowadays?
  3. Which Xiaomi.eu firmware to use/precautions to take?
I'm considering going back to "stable" xiaomi.eu ROMs and waiting for a few months until they've caught up with the current weekly features. They seemed pretty unstable as of late (disconnecting from WiFi, no gestures support with 3rd party launchers,...) so a small wait can't hurt in that regard either.