My mi2 hate sleeping.

Discussion in 'Xiaomi Mi 2 / Mi 2S' started by gpoul, Feb 20, 2013.

  1. gpoul

    gpoulMembers

    Hello guys. I am posting some screenshots from latest miui 3.2.8 Multilanguage. My phone has many wake-ups and more of them are from Google location service although all Google maps location updates and history are set to off. Also weather and Facebook are set to 4 hour intervals checking...
    Any feedback?



    Sent from my MI 2 using Tapatalk 2
     

    Attached Files:

  2. ingbrzy

    ingbrzyXiaomi.eu Multilang leader
    Staff Member

    all seems to be ok...
     
  3. gpoul

    gpoulMembers

    I cannot understand why screen on time is 36 minutes but my phone was awake more than 2 and a half hours. Why I have so many alarms from Google locator.

    Sent from my MI 2 using Tapatalk 2
     
  4. boojay

    boojayMembers

    Jan 9, 2013
    313
    112
    65
    Male
    Canada
    It's not just you, I register very similar numbers all across the board, and while for the most part, Deep Sleep (DS) is preferred, I've also noticed that the amount of DS doesn't really affect my battery life much, if at all. Regardless of whether DS is at 80% or 50%, I'm still registering the same overall usage numbers.

    Even if DS is 0% for an hour or two and 918 MHz is at nearly 100% (with screen off), my battery wasn't dropping, i.e. 0 %/hr, so I think on screen is the biggest culprit for battery drain regardless of processor usage. I'm on the 3120 mAh battery and for kicks I decided to lower my brightness from 80-85% (this is typically where I have it) to Automatic Brightness all day and with 50% remaining, I've been up for 16.5 hrs (4 hr on screen), so I've managed to improve my numbers by a couple of hours from that one change.
     
  5. Acid

    AcidScripting Ninja
    Staff Member

    Aug 20, 2011
    2,726
    744
    245
    Male
    Well maybe this will help:
    - turn off Google Now if you dont use it. Google Search will still work
    - turn on Auto Brightness
    - minimize apps syncing time
    - and most important: set other than default Qualcomms msm-dcvs CPU governor. Use ondemand/interactive governor that will allow your phone to downclock to 384Mhz when idle and making phone even less lag.

    I got almost 3 hours of screen on and more than 40 hours standby without charge with stock battery.
     
  6. stupid question but what app works to set governor on Mi2?
     
  7. boojay

    boojayMembers

    Jan 9, 2013
    313
    112
    65
    Male
    Canada
    Maybe give SetCPU a shot?

    Swyped from my Mi 2
     
  8. moonbugz

    moonbugzMembers

    Feb 19, 2013
    108
    9
    28
    Male
    isn't there an embedded CPU governor in MIUI?
     
  9. ubelai

    ubelaiMembers

    Feb 5, 2013
    209
    20
    40
    Male
    One thing I've noticed is the default min. CPU speed for my device is always usually 918 MHz. This is on interactive/cfq by default too.

    Sent from my MI 2 using Tapatalk 2
     

Share Our Site