NOTICE : LBE / ROOT / PERMISSION -FREEZE ISSUE - 2.6.22


P
#1
There have been mixed reports from users on different devices which are reporting problems with Root access, LBE, bootlooping and possible Force Closing.

We are aware of this, and unfortunately this is beyond our control and appears to be something that Xiaomi need to address and possible will not be done so until the next update (29.6.12)

There are some solutions posted by users with different methods, some work some don't.

Hopefully you all can work together and support each other and share temporary solutions until there is a permanent fix. This thread will remain open for users to post solutions to share and be the focal point for discussion on this topic ONLY.

Regards


MIUI Android Team
 
Likes: Flavio
Apr 12, 2011
56
8
18
#4
I have found the solution

you will have to change

<string name="HIPS_SecurityPrompt_ROOT_Step1">Do you wish to allow %1$d to get ROOT permission?</string>
to
<string name="HIPS_SecurityPrompt_ROOT_Step1">Do you wish to allow %1$s to get ROOT permission?</string>
and should work fine.

attached modified LBE SEC App it is not signed
push it to /system/app
 

Attachments

Apr 22, 2012
22
0
11
#5
i cant get the oportunity to do anything, keeps freezing and showig lbe guard problems, i have reverted back to old roms but same problem. Phone not working so off to bed and will hopefully find the fix on here later...chau
 

ingbrzy

Xiaomi.eu Multilang leader
Staff member
Feb 11, 2012
8,974
21,484
322
#6
I have no problem with lbe or root because of I flashed new update also with siyah kernel... so no problem with root an binary su as with stock kernel...

~Tapatalk~
 
Jul 4, 2011
111
9
28
#7
Not working, did all that. I had to full wipe and install cm9 because when installing miui i was getting process.acore.android and it freeze
 
Mar 11, 2012
63
2
18
#8
Not working, did all that. I had to full wipe and install cm9 because when installing miui i was getting process.acore.android and it freeze
okay ,here is:
full wipers of sgs2! last night l was cleaning completly my sgs2.and l mean full format just to see how's the rom behavior into a brand new clean device...and l notice :
1.long time to first boot (about 3 min on miui logo)
after boot 10 min passed l rebooted it
2.normal boot
another 10 min passed l coppied some files on internal sd,reboot again
3. normal boot
another 10 min passed l was conected to wi fi and signed in to google(for my contacts only) and rebooted again
4. normal boot
another 10 min and l was installed a launcher and some apps without any permission issue and worked fine ...just some laggy things like l posted before.NO Issue at all!
Conclusion: because of the new feature of lbe permission (boot) it need time to read all the stuff on your device ,so be patient atleast on his first boot! if you do a full wipe data factory and on the first boot when the lockscreen appear you go prompt to unlock and then you say "**** ,l don't like this theme ...let's change that ...or vibrate on touch... let's change that..."or going to restore backups rightaway it's totaly wrong! give a little time to your machine!!! l know it's a dual core and 1 gb of ram but that cpu don't even have a cooler ! and heats! let him warm down a bit! l bet you guys have a lot of stuff into your sd cards so let the device to read that alone! it need a bit time for that
when its freeze just keep power button presed until shutting down let him a bit then power on and let it to load alone in peace.
l know what l'm saying and l'm sure about it.just do the things like l listed above​
 
Jul 4, 2011
111
9
28
#9
okay ,here is:​
full wipers of sgs2! last night l was cleaning completly my sgs2.and l mean full format just to see how's the rom behavior into a brand new clean device...and l notice :​
1.long time to first boot (about 3 min on miui logo)​
after boot 10 min passed l rebooted it​
2.normal boot​
another 10 min passed l coppied some files on internal sd,reboot again​
3. normal boot​
another 10 min passed l was conected to wi fi and signed in to google(for my contacts only) and rebooted again​
4. normal boot​
another 10 min and l was installed a launcher and some apps without any permission issue and worked fine ...just some laggy things like l posted before.NO Issue at all!​
Conclusion: because of the new feature of lbe permission (boot) it need time to read all the stuff on your device ,so be patient atleast on his first boot! if you do a full wipe data factory and on the first boot when the lockscreen appear you go prompt to unlock and then you say "**** ,l don't like this theme ...let's change that ...or vibrate on touch... let's change that..."or going to restore backups rightaway it's totaly wrong! give a little time to your machine!!! l know it's a dual core and 1 gb of ram but that cpu don't even have a cooler ! and heats! let him warm down a bit! l bet you guys have a lot of stuff into your sd cards so let the device to read that alone! it need a bit time for that​
when its freeze just keep power button presed until shutting down let him a bit then power on and let it to load alone in peace.​
l know what l'm saying and l'm sure about it.just do the things like l listed above​
Tried this all night and no.. no result. Did you had this problem with process.acore.android ??
 
Aug 10, 2011
97
10
18
#10
i did the following
i took the su binary from 2.6.15
and replaced it with su binary from 2.6.22
now lbe app doesnt crash anymore, and i am able to set permissions manually in the app
 

fergie716

Staff Developer
Aug 8, 2011
171
51
38
#11
I have found the solution

you will have to change

<string name="HIPS_SecurityPrompt_ROOT_Step1">Do you wish to allow %1$d to get ROOT permission?</string>
to
<string name="HIPS_SecurityPrompt_ROOT_Step1">Do you wish to allow %1$s to get ROOT permission?</string>
and should work fine.

attached modified LBE SEC App it is not signed
push it to /system/app

Just wanted to say this worked fine for me, thank you so much

Attached is a flashable zip of the same fix for 2.6.22

Mount /system in recovery before flashing
 

Attachments

Mar 11, 2012
63
2
18
#12
Tried this all night and no.. no result. Did you had this problem with process.acore.android ??
process.acore.android it's related on contacts you may have problem with your contacts when syncronize with your google account maybe

the rest this rom is fine ,laggy or jerky a bit but no issues till now
 
Jul 4, 2011
111
9
28
#13
process.acore.android it's related on contacts you may have problem with your contacts when syncronize with your google account maybe

the rest this rom is fine ,laggy or jerky a bit but no issues till now
I'm not shure it's contact related problem because i don't even sync google contacts, my agenda it's empty, any ideea?
 
Mar 20, 2012
551
63
75
#16
So I don't have any issues when flashing 2.6.22 on my SGS2. No boot loops or apps FC because of the LBE permissions monitor.

However, after some tangling around with the permissions I found out that my newly installed apps, meaning the apps I installed after flashing 2.6.22, are not present in the monitor. So I'm unable to grant root or allow/deny specific actions. It does work for the apps that I had installed before.

I flashed the rom without a factory reset, so I believe that's the main problem. Because after flashing with complete wipes, no apps are listed in the monitor and you are unable to change any settings which may lead to apps FC's.

So I tried disabling the apps permissions, but after a reboot my SGS2 froze... :mad: Not sure if it was because of that setting, because I just was trying different things to get it to work..
 
Feb 23, 2012
133
5
28
#17
So I don't have any issues when flashing 2.6.22 on my SGS2. No boot loops or apps FC because of the LBE permissions monitor.

However, after some tangling around with the permissions I found out that my newly installed apps, meaning the apps I installed after flashing 2.6.22, are not present in the monitor. So I'm unable to grant root or allow/deny specific actions. It does work for the apps that I had installed before.

I flashed the rom without a factory reset, so I believe that's the main problem. Because after flashing with complete wipes, no apps are listed in the monitor and you are unable to change any settings which may lead to apps FC's.

So I tried disabling the apps permissions, but after a reboot my SGS2 froze... :mad: Not sure if it was because of that setting, because I just was trying different things to get it to work..
your s2 froze because of the incorrect variable datatype in the strings.xml, when requesting for root permission, try flashing the above fix and try again. :) so far im not having any problems anymore aside from the about>status FC Bug..

cheers.. just my 2 cents
 
Oct 6, 2011
2
0
21
#20
Didn't work... Had to wipe factory installed the 2.6.22, installed the fix, and then it worked for some time (the time to reinstall all apps as I only had a backup of the system, not apps), until it froze. After some time I rebooted it, and then the cycle of reboots restarted.
Can't install 2.6.16 as it's not on the servers anymore, used the 2.6.15 version I managed to get in some mirror provided on the main discussion, but then it gives the LBE crashed again and again (didn't tried it after wiping factory, maybe next step...).

Worst Miui update I ever had...
 
Feb 23, 2012
133
5
28
#22
Didn't work... Had to wipe factory installed the 2.6.22, installed the fix, and then it worked for some time (the time to reinstall all apps as I only had a backup of the system, not apps), until it froze. After some time I rebooted it, and then the cycle of reboots restarted.
Can't install 2.6.16 as it's not on the servers anymore, used the 2.6.15 version I managed to get in some mirror provided on the main discussion, but then it gives the LBE crashed again and again (didn't tried it after wiping factory, maybe next step...).

Worst Miui update I ever had...
kindly upload your logcat, so we can deduce which is the problem.
 
Oct 6, 2011
2
0
21
#23
I would if the reboot loop would have a bigger interval while it's on... It only stays on for like 30s... And now (dunno what I did in the meantime) the miui home crashes constantly in between restarting.