Suddenly my SD Card cant be seen in MIUI 11. I had no issues of whatsoever in MIUI 10.


SSV_XIAOMI

Members
Apr 29, 2019
7
15
I was blaming myself of why did I just updated to MIUI 11 STABLE version. It broke my ROOT. It has a problem with existing Magisk Module. It hides my other apps. Now it cant see my SD CARD. I had takes time to fix all of them. Now I cant see my SD Card, and the system ui Storage is detecting it to be formated so it can be use, wtf? I had a lot of files in there mainly for portable storage. I cant use the useful things as a geek phone user. Im not the kind of Phone user who were so addicted to gaming or any PRETTY GUI setup. SO basically WTh does an Android 10 can impress me more than 9? I dont know if I could return or planning back to MIUI10 since I had fully backup everything in the TWRP and I can still see my backup files. I Just wanted my ROOT back, FK Kernel Management, working LP, Magisk Modules . I dont care for other features.

My Question is:
How do I downgrade to Xiaomi.EU MIUI 10.4.0 from MIUI 11.0.8 without losing my installed apps ? Can I wiped it then restore to MIUI 10 the restore the TWRP backup?
I
 

Edgar62

Members
Aug 31, 2016
6
13
Hi!

I had a similar issue. Take out the SD card and check/repair on Windows PC. Mine had no errors. After reboot, the card worked again - with MIUI 11.

Regards,

Edgar

Gesendet von meinem POCOPHONE F1 mit Tapatalk
 

SSV_XIAOMI

Members
Apr 29, 2019
7
15
Thanks for the reply @Edgar62 . Right now , I havent done anything yet. But What I notice is , the SD Card is detected but it appears to be ready for Unmount and you have no options to it. The system cant even display its content and couldnt see it affecting all other app as well. The problem occur when this Notification of SYSTEM_xxxx somthing tells that I had an issue with my SD card and when you go into it, it would suggest you to either make the sd card for SYSTEM? or a Portable storage which will Reformat all its content which for me is NO WAY I WOULD DO THAT.

I tried some experiments if it had something to do within some of the SD card file that prevents it from being detected. In TWRP , the SD card is detected flawlessly. You could even Mount or Unmount it. One thing I notice in my SD Card is , there is this file called ".FE_TMP" in the root / main directory of it. When I delete it using the TWRP File Manager. and reboot my Phone, The SYSTEM detects the SD Card and read all its content.

If you copy or move and paste a file to your sd card. this .FETMP appears again and a notification of SYSTEM UI telling that there is a problem with the SD Card appears later. If you ignore it after later, you will notice your phone get laggy / freezes for a while which for me is the cause your SD Card disappear or unmount itself.

Doing the temporarily thing again resolves the issue. SO what the heck does this MIUI 11.0.8 System is doing with the SD CARD why it corrupts it.
I have no problem or whatsoever with my previous MIUI 10.4.0 and just works perfecly with my pocophone f1.

Does this feature in the new MI File Manager had something to do with the issue?
Or is the Feature requested like capability of MIUI to use SD CARD for the system is the CULPRIT?

I hope xiaomi.eu guys resolve this one.