Translation issues

Discussion in 'Question & Answers' started by jcg_vazquez, Nov 22, 2010.

  1. jcg_vazquez

    Nov 22, 2010
    105
    0
    26
    So, i've decompiled framework-res.apk from the last nexus one english pack, created a values-es folder inside res, translated strings.xml, arrays.xml and plurals.xml and inserted them in that folder. Then I've compiled it. Since I've read somewhere that apktool is not working properly when compiling, i've unpacked framework-res from english pack, unpacked my framework-res and then copy-pasted my resources.arsc in the framework-res from english. Finally i've zipped again framework-res with my resources with 0 compression (working on linux).
    BUT! when i push framework in my cell phone (it's a moto milestone) it enters a boot-loop, although permissions are fine!.

    Then i tried, instead of creating another language, overwriting english one (overwrote strings, plurals and the modding part of arrays in /res/values). Did the same thing as before with resources.arsc.
    BUT! when i push framework, my cell phone is still in ENGLISH!
    ?????
    Of course permissions and wipes always done...

    Anyone?
     
  2. Finn

    FinnMembers

    Nov 15, 2010
    303
    6
    40
    Follow the following steps:

    1)Use the framework-res.apk from the english pack.I mean paste it in the apktool folder.
    2)Input the following command in CMD. if framework-res.apk
    3)Input the following command in CMD. apktool d framework-res.apk ./decoded/
    4)Copy the "values" folder and place it somewhere.
    5)Close apktool and delete "decoded" and framework-res.apk
    6)Copy the framework-res.apk from the original MIUI package.The chinese one
    7)Input the following command in CMD. if framework-res.apk
    8)Input the following command in CMD. apktool d framework-res.apk ./decoded/
    9)In /decoded/res/ paste the "values" folder that you copied before plus the values-es folder that has your translations..
    10)Input the following command in CMD. apktool b ./decoded/ build.apk
    11)When done right click on the build.apk file and open with 7ZIP.If you dont have it,install it
    12)Take out the resources.arsc file and place it in your dekstop
    13)Close 7zip and now take the framework-res.apk file from the Apktool folder and place it to your desktop.
    14)Right click on framework-res.apk and open with 7ZIP.
    15)Drag n drop the resources.arsc file from the desktop into that archive.
    16)Now you re ready to use the framework-res.apk in your desktop in an update zip!
     
  3. jcg_vazquez

    Nov 22, 2010
    105
    0
    26
    Thanks a lot man! Really, I was starting to lose it!!! I tried it twice on ubuntu and once in windows... couldn't get it to work on ubuntu, but worked like a charm on win... of course, i don't have 7zip in ubuntu... if anyone knows a solution for linux, it'd be great! (since my win pc it's actually an HTPC, so no keyboard...)
     

Share Our Site