Xiaomi Mi Mix 2S suddenly stopping workin


Th0re

Members
Jun 9, 2019
2
3
Hello,
I have a 7 months old Xiaomi Mi Mix 2S. I did nothing particular with it (no root, no ROM installed...), only the integrated updates of MIUI as they were availables.
This morning it was working just fine, until I got it out of my pocket and it wasn't booting at all. I tried plugging it in, and then it started to boot-loop (Mi logo with URL showing, then battery logo with %-age, ~30% at first and slowly going down, for a second, before stopping and doing it again) I was able to start fast boot by holding start and volume down, the Fast Boot logo showing for about 10 seconds before stopping and going back to the boot-loop. I then tried connecting it to my computer, installing MiFlash and downloading the most recent official ROM. After some boots it stopped and stayed shut down, with only the led usually indicating charge on. I left it like that while the ROM was downloading, and now (2h later) the led doesn't show anymore and it doesn't boot at all, be it normal or fast-boot.
So now I'm out of ideas, any help would be appreciated !
Thanks in advance.

Edit : Maybe this should be in Bug, sorry if I posted in the wrong place
 

Th0re

Members
Jun 9, 2019
2
3
Yeah, that's what I did in the end, just hoping I won't lose the data I had on it...
Thank you anyway :)