HyperOS 1.0 23.11.17/19


Status
Not open for further replies.
I used to flash dirty flash with TWRP and update from Fastboot both before, but it got the same situation: The Google and Webview crashed, WiFi did not work, SIM card couldn't unlock in 11.19dev.
So I dirty flashback to 11.8dev, and everything worked well
Then I saw somebody said you can try to clean the Dalvik/ART cache and cache before you reboot after flashed in Recovery, So I tried with that, and I got this situation: The WiFi is working, the SIM card working, Google crashed, Webview crashed and Xiaomi Account crashed, then I try to clean data of these apps and re-install the APP that getting force close such as WeChat. Right now every APP works well expected Google Pay.
I am 13 Ultra. After following your instructions, the upgrade is now normal. GMS and baseband are no longer lost. I think it is necessary to add a program to clear Dalvik/ART and cache in the installation script, and thank you for providing a solution.
 
  • Like
Reactions: RoughNeck1971
I am 13 Ultra. After following your instructions, the upgrade is now normal. GMS and baseband are no longer lost. I think it is necessary to add a program to clear Dalvik/ART and cache in the installation script, and thank you for providing a solution.
This doesn't work for everyone. Xiaomi 13 pro does not work. Even after cleaning, Dalvik and art applications crash
 
  • Like
Reactions: jamesliu0802
This doesn't work for everyone. Xiaomi 13 pro does not work. Even after cleaning, Dalvik and art applications crash
Have you tried clearing Google-related application data? Especially for GMS, you may need to manually upgrade to the latest version and try clearing the data again...
 
Have you tried clearing Google-related application data? Especially for GMS, you may need to manually upgrade to the latest version and try clearing the data again...
I tried, nothing works. There are always errors in the applications. And departure
 
I just installed the new weekly after downloading it through the updater. I tell you my experience. Install the rom on my xiaomi 13 pro from recovery by wiping dalvik art cache and cache. Correct installation. When I started the errors started. Uninstall Chrome. Clean data from Android system webview. Some errors continued. I had to delete some meaningless app like outdoor active. Errors appeared in microg. Delete data and uninstall. Now after reboot. More or less I think everything works for me. Except, micro g won't let me use it. The app closes. And I tried several versions. I can't link my Google account to YouTube vanced accordingly. I also can't access the hidden miuisettings app. It does not open. I've already tried uninstalling and reinstalling and it doesn't open. Otherwise I'm still trying things out. The rest seems to be going well. If anyone has a solution, I would appreciate it if you could tell me.
Also now when I open Chrome sometimes it gives me an error message and when I look at the details I get a memory error. Does it have something to do with having the memory extension activated? The thing is that now it doesn't let me change or deactivate it either.
Edit. I had to go back to the previous rom. No application from my banks works for me, which is totally necessary for me.
 
Last edited:
I just installed the new weekly after downloading it through the updater. I tell you my experience. Install the rom on my xiaomi 13 pro from recovery by wiping dalvik art cache and cache. Correct installation. When I started the errors started. Uninstall Chrome. Clean data from Android system webview. Some errors continued. I had to delete some meaningless app like outdoor active. Errors appeared in microg. Delete data and uninstall. Now after reboot. More or less I think everything works for me. Except, micro g won't let me use it. The app closes. And I tried several versions. I can't link my Google account to YouTube vanced accordingly. I also can't access the hidden miuisettings app. It does not open. I've already tried uninstalling and reinstalling and it doesn't open. Otherwise I'm still trying things out. The rest seems to be going well. If anyone has a solution, I would appreciate it if you could tell me.
Also now when I open Chrome sometimes it gives me an error message and when I look at the details I get a memory error. Does it have something to do with having the memory extension activated? The thing is that now it doesn't let me change or deactivate it either.
Edit. I had to go back to the previous rom. No application from my banks works for me, which is totally necessary for me.
So do your phone work with SIM and WiFi now? If yes, you can just delete Chrome and Android System Webview then re-install again, this could be way?
 
So do your phone work with SIM and WiFi now? If yes, you can just delete Chrome and Android System Webview then re-install again, this could be way?
Yeah. The SIMs worked for me, I have 2. And the WiFi. I have wiped and deleted data from Android System Webview. And even then there were applications that did not work or closed. Microg wouldn't let me enter my account. OK. I can get by with normal YouTube. Hidden miuisettings didn't even open. The apps of my banks, I have 3, did not open either. And I tried deleting data from all the apps that were failing. Delete them and reinstall them. And they didn't open. They gave error. The feeling I got is that it should not manage the permissions issue well and that some errors are generated with apps that depend in some way on Google.

It is clear that the previous version has something that works correctly and that this week's version does not. It was reinstalling the previous rom from the recovery and all the problems that arose with the new rom have disappeared. I was even able to reinstall microg again and link my Google account to YouTube revanced. Honestly it's all very very strange.
 
Yeah. The SIMs worked for me, I have 2. And the WiFi. I have wiped and deleted data from Android System Webview. And even then there were applications that did not work or closed. Microg wouldn't let me enter my account. OK. I can get by with normal YouTube. Hidden miuisettings didn't even open. The apps of my banks, I have 3, did not open either. And I tried deleting data from all the apps that were failing. Delete them and reinstall them. And they didn't open. They gave error. The feeling I got is that it should not manage the permissions issue well and that some errors are generated with apps that depend in some way on Google.
Those APP that force close, you can try to re-install them but keep data, this could be a way for try, that's what I do to the APP that getting crashed on my phone after update to 11.19dev
 
Those APP that force close, you can try to re-install them but keep data, this could be a way for try, that's what I do to the APP that getting crashed on my phone after update to 11.19dev
It's not possible. I need to be able to access my Banks apps. I tried everything. Clear cache, delete data, uninstall apps. They didn't even get started. The login option didn't even appear. And so it is impossible for me. I'm sorry.
 
It's not possible. I need to be able to access my Banks apps. I tried everything. Clear cache, delete data, uninstall apps. They didn't even get started. The login option didn't even appear. And so it is impossible for me. I'm sorry.
Sounds crazy but are they just getting forced close or something? Hard to be sure if there is something wrong with the permissions management of HyperOS, 11.19dev has very different permission management from 11.8 dev.
 
Sounds crazy but are they just getting forced close or something? Hard to be sure if there is something wrong with the permissions management of HyperOS, 11.19dev has very different permission management from 11.8 dev.
Let's see. I have no idea. I'm not a programmer and for that we already have people here who know a lot about the subject. It is clear that this version of the rom has, apart from the corrections, something different, be it permission management or something that conflicts with Google services and that the previous version does not happen. And I'm not saying at all that it's a matter of the eu rom programmers or the compilation. It could be a problem or probably a problem with this Chinese weekly base. Let's hope that next time we won't have these problems. Because otherwise the issue is complicated. The rom as it is is not operational. At least for an average user like me. It is a pity.
 
Let's see. I have no idea. I'm not a programmer and for that we already have people here who know a lot about the subject. It is clear that this version of the rom has, apart from the corrections, something different, be it permission management or something that conflicts with Google services and that the previous version does not happen. And I'm not saying at all that it's a matter of the eu rom programmers or the compilation. It could be a problem or probably a problem with this Chinese weekly base. Let's hope that next time we won't have these problems. Because otherwise the issue is complicated. The rom as it is is not operational. At least for an average user like me. It is a pity.
Seems like the only better way to solve this one is to clean all the data and then flash the new ROM but these cost too much for me too....So I flash several times then flash back to 11.8 dev, until just now I found how to flash the 11.19dev. But I think they may find it a little bit hard to solve this cause they didn't find anything wrong when they built this version, so this could be a challenge.
 

Seems like the only better way to solve this one is to clean all the data and then flash the new ROM but these cost too much for me too....So I flash several times then flash back to 11.8 dev, until just now I found how to flash the 11.19dev. But I think they may find it a little bit hard to solve this cause they didn't find anything wrong when they built this version, so this could be a challenge.
Tell us how you solved it. But the solution is not to do a clean installation. Right now it is not a valid approach for me to have to do a clean installation with this weekly and for this to be something common since due to my situation, unfortunately I cannot do a clean installation every so often. I hope there is another solution. I know this is a beta program and this can happen. But I know it's not usual.
 
xiaomi 13 ultra Some apps crash after updating version 11.19. Whoo GPS app, grindr app, and Instagram cannot take pictures. Hope they can be updated soon.
 

Attachments

  • Screenshot_2023-11-24-05-07-20-944_com.android.settings.jpg
    Screenshot_2023-11-24-05-07-20-944_com.android.settings.jpg
    238.2 KB · Views: 154
Last edited:
Xiaomi 13 Pro. (nuwa) - successful install!
Seeing some people commenting on clearing the Dalvik cache, I thought that I would give the installation another go. However, it would still not install with TWRP.
So, rebooting to system, and then after I cleared all the recents, Boosted the speed and used Cleaner, I went into TWRP, and cleared the cache and Dalvik. No error appeared, implying that they were both cleared. I had previously tried to go into Fastboot from TWRP, but that did not seem to work properly. So, I rebooted to system, but held down the Power + Volume Down to get into Fastboot.

I then installed (successfully) with Fastboot. When it came to the reboot at the end, I held down the Power + Volume Up to get back into TWRP. I again cleared the cache and Dalvik (to be absolutely sure!), and then did a system reboot. It took maybe a couple of minutes to boot up

So now it has been successfully installed (with Google Wallet / Pay working properly). I shall comment separately on my issues with this newer version.
 
Wanna ask a question, should I download the latest version from the updater or just go for 23.11.8 for more stable?
 
Wanna ask a question, should I download the latest version from the updater or just go for 23.11.8 for more stable?

I think it's a bit up to you and your phone. Some ppl have faced issues and some haven't. Take some minutes to read some of the posts above regarding this.
 
Last edited:
Wanna ask a question, should I download the latest version from the updater or just go for 23.11.8 for more stable?
It depends firstly on the phone that you have, and secondly what the feedback has been for that phone. The decison is yours! ;)
 
Hi,

i just bought Xiaomi 13 ultra and update it to hyperos 1.0 and its showing i do have last ver which is not for my ROM, is it fine to update to .19 or it will brick my phone ?

23.11.8 ISHATR i have this ROM at the begining i didnt wipe the data and its stuck in fastboot after following the steps how to recover its works again and re do the steps, its really nice update and great works from the developers as well , Thank you guys.
 
The 23.11.19 update was postponed due to issues.
In a previous post, I think you said that you didn't notice anything unusual when building and compiling. Does this mean that there is no guarantee that the next update will be bug free, since you don't know what happened and have to rely on luck?
 
Tell us how you solved it. But the solution is not to do a clean installation. Right now it is not a valid approach for me to have to do a clean installation with this weekly and for this to be something common since due to my situation, unfortunately I cannot do a clean installation every so often. I hope there is another solution. I know this is a beta program and this can happen. But I know it's not usual.
Neither I can't accept cleaning all the data and then updating, so I tried all the way and finally found this one.
I do share how to solve it in the same theme before, flash 11.19dev in TWRP, then clean Davilk/ART cache and cache before you reboot, then after booting into the system, you will see Google、System Webview、Xiaomi Account、Chrome said stop working, just uninstall them and re-install and clean the data of Xiaomi Account APP, and re-install those APP that getting force closed without delete them (like cover them but keep data) then it should be work...
This is my experience but may not work for you.
I think about is better to share which part needs to be cleaned with the screenshot to avoid my express may have something wrong.
 

Attachments

  • 图片_20231124133125.jpg
    图片_20231124133125.jpg
    1.6 MB · Views: 139
Last edited:
Status
Not open for further replies.

Similar threads

  • Locked
HyperOS 1.0 24.5.27
Replies
90
Views
30K
  • Locked
HyperOS 1.0 24.5.13
Replies
198
Views
47K
  • Locked
HyperOS 1.0 24.5.20/21
Replies
76
Views
31K