HyperOS 1.0 23.11.17/19


Status
Not open for further replies.
Just installed 23.11.19 and deleted Dalvik Cache & Cache via advanced wipe before reboot.

13 Ultra previously with HyperOS weekly (23.11.8)
Dirty flashed via TWRP A14
Downloaded from OS (Update message in Android settings)
No bootloop after reboot
All apps working
SIM card and Wifi working
No issues with Whatsapp, Line and Messenger
Banking apps working
All settings and all data there from all apps (deleted cache, but not data)

All good for now.

Camera Shutter Sound is fixed now (can be switched on and off within camera app)
I still don’t understand, is it possible to install this firmware through Ota and then clear the data and only then log into the system?
 
My mi 14p is stuck in fastboot
After unlocking BL, I turned on USB debugging, flashed the rom version 1.0.23.11.16.DEV in fastboot mode, and then it got stuck in fastboot mode... I tried the power button + volume up and down, I don’t know. Is there any way you can provide me
The computer's current device administrator can detect the android bootlodar lnterface
Computer system win11

Figure 1 shows the final crash screen after executing first_install_with_data_format.bat.
Figure 2 The result of using the adb command fastboot oem device-info (it should be that the BL is unlocked)
 

Attachments

  • 螢幕擷取畫面 2023-11-23 200843.png
    螢幕擷取畫面 2023-11-23 200843.png
    107.9 KB · Views: 136
  • 螢幕擷取畫面 2023-11-23 201543.png
    螢幕擷取畫面 2023-11-23 201543.png
    18.9 KB · Views: 141
Just installed 23.11.19 and deleted Dalvik Cache & Cache via advanced wipe before reboot.

13 Ultra previously with HyperOS weekly (23.11.8)
Dirty flashed via TWRP A14
Downloaded from OS (Update message in Android settings)
No bootloop after reboot
All apps working
SIM card and Wifi working
No issues with Whatsapp, Line and Messenger
Banking apps working
All settings and all data there from all apps (deleted cache, but not data)

- Fixed: Camera Shutter Sound is fixed now (can be switched on and off within camera app)
- Fixed: No more message about Update in Android settings

All good for now.
Isn't wiping Dalvik not recommended as it leads to a slower OS until the next ROM update?
 
I still don’t understand, is it possible to install this firmware through Ota and then clear the data and only then log into the system?
Never done directly from OS. I downloaded via OTA and then flashed via TWRP and deleted Cache before reboot.
 
Just installed 23.11.19 and deleted Dalvik Cache & Cache via advanced wipe before reboot.
...
But from what I understand, TWRP can't decrypt the data partition on Android 14 yet.
Both the cache and the dalvik-cache reside in the data partition, so... how did you clear them if TWRP can't decrypt?

don't know, too late for me now. But system is fine so far :)

AFAIK the dalvik will be rebuilt on first boot, the cache by using apps.
That was the case until Android 12, no longer the case in Android 13. Don't know about Android 14.
 
True, but it does look like the dalvik-cache was not updated properly, thus the issues.
So if you have those crashing issues, try to wipe dalvik-cache and see if it resolves the crashes.
I think the crashes had something to do with chrome or the android webview. Not all apps crashed, only those that had some connection with the webview or some form of login to Google.
After I deleted webview + chrome updates and cache, all apps now work without crashing.
 
I think the crashes had something to do with chrome or the android webview. Not all apps crashed, only those that had some connection with the webview or some form of login to Google.
After I deleted webview + chrome updates and cache, all apps now work without crashing.
Not necessarily. I saw crashes from random processes, like the built-in network stack.
 
  • Like
Reactions: Mark F and rasne
But from what I understand, TWRP can't decrypt the data partition on Android 14 yet.
Both the cache and the dalvik-cache reside in the data partition, so... how did you clear them if TWRP can't decrypt?


That was the case until Android 12, no longer the case in Android 13. Don't know about Android 14.
There is a new version of TWRP that supports decryption.
 
First of all, thank you for the efforts of our xiaomi.eu rom programmers. After reading the problems and possible solutions, I am one of those who did not have time to download the rom. question and not request. Are the "corrected" roms going to be uploaded again? Or is this weekly already discarded? Thanks in advance.
 
First of all, thank you for the efforts of our xiaomi.eu rom programmers. After reading the problems and possible solutions, I am one of those who did not have time to download the rom. question and not request. Are the "corrected" roms going to be uploaded again? Or is this weekly already discarded? Thanks in advance.
There's nothing to correct. We don't know the source of the problem and there was nothing unusual with the build process.
 
True, but it does look like the dalvik-cache was not updated properly, thus the issues.
So if you have those crashing issues, try to wipe dalvik-cache and see if it resolves the crashes.
I can confirm that I had no issues after reboot...maybe because I deleted Dalvik,
But from what I understand, TWRP can't decrypt the data partition on Android 14 yet.
Both the cache and the dalvik-cache reside in the data partition, so... how did you clear them if TWRP can't decrypt?


That was the case until Android 12, no longer the case in Android 13. Don't know about Android 14.
TWRP for A14 was released 4 days ago. I used for 13 Ultra. It decrypts without issues. TWRP is now like it has always been.

 
True, but it does look like the dalvik-cache was not updated properly, thus the issues.
So if you have those crashing issues, try to wipe dalvik-cache and see if it resolves the crashes.
From what I experienced:
- Tried wiping dalvik-cache using v8.1t5_14 twrp on my k60 and it didn't solve the issue of google play services and xiaomi account.
- Tried reupdating from fastboot without data format. I didn't downgrade from previous weekly beta because I believe the twrp was the culprit but still got the same issue.
- Retry from fastboot again but with data format. Didn't downgrade from previous weekly beta and no issue since then. Network, gapps, xiaomi account, etc. are all working as of now. I still believe that twrp is somehow part of the reason that's why I directly used fastboot with data format instead of using twrp for data format.

Don't know if this can help but here is my log when it has those issues. Wish I could help more but I lack the knowledge and experience.
 
I don't see how the release date has anything to do with its inability to decrypt.
Maybe it's only Xiaomi 14/14 Pro that can't be decrypted yet.
Just wanted to say that I used this version for 13 Ultra for A14 and it works without issues.
 
I discovered that TWRP v8.1t5_A14 for Mi 13 Ultra can decrypt, but at random times this is not working. As for me clearing cache and Dalvik did not help. Apps keep crashing, so I went back to previous build.
 
Я обнаружил, что TWRP v8.1t5_A14 для Mi 13 Ultra умеет расшифровывать, но в случайные моменты это не работает. Лично мне очистка кеша и Dalvik не помогла. Приложения продолжают вылетать, поэтому я вернулся к предыдущей сборке.
пI support, same thing Xiaomi 13 pro. Reverted to previous version
 
Can't seem to download the new weekly version (23.11.19), says file could not be found or not available, for Xiaomi 13 series and other devices
 
I used to flash dirty flash with TWRP and update from Fastboot both before, but it got the same situation: The Google and Webview crashed, WiFi did not work, SIM card couldn't unlock in 11.19dev.
So I dirty flashback to 11.8dev, and everything worked well
Then I saw somebody said you can try to clean the Dalvik/ART cache and cache before you reboot after flashed in Recovery, So I tried with that, and I got this situation: The WiFi is working, the SIM card working, Google crashed, Webview crashed and Xiaomi Account crashed, then I try to clean data of these apps and re-install the APP that getting force close such as WeChat. Right now every APP works well.
If you can't going into Google pay, try with this one:https://xiaomi.eu/community/threads/23-11-8-13-16.70548/post-706388
 
Last edited:
  • Like
Reactions: bear0610
Status
Not open for further replies.

Similar threads

  • Locked
HyperOS 1.0 24.7.1
Replies
54
Views
30K
  • Locked
HyperOS 1.0 24.6.3
Replies
46
Views
31K
  • Locked
HyperOS 1.0 24.5.27
Replies
90
Views
34K