Device is stuck in a bootloop, TWRP is unable to mount storage. How do I fix this without losing my data ?


Jan 18, 2023
Hello guys,
So my devices is stuck in a bootloop, I want to reflash the ROM but I need a backup first.
Things I've tried to fix bootloop that didn't work:
1) Re-flashed the boot.img
2) Re-flashed the vbmeta.img
3) Wiping cache through TWRP Recovery

Things I've tried to back up my data:
1) Going into TWRP to make a backup it reads: "Internal Storage (0MB)", when I try to mount system or data I get "Unable to mount."
2) When I use the Mount->Decrypt Data option it asks me for a password, I tried every password I ever had on the phone and any "default" ones I found online and nothing worked.
3) I tried the adb pull command from my computer I get: "0 files pulled, 0 skipped." and nothing gets copied over.

So I don't know where to go from here, I have some things I have yet to try like:
1) Re-flashing ROM (dirty flash)
2) Re-flashing ROM update
3) Flash TWRP Update (if any)

But I don't know if they're going to to anything or just waste my time. Also I am not sure any of the 3 options will 100% keep my data.
I am not too worried about apps and settings but more about Photos, Videos, PDFs, TXTs and Downloads. Any ideas on what I should do ?

Thanks a lot !
I'm affraid that you cant.. and have to reflash the rom.
because its because data encryption.

but maybe may try Ofox 12.1, as i remember ofox can decrypt an encrypted data (but this when I'm using Poco F3)