[FIXED] MI-ONE to Windows 7 Bluetooth tethering problem

Discussion in 'Xiaomi Mi One/Mi One S' started by 10-80, Apr 8, 2012.

  1. 10-80

    10-80Members

    Mar 4, 2012
    91
    2
    18
    This may be more of a general Android/ICS issue than a MIUI or MI-ONE issue but I'm not sure where else to seek help with this.

    Before I start on this, just a quick thanks to MarkHK, for the ROM, which is really fantastic.

    I'm trying to configure Bluetooth (BT) tethering between my Xiaomi MI-ONE and Windows 7 x64 PC.
    • I'm running Windows 7 64-bit on my primary PC but have also tested on my laptop running Windows 7 32-bit with the same results.
    • I'm running ICS MIUI-2.4.6 on a Xiaomi MI-ONE Plus (Android 4.0.3). I have data working and tethering enabled with my carrier.
    • I can browse the Internet on the MI-ONE and I can tether using USB and Wi-Fi hotspot successfully.
    • I've established a paired BT relationship between the MI-ONE and the Windows PC and I can send files between the two devices over BT.
    • Upon pairing the MI-ONE to Windows, Windows detected 4 new devices and attempted to install drivers for them. It found and installed drivers for one device "Standard Modem over Bluetooth link" but not the other three. So there are now three "problem" devices in Device Manager, all named "Bluetooth Peripheral Device" (see screenshot 1).
    To try to Bluetooth tether the device I did the following:
    1. Pair the devices
    2. On the MI-ONE: enable data, disable WiFi then: settings -> Full settings -> ...More Settings (under Wireless & Networks) -> Tethering -> Bluetooth tethering (enabled - orange tick).
    3. In Windows:
      1. Disable my LAN connection (so I can check whether the BT connection is working)
      2. Control Panel -> Devices and Printers -> right click the MI-ONE BT device -> Connect using -> Access point
      3. "Bluetooth network connection connecting" displays momentarily then "Bluetooth network connection connected" displays.
      4. Tested by trying to browse internet - pages will not load.
    Looking at the Windows "Network connections" dialogue, I can now see that the status is "connected" but there is no network access (see screenshot 2)
    Looking at the connection status and details dialogue, I can see that there is no IP connectivity, an "autoconfiguraiton" IPv4 address has been assigned and there is no IPv4 default gateway or dns server address (see screenshot 2).

    It appears to me that the MI-ONE DHCP service isn't working correctly for Bluetooth tethering.

    Any suggestions or relevant information is much appreciated.
    Cheers, 10-80.
    --
    screenshot 1
    [​IMG]
    --
    screenshot 2
    [​IMG]
    --
     
  2. bluebird

    bluebirdMembers

    Jan 14, 2012
    43
    7
    18
    UK
    Ok - I share your comments about the latest ROM BTW. Nice one Mark.

    Right, I followed your instructions to the letter (good description!). I got the three failed drivers like you BUT my connection worked. So we can rule out the drivers being the issue. What I got was the tether icon in the status bar and a dialogue asking whether this was a home network in win7 64.
    I am running 2.4.6 MIUI ICS
    I am on a 3g network.
    When you say you disabled the LAN how did you do that. In my case I just disconnected from the WIFI signal rather than switch off the the wireless receiver. You could try running tracert in the command box which might give you some clues
     
    10-80 likes this.
  3. 10-80

    10-80Members

    Mar 4, 2012
    91
    2
    18
    Hi bluebird, thanks for helping out.
    I'm also on a 3g network (Optus Australia).
    I disabled the LAN in the Win 7 Network connections dialogue:
    Control Panel -> Network and Internet -> Network connections
    I right click the connection I want to disable ("Local Area Connection") and select "disable". I had to do it this way because I'm using a wired Ethernet connection, not WiFi. The other option is to unplug the Ethernet cable - I've tried that too but it makes no difference.

    When my connection is established (step 3.3 in my OP), I don't think I get the tether icon in the status bar. The only change I see is that the BT icon in the status bar get's two little triangles pointing into it's centre, one either side. Is this what you mean by "tether icon"?
    When I enable the "Portable Wi-Fi hotspot" function, I get a status bar icon named "Tethering or hotspot active" that looks like a WiFi "fan" icon. Similarly, when I enable USB tethering I get a status bar icon with the same name that looks like the USB "Trident" icon. But I don't get one of these when I enable, and connect the BT thethering.

    If you are seeing a tethering icon in the status bar when you enable BT tethering that is different than what I'm seeing, that might indicate the issue is on the MI-ONE rather than Windows -- maybe another configuration item somewhere?

    I tried tracert but it isn't getting anywhere, fails on the first hop:
    Code:
    C:\Users\Administrator>tracert 192.168.1.1
     
    Tracing route to 192.168.1.1 over a maximum of 30 hops
     
      1  192.168.1.2  reports: Destination host unreachable.
     
    Trace complete.
     
  4. bluebird

    bluebirdMembers

    Jan 14, 2012
    43
    7
    18
    UK
    I'm struggling to know what is happening in your case. Are you using IPv6 at all? This is what the status bar looks like:[​IMG]
     

    Attached Files:

  5. 10-80

    10-80Members

    Mar 4, 2012
    91
    2
    18
    That white icon in the top left of your status bar is what I'm missing. Does that appear as soon as you enable BT tethering on the phone or only after you establish the connection from in Windows?
    I'm not sure if I'm using IPv6, would that be a carrier issue, how could I check?

    Seems to me like something on my phone is stopping the BT tethering from loading up properly.
     
  6. bluebird

    bluebirdMembers

    Jan 14, 2012
    43
    7
    18
    UK
    The icon appears once you hit the connect in Windows. IPv6 is a bit of a long shot. Just that if your mobile company uses IPv4 and your ISP uses Ipv6 then DHCP might not work. It is unlikely to be this though as IPv6 is pretty rare at the moment. Try accessing http://ipv6.google.com with both your mobile and isp. If one works then it might be worth looking into it more. Does you mobile co have a policy against tethering?
     
  7. 10-80

    10-80Members

    Mar 4, 2012
    91
    2
    18
    Cant access that IPv6 URL from either of my mobile (via data connection) or home ISP (ADSL), so I guess that rules that out.
    My carrier requires 'Activation' to do tethering but I have completed that process. Given that USB and WiFi hotspot tethering works OK I'm thinking that's not the issue.
    ...running out of possibilities guess :(
     
  8. bluebird

    bluebirdMembers

    Jan 14, 2012
    43
    7
    18
    UK
    Yes, I can't think of anything obvious. It should work, and does work in my case but that doesn't help you any. Perhaps wait until the next update and do a full data wipe but I am clutching at straws here :confused:
     
  9. 10-80

    10-80Members

    Mar 4, 2012
    91
    2
    18
    Yeah, I'll keep trying the new updates as they come out. I did do a full data wipe before flashing 2.4.6 though so it's very puzzling.
    The other thing that occured to me is that it could be the BT USB dongle I'm using because I used the same dongle on both PCs I tested with (neither have internal BT). It's a fairly generic one that I got off eBay a few years ago but it seems to work OK except for this. I'll try to get my hands on an alternate dongle to see if I can rule that out.
    Thanks for all your suggestions bluebird.
     
  10. 10-80

    10-80Members

    Mar 4, 2012
    91
    2
    18
    Well I just bought and installed a new USB BT adapter and I'm having the same experience, so that rules out that possibility. I must be doing something wrong. So frustrating :confused:
     
  11. bluebird

    bluebirdMembers

    Jan 14, 2012
    43
    7
    18
    UK
    Well at least you are narrowing it down :confused:
     
  12. MarkHUK

    MarkHUKFounder & Sys Op
    Staff Member

    The quickest thing you can do for yourself here is try the BT adaptor on another PC with your MI-ONE, it sounds more user-related when in your first post mentioned issues in device manager which only leads me to think its a driver issue with your Windows Systems.

    I'd look into trying it on another system as I say to rule out any hardware issues with the BT adaptor or the phone.

    Thanks,
    Mark
     
  13. 10-80

    10-80Members

    Mar 4, 2012
    91
    2
    18
    Good news!
    I just updated to MIUI 2.4.20 and the problem is fixed.
    There must have been something in the way I'd configured the device when I flashed 2.4.6 that was causeing the problem and it got reset when I deleted all the data and flashed 2.4.20. No idea what it was but it's fixed now so I'm happy.
    Thanks Mark and bluebird for you input.
    Next problem: bluetooth tether with my Acer A500 Android tablet.... but that's a whole other story.
     
  14. bluebird

    bluebirdMembers

    Jan 14, 2012
    43
    7
    18
    UK
    Just glad you got it working. I'll let you sort out the Acer :)
     

Share Our Site