HELP NEEDED: Mi8 Bootloop using TWRP 3-2-3 & Global MIUI 10


Sep 5, 2018

I bought I MI8 Chinese version a week ago. I was able to "successfully" unlock it with the goal of installing the Global ROM. I found a set of instructions online (
To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
) and followed step by step all instructions:
  1. Unlock the phone using the MiFlash Tool
  2. Download the ADB
  3. Downloaded TWRP 3-2-3
  4. Using Fastboot ran powershell commands: Flash Recovery and Boot using TWRP.img
  5. This process was "successful" as I was able to get the TWRP app to run on my phone
  6. Downloaded the MIUI.eu10 Stable version file
  7. Installed the 10 version inside the phone folder TWRP
  8. Clicked "install" in the TWRP app on the phone and selected the WinRAR file with the 10 stable version
  9. Phone runs the install process and enters a bootloop black screen "powered by Android"
Since this was clearly not working I proceeded to download the 9.5 in case that the newer version was the troublemaker. Got the same black bootloop screen...

Now the phone does not enter the fastboot screen with the Xiaomi Mascot, but instead when in the bootloop when I click the power + volume down buttons I get a battery charging logo which seems to be the same as fastboot as the PowerShell commands seem to run here in the same way.

I have tried a few different things I have read only (i.e. re-installing TWRP again, adding a boot.img file to the phone thru PowerShell, etc. with no success). Also tried Wiping and Resetting using the TWRP app but gets me back to the black bootloop screen.

Any guidance and/or help will be GREATLY appreciated! Since I am not a technical person instructions for dummies would be appreciated :)

Thanks for your support and guidance in advance!
did u activated the settings and stuff before installing and doing something? if got it right, u can acces fastboot? also can u acces twrp?
you didnt format any of the partitions first did you? sounds like you used flashed the rom ontop of whatever was there first
I have exactly the same problem. I followed the instructions step by step, but I cannot solve it. Seems like I can throw away my phone :(
Is there anybody with a suggestion on how to fix it?