HyperOS 1.0 HyperOS 1.0 STABLE RELEASE


Yes, please do the same.
I said in post #1.561 that it's an upgrade to switch from MIUI 14 stable to HyperOS stable ROM, so formatting data is not mandatory.

Also your quote from first post is about going from HyperOS weekly to HyperOS stable. But you are referring this quote to a question, which is about going from MIUI 14 weekly to HyperOS stable. Your answer and quote don't fit to the question.
Since this is an upgrade and not a downgrade like the procedure in your quote, it CAN work without formatting data. But it would mean switching the ROM branch, so clean install may be better in this case.
Seems everyone are saying the same thing so no reason for misunderstanding
Do a Clean Install is always the best practice when upgrading:

MIUI14 => HyperOS
Android 13 => Android 14
Weekly => Stable

That's the one million same answered question here. This Forum could has half size if just this Q&A has been deleted and users started to read the OP (first page)
 
Last edited:
What do you mean by "necessary"? TWRP isn't necessary at all since you can flash the ROM via fastboot.
If you don't want to flash ROM updates via fastboot, you have to update TWRP version.
Normally I update via fastboot, because TWRP don't decrypt data. Thank you for answering my questions :)
 
I encountered one minor bug in 1.0.8 on my Xiaomi 13 FUXI device.

When I go to settings > Mobile Networks > SIM (one or two) - I have a new tab to manage esim in my SIM settings however I have the CN variant of the device which regrettably has no esim support so naturally when I tap it, it doesn't do anything and behaves like a ghost button.

I don't recall this button ever being present in 1.0.7 and earlier releases so I figured I'd bring it up even though it doesn't inhibit the functionality of the ROM or device in anyway as far as I can tell.
Hi. How do you know what your model is? I don't remember if I bought the global or CN version. THANK YOU.
 
Hi, first of all I wanna give a big thank you to xiaomi.eu team for providing quality roms for free to xiaomi users around the world❤️

I updated my star device to OS1.0.2.0 today and saw advanced textures feature is absent, is it possible to add it please or there is any way to enable it without root? I like the effects but don't know how to archieve this alone
 
  • Like
Reactions: Evertonduarte
Also I want to know before flashing my phone(munch) does android auto work with cable or wireless since I use it almost all the time
 
Hi, first many thanks for bringing HyperOS to Mi11 Ultra. Just a little question: I remember that with MIUI14 latest TWRP was inside the flashable zip, so that even with installing via fastboot we had latest TWRP without flashing that after. So it was easy to just boot to TWRP after flashing and flash magisk. Is it same now or do i have to boot latest A14 TWRP with fastboot and then install magisk (and twrp with "install to recovery ramdisk" ) ? Thx
 
  • Like
Reactions: Evertonduarte
Hi Good evening everyone, i am very new to the Xiaomi Eu forum although I have used the rom on a few devices, i apologize in advance to the mods if I flout any rule in this post, consider it a newbie error.

I have two devices a Redmi Note 10 pro running the miui 14 EU rom ( which I am having a bit of trouble with ) and a Mi 11 Ultra which i want to update with the new hyperOS EU ROM but a bit afraid due to my experience on the 10 Pro after three boot loop cycles.

question 1

the format data issue: during my attempt to install eu rom on my Note 10 pro, i faced an issue where my internal storage refused to show after formatting data using TWRP and finally Orangefox recoveries, once I formatted data and decrypted, i would be unable to access it, it caused me days of headache and different issues plus the videos on youtube was very unhelpful in solving this. i ended up somehow by luck installing the EU rom on my Note 10 pro and am currently in my third boot loop cycle after a simple restart, i am frustrated and have failed to set up the device after factory resetting again

so can someone give me clear step-by-step instructions on how to avoid the format data issue with Twrp or orangefox and properly install the rom, as this would give me the confidence to install the hyperOS rom on my mi 11 ultra?

The Fastboot Process
: at the beginning of this thread, the fastboot instructions were a bit vague to me, just like my previous request, can someone also provide me with a step-by-step process to install via fastboot

I appreciate you mods and the community for the amazing work you do, please forgive me if i broke a rule with my first ever post
 
Thanks for the great work! Just installed it from Stable Miui 14 for Mi11 Ultra (star)
All looks OK except the WiFi that cant be turned on and not working, tried to reflash, tried to flash using fastboot too, no luck... any idea what got corrupted?
First the flash was with the a13 twrp version, maybe there it corrupted something? anyways I thought reflash using the fastboot might fix it but still not, cant find anyone else here with same issue ;-(

Some logs :
Code:
04-17 07:57:47.342  1179  1179 E [email]android.hardware.wifi@1.0-service[/email]: Failed to access driver state control param No such file or directory, 2: No such file or directory
04-17 07:57:47.342  1179  1179 E [email]android.hardware.wifi@1.0-service[/email]: Failed to load WiFi driver
04-17 07:57:47.342  1179  1179 E [email]android.hardware.wifi@1.0-service[/email]: Failed to initialize firmware mode controller
04-17 07:57:47.343  1179  1179 E [email]android.hardware.wifi@1.0-service[/email]: Wifi HAL start failed
04-17 07:57:47.343  1872  3258 E HalDevMgr: Cannot start IWifi. Status: 9
04-17 07:57:47.343  1872  3258 E WifiVendorHal: Failed to start vendor HAL
04-17 07:57:47.343  1872  3258 E WifiNative: Failed to start vendor HAL
04-17 07:57:47.343  1872  3258 E WifiNative: Failed to start Hal
04-17 07:57:47.343  1872  3258 E WifiClientModeManager[55199262:unknown]: Failed to create ClientInterface. Sit in Idle
04-17 07:57:47.344  1872  3258 E WifiActiveModeWarden: ClientModeManager start failed!ConcreteClientModeManager{id=55199262 iface=null role=null}
04-17 07:57:47.344  1872  3258 D WifiScanRequestProxy: Sending scan available broadcast: false
04-17 07:57:47.344  1872  3269 I WifiScanningService: Received a request to disable scanning, UID = 1000
04-17 07:57:47.344  1872  3269 I WifiScanningService: wifi driver unloaded
04-17 07:57:47.345  1872  3258 I WifiScanRequestProxy: Scanning is disabled
04-17 07:57:47.345  1872  3258 I WifiCountryCode: No active mode, call onDriverCountryCodeChanged with Null
04-17 07:57:47.346  1872  3258 D WifiDfs : Wifi DFS report not enable.
04-17 07:57:47.346  1872  3258 E HalDevMgr: IWifiEventCallback.onFailure. Status: 9
04-17 07:57:47.346  1872  3258 E WifiHalHidlImpl: Cannot call isStarted because mWifi is null
04-17 07:57:47.346  1872  3258 I WifiNative: Vendor HAL died. Cleaning up internal state.
04-17 07:57:47.346  1872  3258 D WifiController: STA disabled, return to DisabledState.
04-17 07:57:47.346  9300  9300 I OsAgent : onReceive: android.net.wifi.action.WIFI_SCAN_AVAILABILITY_CHANGED
04-17 07:57:47.346  1872  3258 D WifiController: EnabledState.exit()
04-17 07:57:47.346  1872  3258 D WifiController: DisabledState.enter()
04-17 07:57:47.346  1872  3258 E WifiActiveModeWarden: One of the native daemons died. Triggering recovery
04-17 07:57:47.347  9300 12765 I OsAgent : updateWiFiScanAvailState, scanAvailable: false
04-17 07:57:47.347  1872  3258 E WifiSelfRecovery: Triggering recovery for reason: WifiNative Failure
04-17 07:57:47.347  1872  3258 E WifiSelfRecovery: Already restarted wifi 2 times in last 1 hour. Disabling wifi
04-17 07:57:47.347  1872  3258 D WifiController: Recovery has been throttled, disable wifi
Anyone any idea? ;-( tried reflash 3 times already no luck..
 
Last edited by a moderator:
Edit. Problem solved in #1601
I just clean install from Miui to HyperOS.
I facing a problem: if delete photo from Gallery, the photos in Google Photos delete too.
I turn off Automatic Download in Gallery, but Gallery still sync photos from Google to the phone.
That isn't work like Miui rom. Anyone know how to fix this?
 
Last edited:

Similar threads

  • Locked
HyperOS 1.0 24.5.27
Replies
90
Views
30K
  • Locked
HyperOS 1.0 24.5.13
Replies
198
Views
47K
  • Locked
HyperOS 1.0 24.5.20/21
Replies
76
Views
31K
  • Locked
HyperOS 1.0 24.4.22
Replies
205
Views
73K