Messenger Lite - Camera Button Isn't Working

Discussion in 'Xiaomi Redmi 4 / 4A / Pro / 4X' started by PooLee, Sep 17, 2017.

  1. PooLee

    PooLeeMembers

    Sep 17, 2017
    3
    1
    13
    Male
    Goszczyno, Poland
    Hello there :D
    I have to say that Messenger Lite is awesome alternative to his bloated brother. The same goes for Xiaomi.eu.
    The only thing I miss is..... quick photo make'n'send :p

    This button should open up your favourite camera app.
    [​IMG]
    When I was using MIU8 Global Dev, things worked flawlessly (how can they not?).
    Right after switching to Xiaomi.eu... guess what - it doesn't do anything :(
    You can click as much as you want. Nothing happens.

    I thought to myself "well, maybe it does need some more magical rights" and so I gave it everything it possible dreamt off... still nothing.

    Pics for some of you not thrusting my dedication :(
    h ttps://i.imgur.com/7u2dqgc.png
    h ttps://i.imgur.com/kUhPi5l.png

    I mean I still can send photos by just manually sharing them from gallery but...
    Why do you ignore me, oh lovely button? ... I just want him to talk to me again :(

    Is MIUI blocking option to start aplication from within another one? (Snapchat and normal Messenger doesn't use "Mi Camera", instead they implement it by their own)

    Oh and if u know better alternative to Messenger Lite - share it with me please, I'd love to have even more battery time!

    Cheers, m8's.
     
    coolpixs4 likes this.
  2. Midvik

    MidvikMembers

    Sep 30, 2017
    11
    1
    15
    Male
    Hi there, i just realized i have the same problem. Is this resolved?
    I can't find anything on google or forums and i don't want to use full messenger.. :/
     
  3. PooLee

    PooLeeMembers

    Sep 17, 2017
    3
    1
    13
    Male
    Goszczyno, Poland
    Nah, still no idea even where to start :/
     
  4. simkka

    simkkaMembers

    Jan 7, 2016
    26
    3
    13
    Same problem.
     
  5. Upo001

    Upo001Members

    Jun 20, 2016
    6
    1
    15
    Male
    Same here. If you dirty flash china developer rom on top of eu rom, without any wipes, camera button is working! Flash back to eu, again not working! And you can do it as many times as you want!
    We would have to undo the option "prevent apps from opening other apps" as in en.miui.com/thread-1156096-1-1.html (sorry can't post links yet).
     
  6. coolpixs4

    coolpixs4Members

    Oct 21, 2015
    37
    7
    20
    Male
    Me too, WTF ...I realized that I have the same problem. it is all working in the 'Fb messenger' but not work in 'messenger lite'.
    . Is there any solution to be resolved?
     
  7. ingbrzy

    ingbrzyXiaomi.eu Multilang leader
    Staff Member

    Check app permissions..
     
  8. coolpixs4

    coolpixs4Members

    Oct 21, 2015
    37
    7
    20
    Male
    [​IMG]
    [​IMG]
    Doesn't have. still problem
     
  9. Upo001

    Upo001Members

    Jun 20, 2016
    6
    1
    15
    Male
    Did you try it yourself? If it works, how you do it?

    Clearly reproducable any time!
    Start Messenger Lite, press camera button, nothing happens! Video:

    Get same version CN developer rom as eu rom. Dirty flash it, do not have to wipe anything, just reboot! Start Messenger Lite, and it works like it should! Video:

    Flash back EU rom, start Messenger Lite, and again not working! Flash CN dev, working! And so on...
    All permissions set of course, and with a dirty flash, all the permissions are the same, nothing changes during a dirty flash!
    The bug is somehow caused by the CN developer -> EU rom process, it must hide there somewhere!
     
    coolpixs4 likes this.
  10. ingbrzy

    ingbrzyXiaomi.eu Multilang leader
    Staff Member

    Does it work on Global ROMs?
     
  11. Upo001

    Upo001Members

    Jun 20, 2016
    6
    1
    15
    Male
    When I made videos, aug 2017, not worked on global roms. Don't know now, not using global roms.
    BTW I have Redmi Note 4 now, and the same issue.
     
  12. ingbrzy

    ingbrzyXiaomi.eu Multilang leader
    Staff Member

    so same issue on our ROM as on Global ROM?
     
  13. saijd

    saijdMembers

    Sep 21, 2017
    63
    15
    18
    Its issue on app not Miui Global and Xiaomi.eu
     
  14. Upo001

    Upo001Members

    Jun 20, 2016
    6
    1
    15
    Male
    Yes, the same. Only works on CN developer rom.

    saijd: if app issue, then how it works on CN developer rom?
     
  15. 5ulo

    5uloMembers

    May 25, 2012
    135
    15
    28
    Male
    Yep.. Weekly xiaomi.eu rom and the same issue..
     
  16. coolpixs4

    coolpixs4Members

    Oct 21, 2015
    37
    7
    20
    Male
    #16coolpixs4,May 9, 2018
    Last edited: May 14, 2018 at 10:51 AM
    I can confirm that this is the issue of eu and mi-globe rom porting.
    it's working fine in china and the original global rom, both dev and stable
    however, the same rom number in eu and mi-globe (eu modification) have this trouble.

    Still don't have any progress or solution ?
     
  17. coolpixs4

    coolpixs4Members

    Oct 21, 2015
    37
    7
    20
    Male
    #17coolpixs4,May 17, 2018 at 4:35 PM
    Last edited: May 18, 2018 at 1:14 AM
    I known what's happen

    Fix solution:

    Disable 3-way reboot menu & return to the original file services.jar in folder /system/framework/, problem solved
     
  18. Upo001

    Upo001Members

    Jun 20, 2016
    6
    1
    15
    Male
    What original services.jar? From china rom?
     
  19. coolpixs4

    coolpixs4Members

    Oct 21, 2015
    37
    7
    20
    Male
    It's depend on your Rom number you flahsed.
    The original is the one not apply patch services.jar to enable 3way reboot menu