Mi Max 2 Low Audio Bit Rate

Discussion in 'Xiaomi Mi Max 2' started by Johnnyman, Nov 9, 2017.

  1. Johnnyman

    JohnnymanMembers

    Nov 7, 2017
    31
    1
    10
    Male
    Hi guys!!!Currently im using latest eu dev rom and its very good!!Is it possible to raise audio bitrate while recording video from 96kbps to 156kbps?
    Thank you!
     
  2. Soebianto

    SoebiantoMembers

    Sep 15, 2017
    375
    207
    57
    Male
    Don't know if there is options somewhere in MIUI to do this easy way, but you can change the max audio bitrate by editing file '"/system/etc/media_profiles.xml" (you need root access)...

    find these text :
    <AudioEncoderCap name="aac" enabled="true"
    minBitRate="8000" maxBitRate="96000"
    minSampleRate="8000" maxSampleRate="48000"
    minChannels="1" maxChannels="6" />

    it's almost at the bottom of the file, and change maxBitRate to "156000", save the file and reboot and try shooting video.

    It worked for me.
     

    Attached Files:

    Johnnyman likes this.
  3. Johnnyman

    JohnnymanMembers

    Nov 7, 2017
    31
    1
    10
    Male
    It worked m8. Thank you very much.

    Don't mess with Max 2
     
  4. Soebianto

    SoebiantoMembers

    Sep 15, 2017
    375
    207
    57
    Male
    Xiaomi hardcoded the max audio bitrate in all their rom this way, so this trick should also works on other devices.

    Does the recorded sound actually better with higher bitrate?
     
  5. Johnnyman

    JohnnymanMembers

    Nov 7, 2017
    31
    1
    10
    Male
    I will make Long video tomorrow with car traffic etc and I will we will see.
    Also I enabled hevc format :)

    Don't mess with Max 2
     
  6. Soebianto

    SoebiantoMembers

    Sep 15, 2017
    375
    207
    57
    Male
    Cool, nice to have hevc format, hopefully our Max2 can record in hevc without any lag when recording.

    Please share with us your settings and result, thx.
     
    Johnnyman likes this.
  7. laurent48

    laurent48Members

    Dec 7, 2017
    5
    0
    1
    Male
    Thanks, it worked for me too.
     

Share Our Site