Mi4c Push Notifications Problem (msgs Arrive Late)


Oct 28, 2015
5
0
13
#1
Hello guys. Any of you with mi4c have problems with push notifications? (Whatsapp, Viber, messenger)

They arrive with an average latency of 2 to 15 minutes. This is not happening every time. I really can't find any pattern.

I already have the correct settings (autostart, lock in memory, allow popups, custom battery profiles to allow connectivity in background) but this drives me crazy.

Any thoughts?

I'm on latest Developer btw.
 

5ulo

Members
May 25, 2012
135
15
30
#3
Any user of mi4c is having those troubles ;-) I read that the problem is solved in the last version. Check out out

Sent from my Mi-4c using Tapatalk
 

5ulo

Members
May 25, 2012
135
15
30
#5
are you sure? there is no mention of solution in changelog of version 5.11.12...
which version are you talking about?
Sorry I read that in Czech / Slovak community forum. It was working yesterday for me too. Today it is terrible. Notifications and widget updates after turning display on.

Sent from my Mi-4c using Tapatalk
 
Nov 17, 2015
3
0
11
#6
I'm having exactly the same issue, I flashed my mi4c last week with the weekly ROM and noticed problems with push notifications, even for 30 minutes in whatsapp! With this weekly ROM I'm still suffering the same problem.
My colleague has a mi4i and flashed his xiaomi.eu weekly ROM also the last week, and in his terminal he is experiencing the same problem.
We also have all configurations in place (no energy management in apps, energy profiles desactivated, etc)
 

5ulo

Members
May 25, 2012
135
15
30
#7
I'm having exactly the same issue, I flashed my mi4c last week with the weekly ROM and noticed problems with push notifications, even for 30 minutes in whatsapp! With this weekly ROM I'm still suffering the same problem.
My colleague has a mi4i and flashed his xiaomi.eu weekly ROM also the last week, and in his terminal he is experiencing the same problem.
We also have all configurations in place (no energy management in apps, energy profiles desactivated, etc)
Try to lock WhatsApp in memory

Sent from my Mi-4c using Tapatalk
 
Nov 17, 2015
3
0
11
#8
Yes, I have it also locked in memory (recent apps) and no change. I'm also suffering problems with web.whatsapp, if the screen is off the website displays a connectivity issue
 
Oct 4, 2015
2,996
1,659
322
#12
Hello guys. Any of you with mi4c have problems with push notifications? (Whatsapp, Viber, messenger)

They arrive with an average latency of 2 to 15 minutes. This is not happening every time. I really can't find any pattern.

I already have the correct settings (autostart, lock in memory, allow popups, custom battery profiles to allow connectivity in background) but this drives me crazy.

Any thoughts?

I'm on latest Developer btw.

This problem also exists on my Redmi Notes 2
 
Mar 9, 2013
230
9
42
#15
Anybody bother to check their "battery manage app" settings?
See alse here: http://xiaomi.eu/community/threads/whatsapp-doesnt-notified-in-real-time.28801/
yes , i have tried to disable the option which miui controls the background apps and the problem stays. also for other programs like waze when you switch between apps in the background and go back to waze, the gps disconnects. also web whatsapp says phone not connected... i think all of this is the same problem.... could any of the stuff can approve ?

Sent from my Mi-4c using Tapatalk
 

5ulo

Members
May 25, 2012
135
15
30
#16
yes , i have tried to disable the option which miui controls the background apps and the problem stays. also for other programs like waze when you switch between apps in the background and go back to waze, the gps disconnects. also web whatsapp says phone not connected... i think all of this is the same problem.... could any of the stuff can approve ?

Sent from my Mi-4c using Tapatalk
Yep.. Waze, sometimes Tapatalk, viber delay,.. Only Telegram is working on 100%

Sent from my Mi-4c using Tapatalk
 

5ulo

Members
May 25, 2012
135
15
30
#18
OK so anyone experiencing this. any forum member can forward this to developers ?????? or this bug is under tests to fix ?

Sent from my Mi-4c using Tapatalk
As I wrote earlier this bug isn't only mi4c related and it's discussed across the whole forum so I suppose developers know about that.

Sent from my Mi-4c using Tapatalk
 
Nov 21, 2015
1
0
11
#22
I've also read about it in the official MIUI forums. It happens when screen is off, and only with WIFI. It is a bug with standby WIFI. Hope this gets fixed, it is a major issue, and my Mi4C is arriving soon:(