MIUI 14 MIUI 14 STABLE RELEASE


I have the same problem even turn off automatically update app in Google Store. Not sure wheather it is because the EU module?
Not related with EU Module and off topic.
Standard Playstore feature

There are several root based solutions, personally I use Update Locker (LSPosed module) not only for YT but also to prevent updates of the few more apps

ReVanced provides their own (separate) Magisk module to block updates, google for more info
 
  • Like
Reactions: JiaiJ
Hello everyone, I hope someone can help me. I have a redmi note 10 pro with the xiaomi.eu v14.0.9.0TKFMIXM rom (I updated it from the v13.0.12.0SKFMIXM rom) on the v13 rom I had magisk installed but I uninstalled it to update to v14 and now I cannot install magisk in v14, the package installer says that an error occurred and it does not install. If I flash through recovery, magisk 1.0 is installed and when I download the full version it stays downloading, I don't know what to do
 

Attachments

  • Screenshot_2024-01-03-18-50-37-119_com.miui.packageinstaller.jpg
    Screenshot_2024-01-03-18-50-37-119_com.miui.packageinstaller.jpg
    149 KB · Views: 98
Hi , yes, I'm updating my already Xiaomi.eu ROM. I have bootloader unlocked since
install with data format? this is related to img.boot partition. Try to reflash twrp. be careful as you might corrupt nvram. select compatible twrp for your unit.
 
Last edited:
  • Haha
Reactions: Bec de Xorbin
install with data format? this is related to img.boot partition. Try to reflash twrp. be careful as you might corrupt nvram. select compatible twrp for your unit.
I don't know how to do all that. Is it safe to cancel this batch job?
 
yes its safe but you cant boot your phone. best way is flash thru edl.
Hello, thanks for the replies, I forgot I got TWRP already. I cancelled the batch job. Pressed Volume up + Power to go to TWRP. Changed language to English. Then I Installed 14.0.3 ROM that I downloaded a while ago. Then rebooted.
 
  • Like
Reactions: laxer
Not related with EU Module and off topic.
Standard Playstore feature

There are several root based solutions, personally I use Update Locker (LSPosed module) not only for YT but also to prevent updates of the few more apps

ReVanced provides their own (separate) Magisk module to block updates, google for more info
Thank you so much for providing these infomation. I will look into it!!
 
  • Like
Reactions: zgfg12
Hi. Did you perhaps get this fixed, as I have same issue?
As already answered:
 
  • Like
Reactions: rovstov
I finally upgraded my Lisa to the latest Stable 14 with XiaomiEUModule (previously I was using a version from Nov without spoofing, and with Magisk and PIF)

I Installed latest XiaomiEUModule, rebooted and Play Integrity (Basic and Device) was passing, and everything was ok.
Thank you

Later I disabled XiaomiEUModule and installed again Magisk (Shamiko, etc) and PI Fork module, I followed this excellent guide and again everything worked (and still works) perfectly:
Thank you

I only had the issue with MS Teams crashing on launch, and I finally resolved by granting the missing Get Device Info permission to Teams:
https://xiaomi.eu/community/threads/microsoft-teams-keeps-crashing.69068/post-713610
 
I have no idea how to install kernel from 14.0.5 to 14.0.8.
Also cannot ask the developers for these things because they are too busy with other important stuff, and probably don't have time and energy for this.

Well you say the kernel is bad... So probably will stay on 14.0.5.
I suggest to sell it and buy a different phone with native DC dimming support.
Good day. drop here or email the kernel (boot.img) from the localized firmware from the eu 14.0.5 team.
The kernel is in the installation archive. . wrote in a personal message
 
Maybe someone has a kernel (boot.img) from the localized firmware from the eu 14.0.5 team.
The kernel is located in the installation archive.
 
for some reason though when i am on 14.0.5.0 i cant sync things anymore, Notes, "Frequent phrases" etc say "Sync was Interrupted. Try again."

Went back to 14.0.4.0 and it works there.

Btw, installing Lsposed and Shamiko breaks the GPay Module and results in not passing basic and device
 
Last edited:

Similar threads

  • Locked
HyperOS 1.0 24.5.27
Replies
90
Views
30K
  • Locked
HyperOS 1.0 24.5.13
Replies
198
Views
46K
Replies
82
Views
59K