MIUI-DEV WEATHER Help & Support


g123k

Members
Nov 23, 2010
9
11
I'm not using MIUI, but when clicking on the widget it FC.
Is it a normal behaviour ?
 

©#®i$

Members
Dec 12, 2010
29
11
Working perfect for me after ADB push of both files, thanks Mark, beautiful app! Hope you can add Dublin to the db soon, I'll use Belfast for testing purposes :p
I don't have root explorer, won't work with file explorer, I'm on an evo and it will not install.?? thanks
 

ZeroBarrier

Members
Nov 24, 2010
249
38
Okay I feel a little defeated. I tried moving the apk and db from the download location on my sdcard to /system/apps. attempter to install via root explorer and it says APP NOT INSTALLED. What am I doing wrong?

CDMA Desire

btw: i don't use adb. am i screwed?
What app did you use to move the apk? If you used root explorer or an equivalent, all you need to do is move the apk to /system/app/ then set the correct permissions to rw-r--r--

Read Write Execute
X X _
X _ _
X _ _

If you need to manually move over the DB file (I didn't need to, the app sucessfully created it properly), just move it to /data/data/com.miui.weather/databases/ and set the correct permissions to rw-rw----

Read Write Execute
X X _
X X _
_ _ _

And you're done! Let me know if you need any more help.
 

Garak

Members
Jan 21, 2011
76
16
I don't have root explorer, won't work with file explorer, I'm on an evo and it will not install.?? thanks
Follow Marks steps here:

Use adb, if you don't have it download the android sdk.

adb push file.apk /system/app

Replacing file.apk with the file name.

Same deal with the miui_city.db to /data/data/com.miui.weather/databases/

Thanks,

Mark
 
S

stiffspliff

step by step using root explorer

move miuiweather.apk to sdcard
open root explorer and navigate to /sdcard
long press on miuiweather.apk and hit COPY
navigate to /system/app
hit menu - PASTE (if it says you can't because its read only, hit the top right button mount r/w, then paste)
longpress on the miuiweather.apk in /system/app
select permissions
make checkboxes look like following: (where x indicates check, 0 indicates unchecked)
Read Write Execute
X ---- X ---- 0
X ---- 0 -----0
X ---- 0 ----0

(all three checkmarks in first column, first checkmark in second column)

same thing with the db file, except instead of /system/app, navigate to /data/data/com.miui.weather/databases/ to paste it
and permissions should look like this
X ---- X ---- 0
X ---- X -----0
0 ---- 0 ----0


you SHOULDNT "install" anything, just move the files to the proper places with proper permissions, and reboot.

i will look into making a flashable zip for each apk if there are still a lot of people having issues
 

mrchambo

Members
Nov 10, 2010
153
26
Mark,

Absolutely gorgeous and once installed, working great!

Worth every penny, pence or shilling....

Thanks, man.

JC
 

Garak

Members
Jan 21, 2011
76
16
It has started to just FC on me now even if I uninstall and push it again, not sure whats gone wrong.
 

matt992

Members
Nov 7, 2010
98
16
hey thanks for the hard work just wondering if there is support for Canada coming soon

thanks matt
 

TreyM

Member
Nov 24, 2010
378
42
The texas version of the app would not install. I dropped it into system/app and set permissions. Rebooted and it worked.

Fantastic work Mark!
 

GingaB

Members
Feb 10, 2011
170
28
Didnt work through root explorer! Had "parsing error". I hav adb so I added the apk/db file to the directory of sdk tools folder. debugged my phone and tried the commands but Im clearly not doing somthing right! Can somebody set me right??


C:\Users\GingaB>cd\

C:\>cd\android-sdk-windows\tools

C:\android-sdk-windows\tools>adb devices
List of devices attached
HTxxxxxxxxx device


C:\android-sdk-windows\tools>adb remount
remount succeeded

C:\android-sdk-windows\tools>adb push MIUIDev_Weather_EU_Beta.apk\system\app
Android Debug Bridge version 1.0.26

-d - directs command to the only connected USB devic
e
returns an error if more than one USB device is
present.
-e - directs command to the only running emulator.
returns an error if more than one emulator is r
unning.
-s <serial number> - directs command to the USB device or emulator w
ith
the given serial number. Overrides ANDROID_SERI
AL
environment variable.
-p <product name or path> - simple product name like 'sooner', or
a relative/absolute path to a product
out directory like 'out/target/product/sooner'.

If -p is not specified, the ANDROID_PRODUCT_OUT

environment variable is used, which must
be an absolute path.
devices - list all connected devices
connect <host>:<port> - connect to a device via TCP/IP
disconnect <host>:<port> - disconnect from a TCP/IP device

device commands:
adb push <local> <remote> - copy file/dir to device
adb pull <remote> [<local>] - copy file/dir from device
adb sync [ <directory> ] - copy host->device only if changed
(see 'adb help all')
adb shell - run remote shell interactively
adb shell <command> - run remote shell command
adb emu <command> - run emulator console command
adb logcat [ <filter-spec> ] - View device log
adb forward <local> <remote> - forward socket connections
forward specs are one of:
tcp:<port>
localabstract:<unix domain socket name>
localreserved:<unix domain socket name>
localfilesystem:<unix domain socket name>
dev:<character device name>
jdwp:<process pid> (remote only)
adb jdwp - list PIDs of processes hosting a JDWP transport

adb install [-l] [-r] [-s] <file> - push this package file to the device and i
nstall it
('-l' means forward-lock the app)
('-r' means reinstall the app, keeping its data
)
('-s' means install on SD card instead of inter
nal storage)
adb uninstall [-k] <package> - remove this app package from the device
('-k' means keep the data and cache directories
)
adb bugreport - return all information from the device
that should be included in a bug report.

adb help - show this help message
adb version - show version num

DATAOPTS:
(no option) - don't touch the data partition
-w - wipe the data partition
-d - flash the data partition

scripting:
adb wait-for-device - block until device is online
adb start-server - ensure that there is a server running
adb kill-server - kill the server if it is running
adb get-state - prints: offline | bootloader | device
adb get-serialno - prints: <serial-number>
adb status-window - continuously print device status for a specifie
d device
adb remount - remounts the /system partition on the device re
ad-write
adb reboot [bootloader|recovery] - reboots the device, optionally into the boo
tloader or recovery program
adb reboot-bootloader - reboots the device into the bootloader
adb root - restarts the adbd daemon with root permissions
adb usb - restarts the adbd daemon listening on USB
adb tcpip <port> - restarts the adbd daemon listening on TCP on th
e specified port
networking:
adb ppp <tty> [parameters] - Run PPP over USB.
Note: you should not automatically start a PPP connection.
<tty> refers to the tty for PPP stream. Eg. dev:/dev/omap_csmi_tty1
[parameters] - Eg. defaultroute debug dump local notty usepeerdns

adb sync notes: adb sync [ <directory> ]
<localdir> can be interpreted in several ways:

- If <directory> is not specified, both /system and /data partitions will be u
pdated.

- If it is "system" or "data", only the corresponding partition
is updated.

C:\android-sdk-windows\tools>
 

Bruce

Members
Feb 18, 2011
129
26
The California version of the app is working for me. I copied it to my SD card vis USB cable. Copied that to /system/app using ES File Explorer on my phone. The app showed up on my desktop and I found my city right away. I did not need to do anything with the city db file. It's a nice looking app, thank you for your work!
 

wezzybman

Members
Nov 15, 2010
71
16
Georgia version confirmed working on the Incredible. Great work guys, now I don't need that skinned Fancy widget anymore :)
 

The Batman

Members
Mar 3, 2011
382
40
When I try to download the city db I receive the following message: Download unsuccessful - Cannot download. The content is not supported on this phone.

Any ideas from anyone? As for "pushing" using adb, to be quite honest, I have no idea what that is or even how to start. I know this is going to end up being a pain for Mark, but if there is a layman's way of installing this application, I would be greatly appreciative.


The Batman
HTC Evo
MIUI v1.2.25
 

DarkNeo

Members
Nov 7, 2010
165
26
Installed via Root explorer, rebooted...stuck on loading screen. FML...


edit- booted into recovery, cleared cache and dalvik cache, all is good : )
 

Maverlck

Members
Mar 10, 2011
19
11
We would need the weather.com location magnet codes for your city, countries - this applies to anyone else who is experiencing missing locations. We added over 68 thousand locations to MySQL and SQLite, we will be looking to drop this in BETA 2.0 but for now this is what we have and we can do what we can to add more support for other locations.

Cheers,

Mark
Dude, How can I supply you this information? I made it with my own hand (verified weather.com) you can verify in weather.com


http://www.weather.com/weather/today/(code)
 

The Batman

Members
Mar 3, 2011
382
40
Downloaded the file through the xda developers website, and it still would not install.

I then went into recovery mode and wiped cache. I am bowed the proud new owner of the weather app hahahaaa!


The Batman
HTC Evo
MIUI v1.2.25

Sent from my PC36100 using the miui-dev.com Forums App