Resolved No lockscreen or home-menu (i9300)

Discussion in 'Bugs' started by CrazyGuy158, Jan 11, 2013.

  1. CrazyGuy158

    Mar 30, 2012
    24
    0
    11
    Male
    Hey guys and gals. I'm running the latest MIUI (3.1.11) and my device is an i9300 Galaxy S III (board name m0) and I have encountered two bugs.

    1. I have no lockscreen whatsoever, despite having set "slide" in the security menu in settings.
    2. I have no home-menu, i.e. the one that appears when you long-press the home-button.

    I can't really take a screenshot of something that doesn't exist. :p
     
  2. CrazyGuy158

    Mar 30, 2012
    24
    0
    11
    Male
    In fact, the home button doesn't work at all when the screen is on, I can't minimize any app. It only works to wake the device.
     
  3. CrazyGuy158

    Mar 30, 2012
    24
    0
    11
    Male
    Is anyone even reading this? I have literally been googling for hours on end, without any luck. Everything works back on stock Samsung rom, but as soon as I flash miui, these bugs show up. No one seems to know.
     
  4. CrazyGuy158

    Mar 30, 2012
    24
    0
    11
    Male
    I have done everything within my knowledge (wipe, format, the lot) and even tried previous versions of MIUI and still no lock screen or working power button. The funny thing is, it worked a few weeks ago when I ran miui. (2.12.21) but now when I tried 2.12.21, it doesn't work.

    I suspect that something outside of /system is messing with me. Maybe something in the /efs partition although that exceeds my knowledge.
     
  5. ingbrzy

    ingbrzyXiaomi.eu Multilang leader
    Staff Member

    try flash stock FW with repartition in ODIN and install again MIUI...
     
  6. CrazyGuy158

    Mar 30, 2012
    24
    0
    11
    Male
    I am currently on stock (though rooted) Samsung firmware (Jellybean 4.1.2). The re-partition thing isn't a smart thing to do on a device like the Galaxy S3.
     
  7. CrazyGuy158

    Mar 30, 2012
    24
    0
    11
    Male
    I'm at my wits' end, guys. My phone doesn't like MIUI :p
     
  8. CrazyGuy158

    Mar 30, 2012
    24
    0
    11
    Male
    Solved. I flashed miui without flashing gapps, then rebooted and went through setup, then rebooted and flashed gapps. Now everything works. :D
     
  9. ingbrzy

    ingbrzyXiaomi.eu Multilang leader
    Staff Member

    I told you.. lol...
     
  10. ezhik

    ezhikMembers

    Jun 2, 2012
    122
    28
    38
    Male
    Agreed. That is the resolution for sure for home button not working. Flash MIUI, go through the setup, reboot into recovery and flash gapps!
     
  11. androsland

    androslandMembers

    Mar 12, 2013
    3
    0
    21
    Male
    Nicosia, Cyprus
    and if nothing of that works?! I am on i9100 came from another custom rom, wiped everything, installed miui, went through setup, rebooted into recovery , installed gapps and still nothing works. Do you have anything else up in your sleeves?
     
  12. ezhik

    ezhikMembers

    Jun 2, 2012
    122
    28
    38
    Male
    check your exact model. There is more then one i9300 model. GT-i9300 is internationl. There are variants. I have a Galaxy S3 that is i747M, it is North American variant of i9300. Take out the battery and take a look.
     
  13. Prostor

    ProstorMembers

    Apr 9, 2013
    3
    0
    11
    Male
    I encountered this problem in 3.2.22 also on my HTC HD2.
    I was sending SMS to multiple contacts (4), and SMS app crashed suddenly during that and MiHome crashed with it too.
    After crash, all system settings went back to defaults, and lockscreen disappeared, home button lost it's touch. I tried everything but couldn't enable lockscren to work again, nor home button.
    I end up reflashing same rom version over existing, and that brought back the lockscreen and home button.
     

Share Our Site