[SOLVED] Ok google doesn't work


gulp79

Members
Aug 1, 2018
135
55
mmm not on xiaomi.eu release 8.11.23...
maybe we have to wait to have this bugfix also on xiaomi.eu
 

Dexer125

Members
Nov 20, 2016
63
20
When I've booted new update this popped up but as you said, when I'm trying to set toggle ON it doesn't work, it just get back to off position.
Here's a video ----> YT


Sent from my MI 8 using Tapatalk
 

Gunshin82

Members
Aug 9, 2018
38
20
When I've booted new update this popped up but as you said, when I'm trying to set toggle ON it doesn't work, it just get back to off position.
Here's a video ----> YT


Sent from my MI 8 using Tapatalk
Same here.

Edit: I didn't do a clean install of 8.11.23 but I did remove the update of the Google application as well as deleting the data attached to it. Reinstalled the update a tried to configure OK Google.

Envoyé de mon MI 8 en utilisant Tapatalk
 

josua98x

Members
Jul 14, 2018
20
15
Same here.

Edit: I didn't do a clean install of 8.11.23 but I did remove the update of the Google application as well as deleting the data attached to it. Reinstalled the update a tried to configure OK Google.

Envoyé de mon MI 8 en utilisant Tapatalk
did a clean install, still nothing :(
 

myfluxi

Members
Oct 31, 2018
24
15
I guess, ingbrzy is reading here and is trying things out (even the useless stuff in the feature xml). He added Oreo HotwordEnrollment apks to priv-apps, not sure why he didn't use Pocos Pie apks.

However, even with Pie apks hotword detection does not work. I can enable voice match just fine but some audio or soundtrigger HAL will malfunction anyway.

A diff of the original CN 8.11.15 and 8.11.23 didn''t show anything of significance.

Something else: ingbrzy, why do you patch fstab.qcom so encryption is broken for us (unless we revert this change)?
 
Last edited:

gulp79

Members
Aug 1, 2018
135
55
On global 8.11.23 ok google is working, hope to see the fix soon on xiaomi.eu (if xiaomi port the fix to china rom or if some dev here will find a way to fix this bug)
 

Gunshin82

Members
Aug 9, 2018
38
20
On global 8.11.23 ok google is working, hope to see the fix soon on xiaomi.eu (if xiaomi port the fix to china rom or if some dev here will find a way to fix this bug)
Hi gulp79,
You've managed to get confirmation about Global?

Envoyé de mon MI 8 en utilisant Tapatalk
 

gulp79

Members
Aug 1, 2018
135
55
Hi gulp79,
You've managed to get confirmation about Global?

Envoyé de mon MI 8 en utilisant Tapatalk
A lot of users on google board confirmed that is working on global beta 8.11.23.
Not on China or xiaomi.eu atm
Btw, I've not tested personally.
 

Gunshin82

Members
Aug 9, 2018
38
20
A lot of users on google board confirmed that is working on global beta 8.11.23.
Not on China or xiaomi.eu atm
Btw, I've not tested personally.
Noted, thanks!
A step forward in the right direction. It's just a matter of time before they get it working on xiaomi.eu.

Envoyé de mon MI 8 en utilisant Tapatalk
 
  • Like
Reactions: optical and bzero86

Dexer125

Members
Nov 20, 2016
63
20
I can retrain my voice model but when I'm in system and say OK or Hey Google nothing happens.

Sent from my MI 8 using Tapatalk
 

Damiaen

Members
Nov 1, 2018
6
13
Today I have downloaded latest beta 8.11.29 and that's all. The first thing what I do after flash new update is checking ok Google setting. This time I could toggle voice match and ok Google has started working. Usually, every day I'm using polish language and it's working also. I changed language for this screen. Funny thing, I didn't do nothing special. My mi 8 came from China and for today ok Google wasn't working.
Screenshot_2018-12-01-11-28-09-547_com.google.android.googlequicksearchbox.png
Screenshot_2018-12-01-11-27-58-896_com.google.android.googlequicksearchbox.png
 

Dexer125

Members
Nov 20, 2016
63
20
ROM Has been reuploaded and ingbrzy said that OK Google Fixed.

Sent from my MI 8 using Tapatalk
 

gulp79

Members
Aug 1, 2018
135
55
I've just installed the new 8.11.29 (was released a second time with some fixes) with magisk 17.3 and Sphinx kernel 1.9...
Now my Ok Google is working....
I can also wake the phone when is sleeping (but can't unlock it)...
Till now seem that all is working!
 

Dexer125

Members
Nov 20, 2016
63
20
It's working but when I clear the ram, I cannot access assistant with voice, firstly I must open the Google app.

Sent from my MI 8 using Tapatalk
 

Gunshin82

Members
Aug 9, 2018
38
20
I've just installed the new 8.11.29 (was released a second time with some fixes) with magisk 17.3 and Sphinx kernel 1.9...
Now my Ok Google is working....
I can also wake the phone when is sleeping (but can't unlock it)...
Till now seem that all is working!
Same here, it won't unlock but it wakes phone.
It's working but when I clear the ram, I cannot access assistant with voice, firstly I must open the Google app.

Sent from my MI 8 using Tapatalk
Try locking the app in the app switch screen.

Envoyé de mon MI 8 en utilisant Tapatalk
 

Dexer125

Members
Nov 20, 2016
63
20
I've noticed that it needs some time to "wake up" after ram cleaning. And about that unlocking, I asked ingbrzy and he laughed me up and said that I have to ask the Google. But, what the Google have to do with it? This option is here but not works on MIUI so it's MIUI problem, not Google's.

Sent from my MI 8 using Tapatalk
 

humrum

Members
Nov 14, 2018
15
15
I've noticed that it needs some time to "wake up" after ram cleaning. And about that unlocking, I asked ingbrzy and he laughed me up and said that I have to ask the Google. But, what the Google have to do with it? This option is here but not works on MIUI so it's MIUI problem, not Google's.

Sent from my MI 8 using Tapatalk
Probably if you protect Google app from being closed, it would "fix" this issue