TWRP / Orangefox / PitchBlack recovery for Redmi Note 9 Pro (Joyeuse)


Darnok09

Members
Aug 12, 2020
3
13
Ok, i install twrp, ROM.eu 11.0.5.0, everything works very well. But! Installed Magiel, and heres come the trouble, because when i want install xposed (just for yt vanced), reebot, and here we have bootloop. Phone restart to fastboot. Anybody knows how to root properly?
Sorry for my english
 

rbarat

Members
Apr 17, 2019
398
67
Ok, i install twrp, ROM.eu 11.0.5.0, everything works very well. But! Installed Magiel, and heres come the trouble, because when i want install xposed (just for yt vanced), reebot, and here we have bootloop. Phone restart to fastboot. Anybody knows how to root properly?
Sorry for my english
What is Magiel? Do you mean Magisk?

Magisk works well, I use it also. Install Magisk ONLY from official source
This looks like a problem with the Xpossed module. It may be incompatible with Android 10 or MIUI. You must use the correct module.
 
Last edited:

cuvetto

Members
Apr 19, 2017
15
15
I'm trying to help you and find out why this only happens to you.
This TWRP is used by a lot of people, no one has the problem but you.

IDK.... I have this problem!

As I wrote, Sniper did not install the procedure, which I strongly recommend in the first post. Once TWRP has been installed exactly as instructed, it already works fine.


Did you install it exactly according to the instructions? Including formatting Data partition?

Of course!! Every single step!

These two steps from instructions are critical if not performing, TWRP may not work properly:
-In TWRP click on Wipe, then on Format Data -> type "yes" (this will decrypt the phone)
-Now you need to restart the phone to TWRP (in TWRP click on the Reboot button, then click on the Recovery button) !!! ( important, otherwise it will not work)


What lockscreen protection method do you have set? I use a PIN and a fingerprint. When jumping to TWRP, then entering the PIN code is then required.
Try switch off any lockscreen protection method and try TWRP.

I have the PIN (no pattern and not fingerprint), and of course, when I enter on TWRP, it ask for me the PIN. I put it, and it work perfectly!

BTW: Why you do this? " the problem is only when I screen off and I want use it again"

When you are on TWRP, if you don't use it for long time, the screen switch off. In order to use it again, I must unlock through swipe, but it doesn't work for me!!
 

rbarat

Members
Apr 17, 2019
398
67
I originally understood that slider doesn't work for you when you turn off the screen in TWRP by pressing the Power button.

What you wrote now is a different situation, so I'll try to test the slider in case the screen turns itself off.
 
Last edited:

cuvetto

Members
Apr 19, 2017
15
15
Before, I understood that it doesn't work for you when you turn off the screen in TWRP by pressing the Power button.

Is the same. The screen can be turned off either by pressing the power button for a moment or by waiting for the stand-by time. In both cases, the result is the same. To return to TWRP I have to swipe, but it is not possible.
 

rbarat

Members
Apr 17, 2019
398
67
I don't understand what's different about your phone, because no one else from the many people who use TWRP has this problem.

I'm sorry, but it looks like you didn't install it well or your install file has been corrupted, it happens.

Download installation file again and make new installation.

Snajper89 had problems, when he performed the new installation really exactly according to the instructions, the problems miraculously disappeared.

I can't give you better advice.
 
Last edited:

cuvetto

Members
Apr 19, 2017
15
15
Did you really install the phone exactly as instructed?

These two steps from instructions are critical if not performing, TWRP may not work properly:
-In TWRP click on Wipe, then on Format Data -> type "yes" (this will decrypt the phone)
-Now you need to restart the phone to TWRP (in TWRP click on the Reboot button, then click on the Recovery button) !!! ( important, otherwise it will not work)

Did you do it? It's really important.

It would be best to do the whole installation process again. Snajpet89 had various problems, when he performed the new installation exactly according to the instructions, the problems miraculously disappeared.

I think you have to ask me at least 3 more times, otherwise I can't understand it .....
Anyway, just to confirm, I redid the whole procedure and the problem persists.

P.S. I HAVE DONE IT!!
These two steps from instructions are critical if not performing, TWRP may not work properly:
-In TWRP click on Wipe, then on Format Data -> type "yes" (this will decrypt the phone)
-Now you need to restart the phone to TWRP (in TWRP click on the Reboot button, then click on the Recovery button) !!! ( important, otherwise it will not work)

P.P.S.
I'm a developer and worked to many TWRP and firmware for other devices.....I know android. If I tell you that I added italian language on this TWRP, I think that I know how to install it....don't you think? I know follow a guide!
 

Yemble

Members
Oct 6, 2019
160
40
I think you have to ask me at least 3 more times, otherwise I can't understand it .....
Anyway, just to confirm, I redid the whole procedure and the problem persists.

P.S. I HAVE DONE IT!!
These two steps from instructions are critical if not performing, TWRP may not work properly:
-In TWRP click on Wipe, then on Format Data -> type "yes" (this will decrypt the phone)
-Now you need to restart the phone to TWRP (in TWRP click on the Reboot button, then click on the Recovery button) !!! ( important, otherwise it will not work)

P.P.S.
I'm a developer and worked to many TWRP and firmware for other devices.....I know android. If I tell you that I added italian language on this TWRP, I think that I know how to install it....don't you think? I know follow a guide!
Do all versions of Joyeuse use the same screen manufacturer? I seem to recall a similar TWRP issue discussed on XDA for Curtana.
 

rbarat

Members
Apr 17, 2019
398
67
Cuvetto,

I'm finishing this discussion, I'm tired. I have nothing more to advise you. Sorry, I don't know why you only have this problem.

If this TWRP doesn't suit you, try Pitch Black recovery, which already exists. But it is also an unofficial version.

You can also wait for the official TWRP version.
 
Last edited:

cuvetto

Members
Apr 19, 2017
15
15
Do all versions of Joyeuse use the same screen manufacturer? I seem to recall a similar TWRP issue discussed on XDA for Curtana.

This can be an option to elaborate on. Do you have a link about this post, in order to go to follow the discussion? Thanks!
 

cuvetto

Members
Apr 19, 2017
15
15
Cuvetto,

I'm finishing this discussion, I'm tired. I have nothing more to advise you. Sorry, I don't know why you only have this problem.

If this TWRP doesn't suit you, try Pitch Black recovery, which already exists. But it is also an unofficial version.

I do not seem to have said that it does not satisfy me, I just reported a bug and I was talking about it to understand if it was a problem for all or only some and in any case address it to solve it. I have always used and created TWRP and have no intention of changing.
Surely I did not get the installation procedure wrong and in any case another user also reported the same thing.
Let's see if maybe it could be a compatibility problem with my phone. I deepen and let you know!
Anyway, thank for your help!
 

rbarat

Members
Apr 17, 2019
398
67
Surely it would be best to have the official TWRP version. This is the best custom TWRP we have so far.
 
Last edited:

rbarat

Members
Apr 17, 2019
398
67
So you're only the second person who report it. Maybe it's really, as someone mentioned here, that our phone uses two types of displays or something.
Fortunately, this trifle does not prevent the normal use of TWRP. For me personally, the slider always works.

The solution for you and Cuvetto is to turn off the screen timeout counter in TWRP settings:
- Settings / 3rd icon / switch off Enable screen timeout
 
Last edited:

SISPANAGHS

Members
Mar 4, 2018
26
15
Read here, at the end of the post: https://xiaomi.eu/community/threads...or-redmi-note-9-pro-joyeuse.56896/post-556515

I installed the TWRP throug automatic installer from 4PDA following the guide (all perfect, I also installed the rom xiaomi.eu 11.0.5 whitout any problem) and I have the problem. I installed again from adbshell with iso file but the situation is the same. I edited also the TWRP, added italian language, repack and flash it again and I have always the same problem with "swipe to unlock" after screen off.
If I switch on the TWRP and I begin to use it, I can swipe normally, the problem is only when I screen off and I want use it again!
hello.can you edit with Greek lang to try?thanks
 

alshoc

Members
Nov 28, 2018
8
15
[QUOTE = "rbarat, publicación: 556862, miembro: 235423"]
Así que solo eres la segunda persona que lo denuncia. Tal vez sea realmente, como alguien mencionó aquí, que nuestro teléfono usa dos tipos de pantallas o algo así.
Afortunadamente, esta bagatela no impide el uso normal de TWRP. Para mí, personalmente, el control deslizante siempre funciona.

La solución para usted y Cuvetto es apagar el contador de tiempo de espera de la pantalla en la configuración de TWRP:
- Configuración / tercer icono / apagar Habilitar el tiempo de espera de la pantalla
[/CITAR]


Yo tengo el mismo problema, tengo que reiniciar el dispositivo hasta que me muestre el desbloqueo con patrón, funciona bien, sin embargo, aparece esta falla, de hecho la versión no oficial de Curtana también tiene ese problema
 

rbarat

Members
Apr 17, 2019
398
67
[QUOTE = "rbarat, publicación: 556862, miembro: 235423"]
Así que solo eres la segunda persona que lo denuncia. Tal vez sea realmente, como alguien mencionó aquí, que nuestro teléfono usa dos tipos de pantallas o algo así.
Afortunadamente, esta bagatela no impide el uso normal de TWRP. Para mí, personalmente, el control deslizante siempre funciona.

La solución para usted y Cuvetto es apagar el contador de tiempo de espera de la pantalla en la configuración de TWRP:
- Configuración / tercer icono / apagar Habilitar el tiempo de espera de la pantalla
[/CITAR]


Yo tengo el mismo problema, tengo que reiniciar el dispositivo hasta que me muestre el desbloqueo con patrón, funciona bien, sin embargo, aparece esta falla, de hecho la versión no oficial de Curtana también tiene ese problema
The solution for you and Cuvetto is to turn off the screen timeout counter in TWRP settings:
- Settings / 3rd icon / switch off Enable screen timeout
 

sir_bazz

Members
Jun 18, 2020
138
40
The solution for you and Cuvetto is to turn off the screen timeout counter in TWRP settings:
- Settings / 3rd icon / switch off Enable screen timeout
Thanks for that. I had considered that as a workaround and it should work for anyone who wants to use that build of TWRP, at least until it gets fixed.

Personally I'm gonna stick with Pitch Black as they're committed to supporting our device and are putting a lot of effort into providing us with a more polished recovery.
 

delboy

Members
Oct 5, 2015
157
55
I just done this on my wife's Joyeuse. Everything works as it should. Just follow the instructions from first post. It's the classic for first install of recovery. Important is to format data with "yes" and to reboot back to recovery, not to system. Thank you very much.
 

rbarat

Members
Apr 17, 2019
398
67
Thank you for confirming the correctness of the instructions.
All you have to do is follow the instructions exactly and the installation is hassle-free.
 
  • Like
Reactions: delboy

androik

Members
Apr 12, 2018
51
20
Hello, I am really tempted to install this recovery, is there any way to avoid formatting the data? Thank you
 

alshoc

Members
Nov 28, 2018
8
15
[QUOTE = "androik, publicación: 557283, miembro: 191336"]
Hola, estoy realmente tentado de instalar esta recuperación, ¿hay alguna forma de evitar formatear los datos? Gracias
[/CITAR]

Instalar mediante fastboot ROM versión 11.0.4, instalando previamente 11.0.2 según el procedimiento:


Later install TWRP 3.4.1B through this methodology:


and finally install version 11.0.5, it worked for me this way without having to delete data
 
  • Like
Reactions: androik

cuvetto

Members
Apr 19, 2017
15
15
So you're only the second person who report it. Maybe it's really, as someone mentioned here, that our phone uses two types of displays or something.
Fortunately, this trifle does not prevent the normal use of TWRP. For me personally, the slider always works.

I understood what's the problem! Isn't caused by the wrong way of following the procedure and installation, but is simply linked to the panel adopted on your terminal.
This model (RN9P) uses two different panel versions: "Tianma" or "Huaxing".
My terminal has a "Tianma" panel and the bug is present. Can anyone else who has or does not have the "Swipe to unlock" problem tell me which panel their phone uses?
 

delboy

Members
Oct 5, 2015
157
55
I understood what's the problem! Isn't caused by the wrong way of following the procedure and installation, but is simply linked to the panel adopted on your terminal.
This model (RN9P) uses two different panel versions: "Tianma" or "Huaxing".
My terminal has a "Tianma" panel and the bug is present. Can anyone else who has or does not have the "Swipe to unlock" problem tell me which panel their phone uses?
This is on my wife's Joyeuse. Everything works ok.
 

Attachments

  • IMG_20200815_163423.jpg
    IMG_20200815_163423.jpg
    179.4 KB · Views: 164

androik

Members
Apr 12, 2018
51
20
[QUOTE = "androik, publicación: 557283, miembro: 191336"]
Hola, estoy realmente tentado de instalar esta recuperación, ¿hay alguna forma de evitar formatear los datos? Gracias
[/CITAR]

Instalar mediante fastboot ROM versión 11.0.4, instalando previamente 11.0.2 según el procedimiento:


Later install TWRP 3.4.1B through this methodology:


and finally install version 11.0.5, it worked for me this way without having to delete data
Thank you for your answer, it seems to me a bit too much installation on top of the other, I'll wait a bit and see if our developer friends come up with something simpler