In Progress 3.1.11, 3.1.18, JLB 10, and JLB 11 - WPA2 wifi still broken


Dec 18, 2012
58
2
18
#1
Running JLB 11, trying to connect to "history8", the WPA2 AES access point. Android says it is "Secured with WPA/WPA2", however I know from Windows that the connection type is WPA2-Personal using AES (not TKIP). (Android can also say "Secured with WPA2" for different routers.)

After connecting with the correct password, Android changes the status of the network to "Saved, secured with WPA/WPA2", however the button stays grey, not orange, and logcat shows the phone tries and fails to connect every 1.4 seconds until the network is forgotten.

http://pastebin.com/AUXr541C

When the access point is changed from a mixed "WPA/WPA2" broadcast, to only "WPA2":
http://pastebin.com/n70XW521

So:
WPA2/AES (seen as "WPA/WPA2") broken.
WPA2/TKIP (seen as "WPA/WPA2") broken.
WPA2/AES (seen as "WPA2") broken.

The only setting I know that works is:
WPA/TKIP works. (seen as "WPA")

Last working version was JLB 7.0 Stable. (It is tested broken in 3.1.11, JLB 10 Stable, 3.1.18, and JLB 11 Stable.)

Using Mi 2.
 

iBotPeaches

Script Gatekeeper
Oct 31, 2011
3,811
1,122
335
#3
I cannot reproduce this issue from our side, please provide the model number of your access point . And your log is not enough to analysis, could you please help to catch a full log for us with following steps:

1. Try to connect your access point and reproduce the issue
2. Launch Dailer app and input *#*#284#*#*, then please wait a minute
3. Connect phone with a Windows PC, please get the log file from MI2 -> Internal storage -> MIUI -> debug_log. It is a zip file named by the log time.
4. Please attach the log file here or send to my email

Thanks a lot
 
Dec 18, 2012
58
2
18
#5
necrobump

I still don't have access to the router in question, but Windows 8 tells me that the wireless router that the newer kernels can't authenticate/connect to is made by MikroTik.