Not open for further replies.


Site Founder
Staff member
Nov 6, 2010
Status: Released!


Notice: GApps are no longer included!
Below are links for ICS & JB. Please download for which version you have.
Please flash ROM, REBOOT, and then flash Gapps.
Do NOT flash them back to back! It will cause Home button not working..!
Jellybean 4.1.x : http://d-h.st/JTW
Ice Cream Sandwich 4.0.x : http://d-h.st/Gyk

Changelog MIUI ROM 3.2.8 http://miuiandroid.com/community/threads/miui-rom-3-2-8-changelog.19580/
MULTI lang for 3.2.8 http://miuiandroid.com/community/threads/miui-multi-lang-3-2-8-ics-jb.19589/
Hossa, already building? :)
Looking forward to it and thx for all the hard work.
i tried the ota package but failed to update my current version. so need to wait for full package
will there be a build for Htc Inspire 4g ?

I very much doubt, its hard to say what devices will be supported in the coming weeks/months. Devices which are running 4.0 will cease to be officially supported after the chinese holiday. 4.0 is a terrible build and has so many bugs plus there are differences in the core. Android 4.1 will be the minimum and will be supported upwards to 4.2+ and these will become MIUI v5 eventually.

For any device to be supported it must have a large and stable user base, running Android 4.1+ and (GSM) and of course this is down to Xiaomi to decide and we follow suit.
Now you don't need to flash the gapps seperately? (Because I didn't find the gapps download here)
Hi Community,
can anyone port MIUI to HOX+ (enrc2b) ?
i don't understand enough about Linux, Android porting and so on...please help the HOX+ Community with MIUI.

greetings from Germany
Your statement completely wrong. This issue exist although hotfix came out on 3.2.1. See my previous post http://miuiandroid.com/community/threads/3-2-1.19508/page-2#post-153616

Well.. Completely wrong.... It was completely wrong in the morning, but after the bugfix in the afternoon is was wrong for only 1-5% of the users and you are one of them.

Sorry wrong link.
The fix was addressed in this quote. After your posts and after the PM failure of one of the moderators ;)
Have you tried to download the firmware, I don't see it in the answers after the bugfix.

Please re-download version 3.2.1 or this 3.2.8 version and tell us if you still encouter the same problem.
Not open for further replies.