[GUIDE][venus|star|mars] How to install Xiaomi.eu ROM for Xiaomi MI11 / Pro / Ultra


ingbrzy

Xiaomi.eu ROM leader
Staff member
Feb 11, 2012
10,397
322
I successfully unlocked and flashed my Chinese Mi 11 Ultra (M2102K1C) to the newest stable ROM: "xiaomi.eu_multi_MI11Pro_MI11Ultra_V12.5.2.0.RKACNXM_v12-11-fastboot.zip"
i followed every step of the guide and everything worked great, but unfortunately SafetyNet Test = failed (CTS profile match fail).

known issue with this ROM version? or did something went wrong? Any workarounds, advices?
seems Xiaomi didnt certified MIUI 12.5 stable yet.. install weekly or older stable version..
 

Soygdl

Members
Oct 18, 2016
6
13
[QUOTE = "Nameless50, publicación: 603140, miembro: 292164"]
Sé que solo quería preguntar si configuró el teléfono antes del flash o no, para que averigüemos cuál es la razón de todos estos dispositivos bloqueados.
[/CITA]

Yes after unlocking the bootloader configure everything and install Xiaomi EU, then just start in fastboot
 

Soygdl

Members
Oct 18, 2016
6
13
[QUOTE = "Nameless50, publicación: 603140, miembro: 292164"]
Sé que solo quería preguntar si configuró el teléfono antes del flash o no, para que averigüemos cuál es la razón de todos estos dispositivos bloqueados.
[/CITA]


Yes friend, when I unlock bootloader configure everything and then install Xiaomi EU ROM fastboot
 

iVeSKi

Members
Apr 7, 2021
14
5
this is my 1st time using xiaomi phone. after flashing process finishes, CMD closes but phone still in fastboot mode. Is it suppose to reboot right away? or wait 15min then reboot?
 

Poney70

Donator
Oct 3, 2019
3,653
337
SafetyNet Test = failed (CTS profile match fail).
When you see "CTS profile match" = fail, it means Xiaomi didn't certify this "Stable" ROM version. :(

It's generally the case for "Stable Beta" versions and this 12.5.2.0 is a "Stable Beta" version (https://xiaomifirmwareupdater.com/miui/star/). :)

Workaround is to use Magisk + "MagiskHide Props Config" module but you can also wait for a new "Stable" ROM version...

;)
 

Sentinel-Four

Members
Apr 8, 2021
2
3
So I tried to install 12.5.3 from 12.0.11 EEA yesterday. I got an error message while flashing (during step 6 or 7 of 8, something about slots). I found that error here in the forum and it was suggested to use an earlier version of Xiaomi.eu and/or flash China ROM first. An earlier version of Xiaomi.eu failed with the same error. Then I tried the China ROM via Mi Flash Tool but as it seems I crossed a point of no return. Flashing crashed with an error. I tried the Xiaomi ADB tools to go back to the EEA version I came from but after a restart to re-establish fastboot connection why mobile didn't turn on again. I still hear the USB connected/disconnected sounds when the phone is attached via cable to my PC, but the phone is not shown via ADB or fastboot.

Long story short: It got bricked and now I am sending it to the service center for repair. I guess they can easy re-flash the standard ROM and hopefully will not make a big fuss about the flashing accident.

Just be careful. Seems that not all flashing attempts run through smoothly. Someone here or an XDA asked if it is mandatory to flash China ROM first before installing Xiaomi.eu and that was denied, therefore I tried to install it directly. Maybe my fault, who knows.
 

splinson

Members
May 5, 2020
19
15
How can you be careful you do the instructions and it works or it doesn't work carefully you can't flash.

It would be better if there were instructions on how to be safe or a workaround that was safe. otherwise everything is just a coincidence.
 

billyken

Members
Apr 20, 2021
4
3
After install the 12.0.10EU, I stock in the fastboot mode and couldn't reboot. Is anybody know how to fix it? It's kind to have your help.
 

4fun20

Members
Feb 18, 2021
70
10
After install the 12.0.10EU, I stock in the fastboot mode and couldn't reboot. Is anybody know how to fix it? It's kind to have your help.
Did you allow the zip file content via right click/properties/allow?
Did you run powershell as admin?

I just try to find out if it's really a ROM issue?
Because I want to flash on Friday ☺.

Thanks for your reply.
 

digeratz

Members
Jan 15, 2019
47
20
Now flashing my m1 11 ultra but kind of stops at "Setting current slot to 'a' "

is this normal? been on that prompt for 5 minutes while writing this. I haven't disconnected the phone yet. still in fastboot.

36151


Edit: I've repeated and was successful but now just rebooting to fastboot. Any advice guys?
 
Last edited:

utumi11

Members
Apr 17, 2021
12
5
Now flashing my m1 11 ultra but kind of stops at "Setting current slot to 'a' "

is this normal? been on that prompt for 5 minutes while writing this. I haven't disconnected the phone yet. still in fastboot.

View attachment 36151

Edit: I've repeated and was successful but now just rebooting to fastboot. Any advice guys?
Probably this will not help but it is worth a chance. Put your phone in fastboot and open up fastboot in cmd on your computer then type
"fastboot set_active a" and then "fastboot erase metadata" followed by "fastboot - w" and finally "fastboot reboot"
 
  • Like
Reactions: Poney70
Apr 14, 2021
6
3
You can chose any "certified" fingerprint in the list. :)

But it's better to use a certified "Mi 11 Ultra" or "Mi 11 Pro" fingerprint, when available. ;)
Thanks, Does something else need doing as CTS still failing? Clear cache somewhere or something?

Thanks again
 

digeratz

Members
Jan 15, 2019
47
20
repeated again but still rebooting fastboot. then noticed message below "but not automatically formatting" what does it mean? :(

36152
 

Poney70

Donator
Oct 3, 2019
3,653
337
Thanks, Does something else need doing as CTS still failing? Clear cache somewhere or something?

Thanks again
If "CTS profile match test" is still failing after you applied a "certified" fingerprint (and rebooted your device), the question is => What ROM version are you using? ^^
 

digeratz

Members
Jan 15, 2019
47
20
Probably this will not help but it is worth a chance. Put your phone in fastboot and open up fastboot in cmd on your computer then type
"fastboot set_active a" and then "fastboot erase metadata" followed by "fastboot - w" and finally "fastboot reboot"

Did this but failed on formating. Did I just brick my phone? :(

36153
 
Apr 14, 2021
6
3
If "CTS profile match test" is still failing after you applied a "certified" fingerprint (and rebooted your device), the question is => What ROM version are you using? ^^
Its the latest stable, usually Magiskhide props can fix it though right?

Regards

EDIT - Tell a lie, seems to be working. It shows CTS API error but i just opened and logged in to my bank without issue when hidden in magiskhide
 
Last edited:

Poney70

Donator
Oct 3, 2019
3,653
337
Its the latest stable, usually Magiskhide props can fix it though right?
Yes, with "Termux" app you typed su (grant root access) then props command, right?

Then try this:

1. Type " 1 " to edit device fingerprint
2. Type " f " to pick a certified fingerprint
3. Type " 30 " to chose "Xiaomi"
4. Type " 29 " to chose "Xiaomi Mi 11 China (11)"
5. Type " y " to confirm it
6. Type " y " to reboot your device

SafetyNet should pass after reboot. ;)

If it's ok, I advise to clear "All app data" of these following apps in phone's settings:

- Google Play store
- Google Play services
- Google Service Framework

Then reboot your device.

:)
 

ingbrzy

Xiaomi.eu ROM leader
Staff member
Feb 11, 2012
10,397
322
ok.. try run command in fastboot:
Code:
fastboot erase boot_ab
and then run again our installation script..
use cmd, not powershell..
 
Apr 14, 2021
6
3
Yes, with "Termux" app you typed su (grant root access) then props command, right?

Then try this:

1. Type " 1 " to edit device fingerprint
2. Type " f " to pick a certified fingerprint
3. Type " 30 " to chose "Xiaomi"
4. Type " 29 " to chose "Xiaomi Mi 11 China (11)"
5. Type " y " to confirm it
6. Type " y " to reboot your device

SafetyNet should pass after reboot. ;)

If it's ok, I advise to clear "All app data" of these following apps in phone's settings:

- Google Play store
- Google Play services
- Google Service Framework

Then reboot your device.

:)
Thanks, I think i already had it working its just saying API error for safetynet. But banks open etc