Help, can't update RTC of my Mi2S so it went back to 1970 after every shutdown.

Discussion in 'Xiaomi Mi 2 / Mi 2S' started by RadarNyan, May 6, 2014.

  1. RadarNyan

    RadarNyanMembers

    Sep 10, 2013
    101
    44
    38
    Male
    #1RadarNyan,May 6, 2014
    Last edited: May 6, 2014
    EDIT: I'm temporary using a workaround and it works pretty fine, and I think it will continue work as long as my RTC clock keeps running...
    http://forum.xda-developers.com/showthread.php?p=52451847

    ---

    Recently I've noticed that my Mi2S can't remember the time goes back to 1970 after shutdown (even if I don't pull the battery)

    I installed busybox and used hwclock -r, shows:
    Sun Jan 4 15:25:49 1970 0.000000 seconds

    And use date to check my local time (updated via network)
    Tue May 6 16:54:11 CST 2014

    But when I try to correct hwclock by using hwclock -w, I got this error:
    hwclock : RTC_SET_TIME: Invalid argument

    I can confirm that the hardware clock is running (the first time I noticed it was Jan 2 1970, and I do can see it running by using hwclock -r, it remains running between shutdown/reboots)

    I've tried to use hwclock -w on different roms (ivan's AOSP, m1cha's CM11, even using aromafm's build in console in CWM) and they all tells me the same error message.

    What can I do to correct the time? It's really annoying since I'll receive a bunch of error message from Google Service during each boot because I'm back in 1970, and it takes a minute or two for my phone to sync time from network.
     

Share Our Site