[rom][cm12.1] Last Hope Rom - Best Rom Ever? ;)


marvollo

Members
Jan 14, 2016
117
40
Sent me logs, I'll look on it.
about twitch problem, its logcat from my rom, but on yours bugi it shoud be the same, to reproduce the problem just install twitch app, open it and launch any stream, twitch force close

seems, like this it the main problem
W/AudioCapabilities(12710): Unsupported mime audio/evrc

W/AudioCapabilities(12710): Unsupported mime audio/qcelp

W/AudioCapabilities(12710): Unsupported mime audio/x-ms-wma

W/AudioCapabilities(12710): Unsupported mime audio/x-ms-wma

W/AudioCapabilities(12710): Unsupported mime audio/x-ms-wma

W/AudioCapabilities(12710): Unsupported mime audio/qcelp

W/AudioCapabilities(12710): Unsupported mime audio/evrc

W/VideoCapabilities(12710): Unsupported mime video/x-ms-wmv

W/VideoCapabilities(12710): Unsupported mime video/mpeg2

W/VideoCapabilities(12710): Unsupported mime video/mpeg2

W/VideoCapabilities(12710): Unsupported mime video/mp4v-esdp

I/VideoCapabilities(12710): Unsupported profile 4 for video/mp4v-es

W/AudioCapabilities(12710): Unsupported mime audio/vnd.rn-realaudio

W/AudioCapabilities(12710): Unsupported mime audio/mpeg-L2

W/AudioCapabilities(12710): Unsupported mime audio/ac3

W/AudioCapabilities(12710): Unsupported mime audio/x-ape

W/AudioCapabilities(12710): Unsupported mime audio/vnd.dts

W/AudioCapabilities(12710): Unsupported mime audio/ffmpeg

W/VideoCapabilities(12710): Unsupported mime video/x-ms-wmv

W/VideoCapabilities(12710): Unsupported mime video/vnd.rn-realvideo

W/VideoCapabilities(12710): Unsupported mime video/vc1

W/VideoCapabilities(12710): Unsupported mime video/x-flv

W/VideoCapabilities(12710): Unsupported mime video/divx

W/VideoCapabilities(12710): Unsupported mime video/ffmpeg

W/AudioCapabilities(12710): Unsupported mime audio/x-ape

W/AudioCapabilities(12710): Unsupported mime audio/ffmpeg

W/AudioCapabilities(12710): Unsupported mime audio/vnd.dts

W/AudioCapabilities(12710): Unsupported mime audio/mpeg-L2

W/AudioCapabilities(12710): Unsupported mime audio/vnd.rn-realaudio

W/AudioCapabilities(12710): Unsupported mime audio/x-ms-wma

W/VideoCapabilities(12710): Unsupported mime video/divx

W/VideoCapabilities(12710): Unsupported mime video/x-flv

W/VideoCapabilities(12710): Unsupported mime video/mpeg2

W/VideoCapabilities(12710): Unsupported mime video/vnd.rn-realvideo

W/VideoCapabilities(12710): Unsupported mime video/vc1

W/VideoCapabilities(12710): Unsupported mime video/ffmpeg

W/VideoCapabilities(12710): Unsupported mime video/x-ms-wmv
 

Attachments

  • logcat.txt
    58.5 KB · Views: 435
Last edited:

bugers

Members
Sep 19, 2015
157
155
Hi buggers, I ask you if you are working in cm12.1rc7(?) or cm13, to fix wifi issues and maybe camera. I think you are one of two people who is developing for mi2 in the world (with marvolo?)
Thanks

Yeap, I'm still on it ;) New version is pretty huge in case of changes. Most of you won't see them on first look (they are under the hood) so be ready for more performance and stability. I'm testing last cherries now and if everything goes smooth you will see next release.

About wifi -> I didn't get any issues nor bug reported after RC6. To be honest I'm rather sure that I didn't get any reports after RC6, so why you are asking about this? ;) Everything should be fine ;)

Camera is pretty funny thing. I'm really happy how is it working now, after month of last changes I got it always running when I needed ;) If you experience any problems, send logs. I'll look on them and fix If it's possible but can't promise nothing it's closed area, sorry. Company of our phones is not open for other developers.
 
Last edited:

bugers

Members
Sep 19, 2015
157
155
about twitch problem, its logcat from my rom, but on yours bugi it shoud be the same, to reproduce the problem just install twitch app, open it and launch any stream, twitch force close

If you have working phone after this crash get this file and send it to me: adb pull /data/tombstones/tombstone_03
 

gonzametal

Members
Feb 11, 2014
71
30
About wifi -> I didn't get any issues nor bug reported after RC6. To be honest I'm rather sure that I didn't get any reports after RC6, so why you are asking about this? ;) Everything should be fine ;)

After a clean install (with opengapps) there is a wifi issue. The problem is the following:

I am connected to a wifi access point and using browser, or some app. Everything is ok. Then I leave the phone for a while, and when I come back and unlock it, the wifi is disconnected. So I long touch the wifi toogle (to see if the SID is missing) and at this moment, the connection is back again.

Another issue is the system becomes a bit slow and needs to be rebooted (once every 3 or 4 days)
 

marvollo

Members
Jan 14, 2016
117
40
Another issue is the system becomes a bit slow and needs to be rebooted (once every 3 or 4 days)

i think its because of power save, its wrong on bugers rom, we should leave it clean as in vanilla cm/aosp, or update it on bugi rom
 

gonewild

Members
Apr 16, 2013
300
52
About wifi -> I didn't get any issues nor bug reported after RC6. To be honest I'm rather sure that I didn't get any reports after RC6, so why you are asking about this? ;) Everything should be fine ;)

Camera is pretty funny thing. I'm really happy how is it working now, after month of last changes I got it always running when I needed ;) I you experience any problems, send logs. I'll look on them and fix If it's possible but can't promise nothing it's closed area, sorry. Company of our phones is not open for other developers.
Clean install here, f2fs and I am using miui camera you included as default camera.

- I still got the same issue with camera on rc6 (I sent you log with rc5 ). The camera of whatsapp is the one who "can't connect" more often in my experience.

- WiFi is fine here. Sometimes when I switched from 3g to wifi, it is impossible to connect to wifi (usually when camera can't connect). The flashlight the same (sometimes you power on the flashlight and you cannot power off without rebooting the phone)

- after 24 hours of average use (browser, social, call phone, youtube) it is often laggy, reboot solve all.

But I know you need logs for all these things. I can live with that,so I am just writing you my personal experience.
You are doing your best, thank you for all your efforts!
 

MiKhan

Members
Sep 21, 2013
217
52
Similar experience here. I use mostly Miui camera and try to quit from it using the "back" key instead of "home". occasionally, it cannot connect, but not very often.
WiFi seems to work stable now (with the exception of a few days after upgrade to RC6).
Regarding the low memory: I installed some of the automation tools and let my phone reboot every night. Not the best solution, since I have to log in some apps (keepass).

But in general, I am happy.
 

Ricardo TOUZON

Members
Dec 12, 2013
29
15
I have the WiFi issue when the phone is sleep the WiFi disconetct and when I switch on the screen the WiFi is on again.

Enviado desde mi ONE E1003 mediante Tapatalk
 

Jezura

Members
Jul 8, 2015
57
20
i think its because of power save, its wrong on bugers rom, we should leave it clean as in vanilla cm/aosp, or update it on bugi rom
Nope, you can see in settings -> apps that the memory usage of system is growing. At the beginning it's around 400 MB but it will raise to 0,9-1 GB in few days
 
  • Like
Reactions: gonewild

marvollo

Members
Jan 14, 2016
117
40
Nope, you can see in settings -> apps that the memory usage of system is growing. At the beginning it's around 400 MB but it will raise to 0,9-1 GB in few days
then seems we have classic memory leak, we need to check all cycles and recursions
 
  • Like
Reactions: bialabs

bugers

Members
Sep 19, 2015
157
155
Clean install here, f2fs and I am using miui camera you included as default camera.

- I still got the same issue with camera on rc6 (I sent you log with rc5 ). The camera of whatsapp is the one who "can't connect" more often in my experience.

- WiFi is fine here. Sometimes when I switched from 3g to wifi, it is impossible to connect to wifi (usually when camera can't connect). The flashlight the same (sometimes you power on the flashlight and you cannot power off without rebooting the phone)

- after 24 hours of average use (browser, social, call phone, youtube) it is often laggy, reboot solve all.

But I know you need logs for all these things. I can live with that,so I am just writing you my personal experience.
You are doing your best, thank you for all your efforts!

ad1. would be great to get logs when using camera in whatsapp. Anyone?
ad2. Please check if wifi has Internet connectivity. When u r using 3g -> wifi def route is still on 3g network until wifi has Internet connectivity.
ad3. yeap, it happened to me last time too. It should be much better now with new version.

Thank you for good words! ;)
 

bugers

Members
Sep 19, 2015
157
155
Similar experience here. I use mostly Miui camera and try to quit from it using the "back" key instead of "home". occasionally, it cannot connect, but not very often.
WiFi seems to work stable now (with the exception of a few days after upgrade to RC6).
Regarding the low memory: I installed some of the automation tools and let my phone reboot every night. Not the best solution, since I have to log in some apps (keepass).

But in general, I am happy.

As I told previously last two things should be much better now. Wait for new version.
Great to see that you're happy ;)
 
  • Like
Reactions: kamakasnh

bugers

Members
Sep 19, 2015
157
155
I have the WiFi issue when the phone is sleep the WiFi disconetct and when I switch on the screen the WiFi is on again.

Enviado desde mi ONE E1003 mediante Tapatalk

Is this bad? ;) If your phone is sleeping why to wake up? Does this break anything for you?
 

Jezura

Members
Jul 8, 2015
57
20
Is this bad? ;) If your phone is sleeping why to wake up? Does this break anything for you?
The problem is, that this is controllable in settings (wifi -> advanced settings -> wifi active in sleep) but whatever you set the phone disables wifi during sleep. For me it's about battery life. 3G drains battery much faster. For others without 3G it could mean that they don't recieve notifications from apps.
 

bugers

Members
Sep 19, 2015
157
155
The problem is, that this is controllable in settings (wifi -> advanced settings -> wifi active in sleep) but whatever you set the phone disables wifi during sleep. For me it's about battery life. 3G drains battery much faster. For others without 3G it could mean that they don't recieve notifications from apps.

What I was trying to say is that if are you sure that this really disconnects phone from Wifi?
 
Last edited:

Jezura

Members
Jul 8, 2015
57
20
What I was try to say is that are you sure that this really disconnects phone from Wifi?
I think so. I usually get some minimal data usage (<1MB) during night, when my phone is on charger and wifi. The same happens during day, when I'm connected to school wifi. If you want me to I can try and test this more. For me it doesn't matter that much (pretty good dataplan), but I can understand it could be annoying for others.
 

acastrocab

Members
Feb 12, 2014
185
38
I think so. I usually get some minimal data usage (<1MB) during night, when my phone is on charger and wifi. The same happens during day, when I'm connected to school wifi. If you want me to I can try and test this more. For me it doesn't matter that much (pretty good dataplan), but I can understand it could be annoying for others.
Well for me works good i never have wifi problem(i have but comes from the router ..i think i have the worst in the earth) the data usage at night may come from the 5.1 always radio active bug?
 

gonewild

Members
Apr 16, 2013
300
52
I use mostly wifi and I never had problems with wifi notification (whatsapp or email) on sleep mode, like delays or worse. Or it seems like this to my not expert eyes
 

Wrshek

Members
Jan 27, 2016
9
15
MK44.4 was also my absolutely favourite, but you can be sure that you wont go back again if you've tried a good working LP Rom. And indeed bugers last release seems to be the best so far.

I recommend you to do it like this:
  1. Make a Backup of your Apps with TitaniumBackup or a similar App and save all the files including your pictures etc. on your computer.
  2. Download and install MiFlashTool from >HERE< and M1chas "unified_single"-package from >THIS THREAD<
  3. Turn off your phone and restart it in fastboot mode (by pressing the power and the volume down button at the same time for several seconds)
  4. Connect your phone with your computer and refresh the flashtool app until your phone is shown
  5. Unpack the "aries_core_unified_single.zip" and start setting up the flashtool by clicking the down-arrow beside the browse button in the flashtool for selecting "advanced-mode"
  6. For the fast boot script choose the "flash_core.bat" in the main folder be sure that its NOT the "flash_partition_table_and_core.bat" when you run it the first time. Ignore the section "nvbootscript" in the menu and set up all the other files located in the "images folder" (when you click the browse button of the particular field there should be only one possible file to choose in the image folder).
  7. Flash it by clicking refresh and flash. Let your phone restart, shut it off again and turn on fastboot mode another time.
  8. Run the flash tool another time with the "flash_partition_table_and_core.bat".
  9. boot into recovery(which is TWRP now), recreate the filesystems for all partitions(system,data,cache,sdcard to ext4) in the wipe menu (go to the wipe menu, advanced wipe, select one of the mentioned partitions and select repair or change file system -> ext4, repeat it with all the mentioned partitions) After that reinstall your ROM -> bugers last hope rom.
  10. Finished.
I wrote it from memory so if you have any problems dont hesitate to ask maybe i've wrote something a bit vague. ;)
So i tried to make recomended istall procedure from the first post and i get error in MiFlash at step 6. "FAILED (remote: partition table doesn't exist)" any idea?
 

marvollo

Members
Jan 14, 2016
117
40
As I told previously last two things should be much better now. Wait for new version.
Great to see that you're happy ;)
on RC7 twitch problem still exists, this is tombstone from your RC7

And one time my phone was reboot themself
 

Attachments

  • tombstone_00.txt
    1.3 MB · Views: 498
Last edited:

gonewild

Members
Apr 16, 2013
300
52
Wipe data and cache, flash Rc7 and restore data backup. When the screen went to sleep after the first reboot, I couldn't power on again. Always black screen. Only removing battery make it restart but the problem is still there. Got back to rc6 backup
 
  • Like
Reactions: marvollo

marvollo

Members
Jan 14, 2016
117
40
Wipe data and cache, flash Rc7 and restore data backup. When the screen went to sleep after the first reboot, I couldn't power on again. Always black screen. Only removing battery make it restart but the problem is still there. Got back to rc6 backup
already have this bug, back to my rom again
 

Yurienu

Members
Jan 20, 2016
35
20
Hurgh, my phone keeps rebooting in RC7 after 30 seconds or so when I type phone code…
How can I get log for that?
Back to RC6 meanwhile…