MIUI 12.3 20.11.18


Do you like this MIUI version?


  • Total voters
    176
Status
Not open for further replies.

Iain_B

Members
Mar 25, 2013
417
67
You have described it so often in a really helpful way, why not put it together for a tutorial in the Question & Answer forum section? Then it doesn't always have to be repeated so often
I have thought about it. But ... Murphy's Law!
As soon as it's put together, TWRP will be resolved!! ;)

[Edit: Also It's not the official solution, even though it works. And I think that it may confuse as well, especially those not familar with Fastboot.]
 

-fluffy-

Members
Mar 9, 2020
174
40
@Iain_B
It's exactly the same thing for umi , cmi and lmi ..
The difference is that on lmi and cmi the twrp 0623 can be installed and worked with buttons or powermenu , twrp is accessible on those devices ..
With umi we can't enter twrp other way except by fastboot and the known command
..
Probably because of this issue reported , friend has umi and make the mistake to flash the twrp 0623 and not boot , so the error can't load authenticate boot.img is known when we flash the twrp and not boot ..
i also try installing the latest rom 20.11.18
an i didt it wiht twrp 1303
an it installed boot.img an twrp.img
after that i got error
an now it got hot because no matter what i didt it came wiht error 7 in twrp
an cut do nothing
i then to get back to my old rom 20.10.22
i fastboot flash boot boot.img from 20.10.22
restarted fastboot flashed my old twrp
fastboot flash recovery twrp.img
then fastboot boot twrp.img
niw i started in my old twrp
an i still hade my old rom 20.10.22 on so my phone didt start up again
 

Igor Eisberg

Developer
Staff member
Oct 6, 2016
4,152
322
1. Fullscreen gestures on Mi 10 for some reason do not work when using nova launcher. (using Fluid NG right now as an alternative but every reboot it reverts to buttons so i have to manually change it back every time i reboot)
2. Had some problems with magisk, but using default option in magiskhide props fixed that. See responses above
3. Dark mode breaks after reboot until manually toggled off and back on
4. Substratum isn't working at all, even for firefox, discord etc, apps just crash. Patching system launcher breaks the system also.
5. for some reason after restart my widget settings reset, but i didn't try clearing it's data yet. Working fine on my mi9se with miui12.1something
6. something else was annoying/not working but i forgot about it, maybe ill remember later and edit/reply
gpay gms patch works and i have added my card but never tried to pay with it yet.
1. Because they are integrated inside the stock launcher, and the legacy gestures were removed on Android 11 ROMs. Ask Xiaomi, I'm confused too.
4. Substratum was never designed or guaranteed to work with MIUI.

Got nothing to comment on the rest.

  • Can't see full screen navigation settings with Nova Launcher. I can in stable.
  • Can't switch previous app with gesture. I had that option before with both stock and custom launchers.
  • Full screen gesture settings placed to Home Screen section which is sad. It were on Additional Settings before.
  • Dark mode problems still continues. (3rd party app list shows up very late)
  • New privacy features are great.
1-3) Android 11? Read my reply to Barsoom here.
4) That's how Xiaomi implemented it, sadly. This is known and nothing we can do on our side.

I can't login to Wi-Fi it doesn't open page to login my device is redmi note 7
That's the bug report in screenshot
View attachment 32986
 
  • Like
Reactions: Barsoom

X3N0N

Members
Oct 16, 2020
2
3
Nice update great job! But I have one problem, when I go to twrp the system shows as 0mb because of the format that the data has I remember It was 2fb2f or something like that, I change It to FAT and then to EXT4 and It showed the internal storage but then I couldn't start the system. I think it's a problem with twrp or something I don't know how to fix It , also this error started when I updated my phone (mi 10) to this new version, anyways great job and try to fix It please!
 

Iain_B

Members
Mar 25, 2013
417
67
Nice update great job! But I have one problem, when I go to twrp the system shows as 0mb because of the format that the data has I remember It was 2fb2f or something like that, I change It to FAT and then to EXT4 and It showed the internal storage but then I couldn't start the system. I think it's a problem with twrp or something I don't know how to fix It , also this error started when I updated my phone (mi 10) to this new version, anyways great job and try to fix It please!
For the last few weeks there have been problems with Mi 10 (umi) which is also what I have, and TWRP (as well as with cmi & lmi). There has been much discussion here about all of the problems that people have been having. It looks as though you have been using the 'new' 3.4.0 TWRP. This is based on an old version of TWRP which does not decrypt your storage. This therefore also shows storage of 0 MB. I would strongly advise against trying to reformat this storage because you may lose any files, data, etc you may have stored. You will probably now have to do a Factory Reset to get back into it. The file system should be f2fs. Unfortunately the TWRP that you are using does not give that option.
Hopefully the Factory Reset will get you up and running again, and reformat the partitions to f2fs. If not, come back here for further instructions!
 
Last edited:

gkalen

Members
Oct 23, 2020
123
30
i also try installing the latest rom 20.11.18
an i didt it wiht twrp 1303
an it installed boot.img an twrp.img
after that i got error
an now it got hot because no matter what i didt it came wiht error 7 in twrp
an cut do nothing
i then to get back to my old rom 20.10.22
i fastboot flash boot boot.img from 20.10.22
restarted fastboot flashed my old twrp
fastboot flash recovery twrp.img
then fastboot boot twrp.img
niw i started in my old twrp
an i still hade my old rom 20.10.22 on so my phone didt start up again
If i understand well , because some parts of your post confused me , your phone don't startup because you have to format data probably to go back to 20.10.22 rom ..
 

josueafkaa

Members
Mar 15, 2020
55
20
redmi note 7 always after a restart activates silent mode alone, and I have to manually disable it always.
Besides that, the silent mode icon that appears on the right side of the screen, when I increase or decrease the volume, the icon is appearing in blue as if it were activated, but it is not
Screenshot_2020-11-21-22-03-28-202_com.android.settings.jpg
from time to time the phone vibrates out of nowhere, but it’s not notification or anything, it just activates the vibration engine once and nothing happens
 
Last edited:

Gonzalo12

Members
Jan 19, 2019
10
15
Hi, I have a question. When a device reaches the EOL state, which is the latest rom the stable one or the beta one?
 

josueafkaa

Members
Mar 15, 2020
55
20
Hi, I have a question. When a device reaches the EOL state, which is the latest rom the stable one or the beta one?
As far as I remember, the developers recommend using the stable rom, because any bugs or security updates will no longer be fixed or added
 

Bernd_with_MI4C

Members
Jan 8, 2017
32
20
Gonzalo12 said:


Hi, I have a question. When a device reaches the EOL state, which is the latest rom the stable one or the beta one?

This will usually be the dev version - for example, I'm waiting for a stable MIUI12 for the Redmi Note 5 Pro and therefore always have the dev version of MIUI12 installed on sold devices!
 

Keshow

Members
Jan 20, 2018
21
13
Good Morning.. I try to update from xiaomi.EU 11.11 to 18.11 weekly... But after install magsik from recovery.. The phone open then make restart and i can't use it... Any solution?

K20 pro

Magsik 20.4

App last updated

Recovery SHRP_v2.3_raphael-193417062020.zip
 
Last edited:

cris2d2

Members
Dec 31, 2016
55
20
Is anyone having problems with sms app Pulse SMS? On my Mi9TPro with latest xiaomi.eu weekly ROM, this app doesn't make a sound when it receives a notification, only vibrates. Every is set up properly, an existing sound (that works in other apps) is assigned to every notification channel, every proper permission is given. I have reinstalled many times the app but nothing changed.
This problem occurs only on MIUI ROMs, on AOSP ROMs it's working just fine.
 

Iain_B

Members
Mar 25, 2013
417
67
Good Morning.. I try to update from xiaomi.EU 11.11 to 18.11 weekly... But after install magsik from recovery.. The phone open then make restart and i can't use it... Any solution?
Which phone are you using?
Which recovery version did you use for updating ROM & Magisk?
Which version of Magisk?
 

geoorg

Members
Sep 28, 2020
311
57
Is anyone having problems with sms app Pulse SMS? On my Mi9TPro with latest xiaomi.eu weekly ROM, this app doesn't make a sound when it receives a notification, only vibrates. Every is set up properly, an existing sound (that works in other apps) is assigned to every notification channel, every proper permission is given. I have reinstalled many times the app but nothing changed.
This problem occurs only on MIUI ROMs, on AOSP ROMs it's working just fine.
Try going to
app info->Notification
And turn on "allow sound"
 

madvillain

Members
Jun 1, 2020
14
15
1. Fullscreen gestures on Mi 10 for some reason do not work when using nova launcher. (using Fluid NG right now as an alternative but every reboot it reverts to buttons so i have to manually change it back every time i reboot)
2. Had some problems with magisk, but using default option in magiskhide props fixed that. See responses above
3. Dark mode breaks after reboot until manually toggled off and back on
4. Substratum isn't working at all, even for firefox, discord etc, apps just crash. Patching system launcher breaks the system also.
5. for some reason after restart my widget settings reset, but i didn't try clearing it's data yet. Working fine on my mi9se with miui12.1something
6. something else was annoying/not working but i forgot about it, maybe ill remember later and edit/reply
gpay gms patch works and i have added my card but never tried to pay with it yet.
Thanks for all those informations but you're using mi 10 and not mi note 10 (tucana) ?
 

Allessa

Members
Nov 18, 2020
10
5
Successfully managed to get from last week's build to this one keeping all my data as well as my installed 0623 TWRP.

There's a lil problem remaining:
Have had my Magisk Manager hidden. By the need to reinstall Magisk after flashing the ROM, I obviously got a second Magisk Manager installed. How to deal with that? How to get Magisk back to a proper clean state without losing GPay and Banking Apps activation?
 

X3N0N

Members
Oct 16, 2020
2
3
For the last few weeks there have been problems with Mi 10 (umi) which is also what I have, and TWRP (as well as with cmi & lmi). There has been much discussion here about all of the problems that people have been having. It looks as though you have been using the 'new' 3.4.0 TWRP. This is based on an old version of TWRP which does not decrypt your storage. This therefore also shows storage of 0 MB. I would strongly advise against trying to reformat this storage because you may lose any files, data, etc you may have stored. You will probably now have to do a Factory Reset to get back into it. The file system should be f2fs. Unfortunately the TWRP that you are using does not give that option.
Hopefully the Factory Reset will get you up and running again, and reformat the partitions to f2fs. If not, come back here for further instructions!
Don't worry nothing hapenned to my phone because I made a backup, I also tried to do a Factory Reset but It showed some errors like unable to mount system partition, unable to format data... Then I reboot the system and nothing hapenned I had all the applications and nothing changed. And yes the twrp version is 4.3.0, I had an old version of twrp but it has been updated to the new one with this rom update.
 

Allessa

Members
Nov 18, 2020
10
5
Successfully managed to get from last week's build to this one keeping all my data as well as my installed 0623 TWRP.

There's a lil problem remaining:
Have had my Magisk Manager hidden. By the need to reinstall Magisk after flashing the ROM, I obviously got a second Magisk Manager installed. How to deal with that? How to get Magisk back to a proper clean state without losing GPay and Banking Apps activation?
Answering to my own question (for the case somebody else has the same problem):
The old hidden Manager did not even start any more. So I simply uninstalled this one and opened the newly installed one. This one asked me for downloading full Magisk Manager, what I confirmed, then I checked the settings there - only the Hide Manager needed to be redone. Nothing else. The rest of the old configuration seems to have survived.
 
  • Like
Reactions: Iain_B
Status
Not open for further replies.