Miui 10 Neue Strings


Dec 5, 2016
85
19
20
Also nicht Box, sondern Gerät?

Code:
  <string name="fast_connect_device_box">Gerät/Box</string>

  <string name="fast_connect_device_box_name">%1$s Gerät/Box</string>
 
Dec 5, 2016
85
19
20
Code:
  <string name="bluetooth_connected">%1$s verbunden</string>
string name="bluetooth_connected, gibt es 8x, davon 2x %1$s

2x entfernt ;)
 
Last edited:
Likes: BodoT
Apr 6, 2018
42
6
20
Code:
  <string name="bluetooth_connected">%1$s verbunden</string>
string name="bluetooth_connected, gibt es 8x, davon 2x %1$s

2x entfernt ;)
Danke, bei verbundenem Bluetooth-Gerät ist jetzt alles super. Spannend wird es während eines Verbindungs- bzw. Trennungsvorgangs.

In beiden Fällen erscheint in den BT-Einstellungen:
Code:
%1$s verbunden (kein Telefon)
Hier sehe ich gleich drei Probleme:
1. mal wieder der altbekannte Platzhalter
2. Was will mir die Meldung (speziell der "Kein Telefon"-Part) sagen?
3. warum kommt beim Verbinden und beim Verbindungsverlust (wenn ich das BT-Headset ausschalte) die gleiche Meldung?

Fragen über Fragen. Hätte nicht gedacht, dass etwas so einfach vermutetes so kompliziert sein kann.

Kleiner Nachtrag, weil ich weiter nachgeforscht habe:
Den Eintrag gibt es gleich in sieben verschiedenen xml-Dateien. Warum ist so vieles zigfach vorhanden?
Der Tag heißt (meist): bluetooth_connected_no_headset
Warum also heißt es im Deutschen dann "(kein Telefon)"? Ein Headset ist kein Telefon.
 
Last edited:
Apr 6, 2018
42
6
20
eine Kleinigkeit habe ich gerade noch entdeckt. In den Einstellungen gibt es einen Punkt "Wichtige Sicherheitshinweise". In diesen Hinweisen wird Zubehör einmal falsch geschrieben: Zubehöt

Spannenderweise finde ich diesen String nicht im Git.
 
Dec 5, 2016
85
19
20
<string name="bluetooth_connected">Verbunden</string>
<string name="bluetooth_connected_no_a2dp">Verbunden (keine Medien)</string>
<string name="bluetooth_connected_no_headset">Verbunden (kein Telefon)</string>
<string name="bluetooth_connected_no_headset_no_a2dp">Verbunden (keine Medien oder Telefon)</string>
<string name="bluetooth_connected_no_map">Verbunden (kein Nachrichtenzugriff)</string>

<string name="bluetooth_connected">Connected</string>
<string name="bluetooth_connected_no_a2dp">Connected (no media)</string>
<string name="bluetooth_connected_no_headset">Connected (no phone)</string>
<string name="bluetooth_connected_no_headset_no_a2dp">Connected (no phone or media)</string>
<string name="bluetooth_connected_no_map">Connected (no message access)</string>
 
Dec 5, 2016
85
19
20
eine Kleinigkeit habe ich gerade noch entdeckt. In den Einstellungen gibt es einen Punkt "Wichtige Sicherheitshinweise". In diesen Hinweisen wird Zubehör einmal falsch geschrieben: Zubehöt

Spannenderweise finde ich diesen String nicht im Git.
stimmt, ich auch nicht
auf meinem Gerät aber auch nicht, wo steht das da?
 
Last edited:
Dec 5, 2016
85
19
20
Danke, bei verbundenem Bluetooth-Gerät ist jetzt alles super. Spannend wird es während eines Verbindungs- bzw. Trennungsvorgangs.

In beiden Fällen erscheint in den BT-Einstellungen:
Code:
%1$s verbunden (kein Telefon)
Hier sehe ich gleich drei Probleme:
1. mal wieder der altbekannte Platzhalter
2. Was will mir die Meldung (speziell der "Kein Telefon"-Part) sagen?
3. warum kommt beim Verbinden und beim Verbindungsverlust (wenn ich das BT-Headset ausschalte) die gleiche Meldung?

Fragen über Fragen. Hätte nicht gedacht, dass etwas so einfach vermutetes so kompliziert sein kann.

Kleiner Nachtrag, weil ich weiter nachgeforscht habe:
Den Eintrag gibt es gleich in sieben verschiedenen xml-Dateien. Warum ist so vieles zigfach vorhanden?
Der Tag heißt (meist): bluetooth_connected_no_headset
Warum also heißt es im Deutschen dann "(kein Telefon)"? Ein Headset ist kein Telefon.
weil im engl. string halt phone steht, da wurde das ja schon falsch ins engl .übersetzt
und da auch
<string name="bluetooth_connected_no_headset">已连接(无手机)

Zu gut deutsch, verbunden ja aber nicht mit einem Headset, sondern mit einem Telefon ?
 
Last edited:
Apr 6, 2018
42
6
20
na sowas. Vielleicht Android 6-spezifisch?

View attachment 22117
wo ich gerade gelangweilt meinen eigenen Screenshot betrachte:
"Total" ist (in dem Kontext) Englisch und sollte im Deutschen "Gesamt" heißen.

Nachtrag:
gleiches gilt natürlich auch für die ganzen Anzeigen im oberen Bereich:
Screen Size
Resolution
Battery Capacity
Rear Camera
und inches sollte Zoll sein
 
Last edited:
Dec 5, 2016
85
19
20
wo ich gerade gelangweilt meinen eigenen Screenshot betrachte:
"Total" ist (in dem Kontext) Englisch und sollte im Deutschen "Gesamt" heißen.

Nachtrag:
gleiches gilt natürlich auch für die ganzen Anzeigen im oberen Bereich:
Screen Size
Resolution
Battery Capacity
Rear Camera
und inches sollte Zoll sein
Das du das alles so feststellst ist ja schön, aber

Screen Size
Resolution
Battery Capacity
Rear Camera
und inches

das wurde übersetzt und kommt jetzt aber vom Server.
 

BodoT

Members
Apr 6, 2018
42
6
20
Hallo Hen Ry,

in deinem Screenshot müsste "Anschließen" groß geschrieben werden und vor dem etc. kein Komma stehen (ist ja schließlich ein "und" drin enthalten. Spannenderweise finde ich beides nicht in Github. Bin allerdings etliche Texte mal durchgegangen und habe eine Reihe Pull Requests gestellt.

Mysterien über Mysterien.

Gruß
Bodo
 
Dec 5, 2016
85
19
20
Problem erstmal gesichtet, nur noch zusammenpuzzeln.
Beim MusicMan scheint da textlich wohl was aus dem digitalen Ruder zu laufen. Bist du da dran?
das kommt da hin

Mini BT MusicMan [SBC]
Verbindung aktiv (Medien)


- Connected in use
- Connected in use (media)
- Connected in use (mobile phone)
 
Last edited:
Dec 5, 2016
85
19
20
Ist vermutlich von Gerät zu Gerät verschieden, man könnte jetzt %1$s weglassen, dann würde bei allen 'Verbindung/Verbunden' stehen und

<item>aktiv</item>
<item>aktiv (Medien)</item>
<item>aktiv (Telefon)</item>

würde dann nicht mehr erscheinen.

Bei mir passt das, wie in den Screenshots darüber.
 
Apr 6, 2018
42
6
20
Ist vermutlich von Gerät zu Gerät verschieden, man könnte jetzt %1$s weglassen, dann würde bei allen 'Verbindung/Verbunden' stehen und

<item>aktiv</item>
<item>aktiv (Medien)</item>
<item>aktiv (Telefon)</item>

würde dann nicht mehr erscheinen.

Bei mir passt das, wie in den Screenshots darüber.
theoretisch müsste man sich daran orientieren, was im Englischen dort steht - wenn wir davon ausgehen können, dass es dort richtig ist. Schwierig daran ist, dass man sich schlecht Deutsch und Englisch "nebeneinander" ansehen kann. Auch, weil nirgendwo das Englische Original verlinkt ist (wäre cool im ersten Beitrag).
 
Dec 5, 2016
85
19
20
Das Original ist nicht englisch sondern chinesisch, da fangen die Probleme schon an.
Erste Übersetzungsfehler von cn -> en und dann -> de.

Ändere doch mal die Sprache, egal welche und schaue Dir das Ergebnis an.

string (Verbindung) + array (%1$s) = Verbindung, In Verwendung (Medien) = Verbindung aktiv (Medien)

strings.xml
1. Zeile: Orginal übersetzt mit Google
2. Zeile: Übersetzt ins englische, schon ein Unterschied zu sehen
3. Zeile: Aktuell xiaomi.eu

Code:
Bluehooth.apk
<string name="bluetooth_connected">蓝牙音频已连接</string>   Bluetooth audio is connected
<string name="bluetooth_connected">Bluetooth audio connected</string>
<string name="bluetooth_connected">Bluetooth Audio verbunden</string>

EmergencyInfo.apk
<string name="bluetooth_connected">已连接%1$s</string>   Connected to %1$s
<string name="bluetooth_connected">Connected%1$s</string>
<string name="bluetooth_connected">Verbunden</string>

MiuiBluetooth.apk
<string name="bluetooth_connected">已连接</string>   connected
<string name="bluetooth_connected">Paired</string>
<string name="bluetooth_connected">Verbunden</string>

PackageInstaller.apk
<string name="bluetooth_connected">已连接%1$s</string>   Connected to %1$s
<string name="bluetooth_connected">Connected%1$s</string>
<string name="bluetooth_connected">Verbunden</string>

MiuiSystemUI.apk
<string name="bluetooth_connected">已连接%1$s</string>   Connected to %1$s
<string name="bluetooth_connected">Connected %1$s</string>
<string name="bluetooth_connected">Verbunden</string>

Settings.apk
<string name="bluetooth_connected">已连接%1$s</string>   Connected to %1$s
<string name="bluetooth_connected">Connected %1$s</string>
<string name="bluetooth_connected">Verbindung %1$s</string>

StorageManager.apk
<string name="bluetooth_connected">已连接%1$s</string>   Connected to %1$s
<string name="bluetooth_connected">Connected%1$s</string>

Telecom.apk
<string name="bluetooth_connected">已连接%1$s</string>   Connected to %1$s
<string name="bluetooth_connected">Connected%1$s</string>
<string name="bluetooth_connected">Verbunden</string>

  <string-array name="bluetooth_audio_active_device_summaries">
    <item></item>
    <item>aktiv</item>
    <item>aktiv (Medien)</item>
    <item>aktiv (Telefon)</item>

TeleService.apk
<string name="bluetooth_connected">已连接%1$s</string>   Connected to %1$s
<string name="bluetooth_connected">Connected%1$s</string>
<string name="bluetooth_connected">Verbunden</string>

Traceur.apk
<string name="bluetooth_connected">已连接%1$s</string>   Connected to %1$s
<string name="bluetooth_connected">Connected%1$s</string>

Original arrays.xml
   <string-array name="bluetooth_audio_active_device_summaries">
        <item></item>
        <item>,使用中</item>   In Verwendung/aktiv
        <item>,使用中(媒体)</item>  In Verwendung/aktiv (Medien)
        <item>,使用中(手机)</item>  In Verwendung/aktiv (Telefon)

englische Übersetzung
    <string-array name="bluetooth_audio_active_device_summaries">
        <item></item>
        <item>, active</item>
        <item>, active (media)</item>
        <item>, active (phone)</item>

deutsche Übersetzung
  <string-array name="bluetooth_audio_active_device_summaries">
    <item></item>
    <item>aktiv</item>
    <item>aktiv (Medien)</item>
    <item>aktiv (Telefon)</item>
Bei mir funktioniert es ja so...
 
Last edited:
Apr 6, 2018
42
6
20
Hallo Hen Ry,

vermutlich fangen die Probleme noch eine Stufe früher an, da die meisten Texte aus dem Stock Android kommen und wohl erstmal aus den englischen Stock-Android und werden von dort für MIUI ins Chinesische übersetzt wurden ... aua

Habe für dieses entsprechende BT-Gerät mal auf Englisch gestellt und dort funktioniert es 1a ohne den Platzhalter (was zu erwarten war). Die entscheidende Frage ist natürlich, welche der vielen Texte angepasst werden müssen, damit nicht wieder andere Zeilen kaputt gehen. Womöglich ist es sinnvoll, sich am Chinesischen zu orientieren.
 
Last edited: