No Gps At All Since 7.8.31

Discussion in 'Xiaomi Mi 5' started by egold70, Oct 4, 2017.

  1. egold70

    egold70Members

    May 13, 2016
    227
    67
    50
    Male
    Never had real GPS issues in my Mi5 3/64 in almost year of excellent service this device brought.
    Flashed every weekly xiaomi.eu build without problems.
    Last time GPS worked was ironically on august 31, the same day build went live next morning and was supposed to "fix" GPS for some people. For me it caused no GPS functionality at all.
    No nav app can ever get fix, on CIT GPS test there are 0 satellites and no fix no matter how long checked. When noticed this for the first time I managed somehow by switching location off, reboot and cache wipe to restore almost instant fix in hardware test. Thought that this is point software glitch but the same situation resumed several days later when needed GPS again.
    Since then I`ve tried the following:
    Wipe data in twrp, format data+internal storage, install same xiaomi.eu - no change,
    Fastboot flash latest global beta-no GPS,
    Clean flashed 8.5.3 global stable-no satellites again which lead me to believe it`s hardware issue.
    Decided to try Lineage OS and surprisingly GPS status & toolbox found 20+ satellites, in MIUI on same app there were always 0/0. Despite that "progress" the app and any nav app still failed to get fix, on GPS status there were always 0 connected satellites with 24, 18 or 15 available.
    Then I flashed latest MM build 6.11.10 to see if this improves but again there were 0/0 satellites in MIUI, tried also several different older firmwares without success, flashed also Mi globe rom to just get same result.
    All the above made me believe this is actually Xiaomi/MIUI software issue, I see no other explanation to the facts mentioned: same 0 satellites was replaced once with instant fix by software means and many satellites visible in Iineage OS, beside that every app checks and reports GPS sensor as present an functional.
    Is anyone else experiencing same issue? I`ve read about 0 satellites in CIT hardware test but did someone actually managed to fix this and if yes how?
    Haven`t tried China builds but don`t think that would make difference. My device was never rooted and everything else is working perfectly.
    IMO the probability for hardware failure is low so I would gladly consider any method to restore GPS.
     
  2. Sebastián Valencia

    Oct 12, 2017
    3
    0
    1
    Male
    yes, I have the same problem, since my phone started with GPS issues with the official multilanguaje rom, then I flashed the stable rom of xiaomi.eu and it started to work properly, but then I decided to try MIUI 9 with a xiaomi,eu rom, and everything got screwed, not even a little connection to satellite, nothing, sometimes it just locate me in the middle of the african ocean, very sad, I think I'll try going back to the stable version of MIUI 8 and wait to see if there's a solution for this problem in order that GPS is essential for me
     
  3. MaxB1978

    MaxB1978Members

    Aug 26, 2016
    1
    0
    11
    Male
    Same problem... Back to 8.5.3
     
  4. egold70

    egold70Members

    May 13, 2016
    227
    67
    50
    Male
    Unfortunately going back to 8.5.3 does not fix my GPS, 0/0 always. only in lineage the phone sees 24-25 satellites but still fails to connect to any of them
     
  5. peroni

    peroniMembers

    Sep 28, 2017
    3
    1
    5
    When you start gps status or any other application using GPS, does the tiny GPS icon show in the notification bar?
     
  6. Sebastián Valencia

    Oct 12, 2017
    3
    0
    1
    Male
    I was afraid about that, sucks too much to have to change MIUI 9, I loved it and the speed but yeah I cant live without GPS. Hope one day they fix that problem, but in some comments on the last rom release a lot of people was saying that their mi5 was alright with the GPS thing
     
  7. debianus

    debianusMembers

    Nov 26, 2013
    43
    19
    18
    Male
    Spain
  8. egold70

    egold70Members

    May 13, 2016
    227
    67
    50
    Male
    Most of the times yes, occasionally there is no icon but close/open the app again brings it
    7.10.12 which also "optimizes the GPS" did not change a thing for me: 0/0 satellites in GPS status and hardware test
     
  9. peroni

    peroniMembers

    Sep 28, 2017
    3
    1
    5
    Ok, the reason I said that, for me a weird combination of factors caused an issue with starting GPS unless I was in flight mode. Eventually flashing a different modem firmware (NON-HLOS.bin) solved it but I had to try a few of them. There is a collection over at xda.
    No problem since.
     
  10. egold70

    egold70Members

    May 13, 2016
    227
    67
    50
    Male
    Thank you, haven`t tried yet in flight mode but will definitely do.
    Meanwhile I flashed again Lineage as the suggested app by @debianus didn`t helped in MIUI, that`s the result
    Screenshot_20171013-173405.png
    These probably describe satellites but the phone fails to connect to any of them no matter what
    Screenshot_20171013-174229.png
     
  11. egold70

    egold70Members

    May 13, 2016
    227
    67
    50
    Male
    #11egold70,Oct 13, 2017
    Last edited: Oct 13, 2017
    Do you remember by chance which modem version worked for you? I already tried several different firmwares(they content the modem, don`t they?) without success
     
  12. egold70

    egold70Members

    May 13, 2016
    227
    67
    50
    Male
    I didn`t believe but the issue appears to be hardware
    Tried in flight mode in Lineage but after reset without network there are always 0 satellites found, obviously the 20+ are from A-GPS data and not from scan
    Flashed 7.10.12 china beta fastboot with clean all and still 0 satellites
    Enough dealing with that, unfortunately the device will go to lab for check up
     
  13. egold70

    egold70Members

    May 13, 2016
    227
    67
    50
    Male
    Last update, the hardware is OK, something is really f***ed up with this phone. The phone heats and depletes the battery while searching for GPS
    On clean flashed global beta 7.10.12 and while playing with GPS reset app I get lock once within 5 sec, being so surprised and even shocked I forget to SC this but it showed 6/16 satellites and my correct address and position on map, then out of the sudden the satellites count changed back to 0/0 as it was always in the last month and nothing more...weird
    I do believe that the problem is in wrong "connection" between hardware and OS, don`t know if its drivers, firmware or what. The only idea haven`t checked yet is flash with newer version of miflash, I`m using 2016.08.30
     

Share Our Site