In Progress MIUI 2.3.23 Huawei U8860 Honor Bootloop

Discussion in 'Bugs' started by kaefert, Mar 23, 2012.

  1. kaefert

    kaefertMembers

    Mar 18, 2012
    19
    0
    11
    Male
    The following 3 versions that I managed to download from the release threads at different times all bootloop, here are the dmesg / logcat outputs:

    MD5(miuiandroid_Honor-2.3.23.zip)= 5665cd65dfaa2236cc2c5ec889792463
    dmesg output: http://pastebin.com/adcfVchQ

    MD5(miuiandroid_Honor-2.3.23.zip)= 56de0032581336f00a5c44a7de383ae7
    dmesg output: http://pastebin.com/SygYMtYV

    MD5(miuiandroid_Honor-2.3.23.zip)= b97b591bbcf3a73cb716aaec159f6ab3
    logcat output: http://pastebin.com/0PHeLHWG
    dmesg output: http://pastebin.com/bEWPkjMp

    EDIT: Bug has been fixed in the new release 2.3.30
    logcat output: http://pastebin.com/PpYaBRjj
     
  2. iBotPeaches

    iBotPeachesScript Gatekeeper

    Oct 31, 2011
    3,811
    1,112
    335
    Kansas
    The ROM was pulled due to bugs. Please revert to your previous build and wait until these are solved.
     
  3. kaefert

    kaefertMembers

    Mar 18, 2012
    19
    0
    11
    Male
    "previous build" ? as far as I know this was the first miuiandroid.com release for the Huawei U8860 Honor. The ROM I was using previously (and which I restored from the nandroid backup I made before flashing this release) Is a chinese unofficial MIUI build that I downloaded from here: http://115.com/file/dpplk412#u8860-MIUI4.0-geno.zip
    But now I guess I will try out the new official chinese MIUI release from here: http://bigota.d.miui.com/2.3.23/miui_Honor_2.3.23_20cedef797_4.0.zip

    But still - Thanks for the answer!
     
  4. kaefert

    kaefertMembers

    Mar 18, 2012
    19
    0
    11
    Male
    Okey so I've found that there is a third version of the file "miuiandroid_Honor-2.3.23.zip" with the md5sum = b97b591bbcf3a73cb716aaec159f6ab3

    I downloaded and flashed this but it still doesn't get past the golden bootanimation-logo. I've also read up about dmesg and logcat and have learned that those aren't the same..

    sorry for only posting the dmesg kernel output and not the output of the android logcat logging system for the last two versions.

    I've tried to use http://logcat.miuiandroid.com/ for uploading it but it allows no more than 10000 chars, which is not enough to get to the part where it starts looping.
    Therefore I used pastebin again:
    logcat: http://pastebin.com/0PHeLHWG
    dmesg: http://pastebin.com/bEWPkjMp
     
  5. iBotPeaches

    iBotPeachesScript Gatekeeper

    Oct 31, 2011
    3,811
    1,112
    335
    Kansas
    MD5(miuiandroid_Honor-2.3.23.zip)= b97b591bbcf3a73cb716aaec159f6ab3

    That version has been shown to work by testers. Have you tried wiping dalvik and possibly a full wipe when flashing it? You might have out of date jar files which would explain the boot loop.
     
  6. kaefert

    kaefertMembers

    Mar 18, 2012
    19
    0
    11
    Male
    hmm, I already restored my backup when I got your answer via mail. Since I was not sure if I did a full wipe I redid the whole procedure again:
    -) First wipe data & cache from recovery menu
    -) then flash zip file.

    --> gives me a bootloop with the dmesg and logcat output I linked in my previous post already.
    So either your huawei honor testers did something different than I did, or there are some different versions of the huawei honor?..
     
  7. snooze

    snoozeMembers

    Mar 25, 2012
    3
    0
    11
    Male
    I have the same problem. tried everything:(
     
  8. MarkHUK

    MarkHUKFounder
    Staff Member

    i need to find someone with the device willing to go through some testing.
     
  9. kaefert

    kaefertMembers

    Mar 18, 2012
    19
    0
    11
    Male
    I have the device and I am willing to test for you :) just tell me what to do (but not for the next 8 hours I'm gonna go to sleep now)
     
  10. snooze

    snoozeMembers

    Mar 25, 2012
    3
    0
    11
    Male
    Any luck getting it fixed??:)
     
  11. MarkHUK

    MarkHUKFounder
    Staff Member

    need logcat of error when booting?
     
  12. kaefert

    kaefertMembers

    Mar 18, 2012
    19
    0
    11
    Male
    have you looked at my post? Did I do something wrong, or what can I do to make it useful?
    http://pastebin.com/0PHeLHWG
     
  13. MarkHUK

    MarkHUKFounder
    Staff Member

    Need a LOGCAT not DMESG if possible please kaefert.

    Thanks,

    Mark
     
  14. kaefert

    kaefertMembers

    Mar 18, 2012
    19
    0
    11
    Male
  15. MarkHUK

    MarkHUKFounder
    Staff Member

    Thanks, need a bit of time to go read through these, I'm not giving you an ETA as thats unfair to me and to you.

    Thanks for the logs it will help track down the problem. I've moved the bug status to 'In progress'

    Mark
     
  16. kaefert

    kaefertMembers

    Mar 18, 2012
    19
    0
    11
    Male
    No pressure, take your time! I'm happy for results whenever they come :) Thanks for developing this great ROM for us!
     
  17. MarkHUK

    MarkHUKFounder
    Staff Member

    Ok so when it deodexed it didn't do it properly. I'm going to look further into the issue but this logcat was VERY helpful.

    Thanks again kaefert.
     
  18. kaefert

    kaefertMembers

    Mar 18, 2012
    19
    0
    11
    Male

Share Our Site