Permissions Issue (particularly for Google, Google Translate)


fdmx7

Members
Mar 11, 2023
1
3
Recently, my Redmi Note 10 Pro, updated to MIUI 14 (xiaomi.eu_multi_HMNote10Pro_V14.0.1.0.TKFMIXM_v14-13). Ever since then, I wasn't able to translate picture from my gallery because it seems like the translate app can't access it(?). In other words, its asking for permission to access the gallery. Thing is, it has access.

When I tap the Open Settings button, instead of bringing me to the Translate app's settings/ permission, it goes directly to the Google app, in which there is no way to enable or disable any kind of permission.

The Google app, itself, also cannot access the gallery. I am certain this only happened after updating because I am using Translate everyday, and other apps also asked for permissions again, such as Messenger, but those were allowed with no problem.

Images for context:
Here is what Translate is saying:
1678574707372.jpeg


And then, when I tap the 'Go to Settings', it goes to:
Screenshot_2023-03-11-17-42-02-078_com.miui.securitycenter.jpg


As you can see, no permissions. And here is Translate's actual settings:
Screenshot_2023-03-11-17-42-17-996_com.miui.securitycenter.jpg


I can't find a way to solve this. Any help would be great since I really need the Translate app. I'm in a foreign country. Sorry if I did anything wrong, first time posting in a forum.

Thanks!
 
I had a similar issue with Google Messages asking for a permission it already had in last week's dev build on my pair of Poco F3s.
Updating Google Play Services using the latest appropriate build from apkmirror fixed it.
Just make sure you take a good look at the app version you're running and find the suitable match for architecture, dpi, signature etc. Worst case you can uninstall the update to get back to where you started since Play Services is a system app.
 
We had the same problem and I able to fix mine with the following steps:

1. Go to settings > Apps > Manage apps
2. Search for lens > permission
3. Uncheck the following
•access files & documents
•access photos and videos
• access audio files
4. Go to Google search bar and press lens or Google translate and press camera, a pop up message will appear asking for permission just allow and your done.
 

Attachments

  • Screenshot_2023-05-01-20-02-35-944_com.miui.home-edit.jpg
    Screenshot_2023-05-01-20-02-35-944_com.miui.home-edit.jpg
    127.4 KB · Views: 310
  • IMG_20230501_200446.jpg
    IMG_20230501_200446.jpg
    116.3 KB · Views: 217
  • Screenshot_2023-05-01-20-05-31-500_com.google.android.googlequicksearchbox-edit.jpg
    Screenshot_2023-05-01-20-05-31-500_com.google.android.googlequicksearchbox-edit.jpg
    800.3 KB · Views: 201
Recently, my Redmi Note 10 Pro, updated to MIUI 14 (xiaomi.eu_multi_HMNote10Pro_V14.0.1.0.TKFMIXM_v14-13). Ever since then, I wasn't able to translate picture from my gallery because it seems like the translate app can't access it(?). In other words, its asking for permission to access the gallery. Thing is, it has access.

When I tap the Open Settings button, instead of bringing me to the Translate app's settings/ permission, it goes directly to the Google app, in which there is no way to enable or disable any kind of permission.

The Google app, itself, also cannot access the gallery. I am certain this only happened after updating because I am using Translate everyday, and other apps also asked for permissions again, such as Messenger, but those were allowed with no problem.

Images for context:
Here is what Translate is saying:
View attachment 46691

And then, when I tap the 'Go to Settings', it goes to:
View attachment 46692

As you can see, no permissions. And here is Translate's actual settings:
View attachment 46693

I can't find a way to solve this. Any help would be great since I really need the Translate app. I'm in a foreign country. Sorry if I did anything wrong, first time posting in a forum.

Thanks!
I have the same issue with Google lens and none of these fixes solved my problem. Any other suggestions?

found out this issue recently, not sure how long it has been like this. But i did fixed it.

1) Get the latest google app apk from apkmirror (yes there's many versions of the app, read the FAQ, even i couldn't fully understand it. I only know i probably had to install the arm version on my Poco F3).
2) Next, copy it over to your phone.
3) get xiaomiadbfastboottools (apparently the original github is down, so refer here
To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
). Once you get it up and running, uninstall the google apk from said tool.
4) install the latest google apk you copied over on your phone.
5) open google app, go to the camera icon to open up lens, in which it will now ask for camera permissions, and gallery permissions, enable it and voila.